HDU3853-LOOPS(概率DP求期望)

LOOPS

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 125536/65536 K (Java/Others)
Total Submission(s): 1864    Accepted Submission(s): 732


Problem Description
Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl).

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS.

The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)!
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS.




 

Input
The first line contains two integers R and C (2 <= R, C <= 1000).

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces.

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them).

You may ignore the last three numbers of the input data. They are printed just for looking neat.

The answer is ensured no greater than 1000000.

Terminal at EOF


 

Output
A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS.

 

Sample Input
 
   
2 2 0.00 0.50 0.50 0.50 0.00 0.50 0.50 0.50 0.00 1.00 0.00 0.00
 

Sample Output
 
   
6.000
 

  题意:有R*C个格子,一个家伙要从(0,0)走到(R-1,C-1) 每次仅仅有三次方向,各自是不动,向下,向右,告诉你这三个方向的概率,以及每走一步须要耗费两个能量,问你走到终点所须要耗费能量的数学期望:

思路:非常裸的概率DP求期望,仅仅是有一个坑点要注意,就是当分母为0的时候,浮点数仅仅会出现NAN,而不会像整形那样报RE!

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;
const int maxn =  1000+10;
const int dx[3] = {0,0,1};
const int dy[3] = {0,1,0};
const double eps = 1e-8;
double p[maxn][maxn][3];
int r,c;
double dp[maxn][maxn];
bool isok(int x,int y){
    return x>=0&&x<r && y>=0&&y <c &&!(x==r-1&&y==c-1);
}
int main(){

    while(~scanf("%d%d",&r,&c)){
        for(int i = 0; i < r; i++){
            for(int j = 0; j < c; j++){
                for(int k = 0; k < 3; k++){
                    scanf("%lf",&p[i][j][k]);
                }
            }
        }
        dp[r-1][c-1] = 0.0;
        for(int i = r-1; i >= 0; i--){
            for(int j = c-1; j >= 0; j--){
                double t = 2.0;
                for(int k = 1; k < 3; k++){
                    int xx = i + dx[k];
                    int yy = j + dy[k];
                    if(isok(xx,yy)){
                        t += dp[xx][yy]*p[i][j][k];
                    }
                }
                if(fabs(1-p[i][j][0])<eps) dp[i][j] = 0;
                else dp[i][j] = t/(1-p[i][j][0]);

            }
        }
        printf("%.3lf\n",dp[0][0]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值