Milk Pails(BFS)

Milk Pails

时间限制: 1 Sec  内存限制: 64 MB
提交: 16  解决: 4
[提交][状态][讨论版]

题目描述

Farmer John has received an order for exactly M units of milk (1≤M≤200) that he needs to fill right away. Unfortunately, his fancy milking machine has just become broken, and all he has are two milk pails of integer sizes X and Y (1≤X,Y≤100) with which he can measure milk. Both pails are initially empty. Using these two pails, he can perform up to K of the following types of operations (1≤K≤100):

- He can fill either pail completely to the top.

- He can empty either pail.

- He can pour the contents of one pail into the other, stopping when the former becomes empty or the latter becomes full (whichever of these happens first).

Although FJ realizes he may not be able to end up with exactly M total units of milk in the two pails, please help him compute the minimum amount of error between M and the total amount of milk in the two pails. That is, please compute the minimum value of |M−M′| such that FJ can construct M′ units of milk collectively between the two pails.

输入

The first, and only line of input, contains X, Y, K, and M.

输出

Output the smallest distance from M to an amount of milk FJ can produce.

样例输入

14 50 2 32

样例输出

18
【分析】这跟昨天的 母亲的牛奶那题特别像,两个瓶,一开始都为空,有三种操作,将一个瓶灌满,讲一个瓶清空,然后就是将一个瓶网另一个瓶倒,直到到完
或者到满。将昨天的代码稍微改了一下。
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <time.h>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#define inf 0x3f3f3f3f
#define mod 1000000007
typedef long long ll;
using namespace std;
const int N=210;
int n,dp[N],len;
int w[N][N];
int g[3];
int a,b,c;
int X,Y,K,M;
set<int>p;
int minn=inf;
struct man {
    int x,y;
    int step;
};

void bfs() {
    w[0][0]=1;
    queue<man>q;
    man s;
    s.x=0;
    s.y=0;
    s.step=0;
    q.push(s);
    while(!q.empty()) {
        man t=q.front();
        q.pop();
        minn=min(minn,abs((t.x+t.y)-M));
        if(t.step==K)continue;
        int f[3];
         f[0]=t.x;
            f[1]=t.y;
         if(!w[f[0]][0]){man kk;kk.x=f[0];kk.y=0;kk.step=t.step+1;w[f[0]][0]=1;q.push(kk);}
         if(!w[f[0]][g[1]]){man kk;kk.x=f[0];kk.y=g[1];kk.step=t.step+1;w[f[0]][g[1]]=1;q.push(kk);}
         if(!w[0][f[1]]){man kk;kk.x=0;kk.y=f[1];kk.step=t.step+1;w[0][f[1]]=1;q.push(kk);}
         if(!w[g[0]][f[1]]){man kk;kk.x=g[0];kk.y=f[1];kk.step=t.step+1;w[g[0]][f[1]]=1;q.push(kk);}
        for(int i=0; i<2; i++) {
            f[0]=t.x;
            f[1]=t.y;
            if(f[i]==0)continue;
            for(int j=0; j<2; j++) {
                f[0]=t.x;
                f[1]=t.y;
                man k;
                if(i==j||f[j]==g[j])continue;
                if(f[i]+f[j]>=g[j]) {
                    f[i]=f[i]-(g[j]-f[j]);
                    f[j]=g[j];
                    // printf("@%d %d\n",f[i],f[j]);
                } else if(f[i]+f[j]<g[j]) {
                    f[j]+=f[i];
                    f[i]=0;

                }
                k.x=f[0];
                k.y=f[1];
                // printf("!!!%d %d %d\n",k.x,k.y,k.z);
                if(w[k.x][k.y]==0) {
                        k.step=t.step+1;
                    q.push(k);
                    w[k.x][k.y]=1;
                }
            }
        }
    }
}

int main() {
    memset(w,0,sizeof(w));

    cin>>X>>Y>>K>>M;
    g[0]=X;
    g[1]=Y;
    bfs();
   cout<<minn<<endl;
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/jianrenfang/p/5722876.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
在信号处理领域,DOA(Direction of Arrival)估计是一项关键技术,主要用于确定多个信号源到达接收阵列的方向。本文将详细探讨三种ESPRIT(Estimation of Signal Parameters via Rotational Invariance Techniques)算法在DOA估计中的实现,以及它们在MATLAB环境中的具体应用。 ESPRIT算法是由Paul Kailath等人于1986年提出的,其核心思想是利用阵列数据的旋转不变性来估计信号源的角度。这种算法相比传统的 MUSIC(Multiple Signal Classification)算法具有较低的计算复杂度,且无需进行特征值分解,因此在实际应用中颇具优势。 1. 普通ESPRIT算法 普通ESPRIT算法分为两个主要步骤:构造等效旋转不变系统和估计角度。通过空间平移(如延时)构建两个子阵列,使得它们之间的关系具有旋转不变性。然后,通过对子阵列数据进行最小二乘拟合,可以得到信号源的角频率估计,进一步转换为DOA估计。 2. 常规ESPRIT算法实现 在描述中提到的`common_esprit_method1.m`和`common_esprit_method2.m`是两种不同的普通ESPRIT算法实现。它们可能在实现细节上略有差异,比如选择子阵列的方式、参数估计的策略等。MATLAB代码通常会包含预处理步骤(如数据归一化)、子阵列构造、旋转不变性矩阵的建立、最小二乘估计等部分。通过运行这两个文件,可以比较它们在估计精度和计算效率上的异同。 3. TLS_ESPRIT算法 TLS(Total Least Squares)ESPRIT是对普通ESPRIT的优化,它考虑了数据噪声的影响,提高了估计的稳健性。在TLS_ESPRIT算法中,不假设数据噪声是高斯白噪声,而是采用总最小二乘准则来拟合数据。这使得算法在噪声环境下表现更优。`TLS_esprit.m`文件应该包含了TLS_ESPRIT算法的完整实现,包括TLS估计的步骤和旋转不变性矩阵的改进处理。 在实际应用中,选择合适的ESPRIT变体取决于系统条件,例如噪声水平、信号质量以及计算资源。通过MATLAB实现,研究者和工程师可以方便地比较不同算法的效果,并根据需要进行调整和优化。同时,这些代码也为教学和学习DOA估计提供了一个直观的平台,有助于深入理解ESPRIT算法的工作原理。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值