栈的应用(平衡括号)

Description

There are six kinds of brackets: ‘(‘, ‘)’, ‘[‘, ‘]’, ‘{’, ‘}’. dccmx’s girl friend is now learning java programminglanguage, and got mad with brackets! Now give you a string of brackets. Is it valid? For example: “(([{}]))” is valid, but([)]” is not.

Input

 First line contains an integer T (T<=10): the number of test case.

Next T lines, each contains a string: the input expression consists of brackets.

The length of a string is between 1 and 100.

Output

For each test case, output “Valid” in one line if the expression is valid, or “Invalid” if not.

Sample Input

 

2
{{[[(())]]}}
({[}])

Sample Output 

Valid
Invalid

代码:

View Code
  #include<stdio.h>
#include<string.h>
int main()
{
char stack(char a[],int n);
int n,i,len,j;
char a[100];
scanf("%d%*c",&n);
for(i=0;i<n;i++)
{
scanf("%s",a);
len=strlen(a);
if(stack(a,len))
printf("Valid\n");
else
printf("Invalid\n");
}
return 0;
}
char stack(char a[],int n)
{
int i;
char b[100],t;
int top=0,buttom=0;
for(i=0;i<n;i++)
{
if(a[i]=='(' || a[i]=='[' || a[i]=='{')
b[top++]=a[i];
else
{
if(top==0)
{top=1;
break;}
t=b[top-1];
if((t=='['&&a[i]==']')||(t=='{'&&a[i]=='}')||(t=='('&&a[i]==')'))
{ --top; t=b[top-1]; }
}
}
if(top==buttom)
return 1;
else return 0;

}


转载于:https://www.cnblogs.com/dream-wind/archive/2012/03/16/2400032.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值