LightOJ1007(欧拉函数)

Mathematically Hard

Mathematically some problems look hard. But with the help of the computer, some problems can be easily solvable.

In this problem, you will be given two integers a and b. You have to find the summation of the scores of the numbers from a to b (inclusive). The score of a number is defined as the following function.

score (x) = n2, where n is the number of relatively prime numbers with x, which are smaller than x

For example,

For 6, the relatively prime numbers with 6 are 1 and 5. So, score (6) = 22 = 4.

For 8, the relatively prime numbers with 8 are 1, 3, 5 and 7. So, score (8) = 42 = 16.

Now you have to solve this task.


Input

Input starts with an integer T (≤ 105), denoting the number of test cases.

Each case will contain two integers a and b (2 ≤ a ≤ b ≤ 5 * 106).

Output

For each case, print the case number and the summation of all the scores from a to b.

Sample Input

3

6 6

8 8

2 20

Sample Output

Case 1: 4

Case 2: 16

Case 3: 1237

 

分析:题目让求区间[a,b]所有数的欧拉函数值之和。

#include<cstdio>
unsigned long long a[5001000];
void Euler()
{
    for(int i=1;i<5000001;i++) a[i]=i; 
    for(int i=2;i<5000001;i++)
    {
        if(a[i]==i)
        {
            for(int j=i;j<5000001;j+=i)
            a[j]=a[j]/i*(i-1);
        }
    }
}
int main()
{
    int T,cas=1;
    Euler();
    for(int i=2;i<5000001;i++)
    a[i]=a[i]*a[i]+a[i-1];
    scanf("%d",&T);
    while(T--)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        printf("Case %d: %llu\n",cas++,a[y]-a[x-1]);
    }
    return 0;
}
View Code

 

 

转载于:https://www.cnblogs.com/ACRykl/p/8568888.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值