zzu--2014年11月16日月潭赛 C称号

1230: Magnets

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 24   Solved: 13
[ Submit][ Status][ Web Board]

Description

Mad scientist Mike entertains himself by arranging rows of dominoes. He doesn't need dominoes, though: he uses rectangular magnets instead. Each magnet has two poles, positive (a "plus") and negative (a "minus"). If two magnets are put together at a close distance, then the like poles will repel each other and the opposite poles will attract each other.

Mike starts by laying one magnet horizontally on the table. During each following step Mike adds one more magnet horizontally to the right end of the row. Depending on how Mike puts the magnet on the table, it is either attracted to the previous one (forming a group of multiple magnets linked together) or repelled by it (then Mike lays this magnet at some distance to the right from the previous one). We assume that a sole magnet not linked to others forms a group of its own.

Mike arranged multiple magnets in a row. Determine the number of groups that the magnets formed.

Input

The first line of the input contains an integer n (1 <= n <= 100000) ---- the number of magnets. Then n lines follow. The i-th line (1 <= i <= n) contains either characters "01", if Mike put the i-thmagnet in the "plus-minus" position, or characters "10", if Mike put the magnet in the "minus-plus" position.

Output

On the single line of the output print the number of groups of magnets.

Sample Input

6
1 0
10
10
01
10
10
4
01
01
1 0
10

Sample Output

3
2

HINT

The first testcase corresponds to the figure. The testcase has three groups consisting of three, one and two magnets.


The second testcase has two groups, each consisting of two magnets.

Source

CF


题意:就是去求一堆磁铁能分成几段!


大水题AC代码:

#include <stdio.h>

int main()
{
    char a[3];
    int n;
    while(scanf("%d", &n) != EOF)
    {
                      scanf("%s", a);
                      n--;
                      char cur = a[1];
                      int ans=1;
                      while(n--)
                      {
                                scanf("%s", a);
                                if(a[0] == cur)
                                {
                                        ans++;
                                        cur = a[1];
                                }
                      }
                      printf("%d\n", ans);
    }
    return 0;
}




版权声明:本文博客原创文章,博客,未经同意,不得转载。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值