Poj(1466),最大独立集,匈牙利算法

题目链接:http://poj.org/problem?id=1466

Girls and Boys
Time Limit: 5000MS Memory Limit: 10000K
Total Submissions: 12026 Accepted: 5355

Description

In the second year of the university somebody started a study on the romantic relations between the students. The relation "romantically involved" is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been "romantically involved". The result of the program is the number of students in such a set.

Input

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1 (n <=500 ), for n subjects.

Output

For each given data set, the program should write to standard output a line containing the result.

Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output

5
2

Source

 
题意:
就是有n个人,每个人与其他的某几个人有关系,这个关系且称为浪漫关系,然后最后求一个最大的集合,使得集合中所有的人两两之间都不存在浪漫关系。
分析:
1、最大独立集 = 顶点数 - 最大匹配数
2、匈牙利算法
3、这里的男女性别没有给出,匹配关系放大一倍,那么实际的匹配数就是/2了。
 
#include <stdio.h>
#include <string.h>

#define MAX 505

int n;
bool maps[MAX][MAX];
bool use[MAX];
int match[MAX];

bool DFS(int stu)
{
    int num = 0;
    for(int i=0; i<n; i++)
    {
        if(!use[i]&&maps[stu][i])
        {
            use[i] = true;
            if(match[i]==-1||DFS(match[i]))
            {
                match[i] = stu;
                return true;
            }
        }
    }
    return false;
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        memset(match,-1,sizeof(match));
        memset(maps,false,sizeof(maps));
        for(int i=0; i<n; i++)
        {
            int u,num;
            scanf("%d: (%d)",&u,&num);
            for(int i=0; i<num; i++)
            {
                int v;
                scanf("%d",&v);
                maps[u][v] = true;
            }
        }
        int num = 0;
        for(int i=0; i<n; i++)
        {
            memset(use,false,sizeof(use));
            if(DFS(i)) num++;
        }
        printf("%d\n",n-num/2);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/TreeDream/p/5760134.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值