Description
Yu Zhou likes to play Go
with Su Lu. From the historical research, we found that there are much difference on the rules between ancient go and modern go.
Here is the rules for ancient go they were playing:
- The game is played on a cell board, the chess can be put on the intersection of the board lines, so there are different positions to put the chess.
- Yu Zhou always takes the black and Su Lu the white. They put the chess onto the game board alternately.
- The chess of the same color makes connected components(connected by the board lines), for each of the components, if it's not connected with any of the empty cells,
this component dies and will be removed from the game board. - When one of the player makes his move, check the opponent's components first. After removing the dead opponent's components, check with the player's components and remove
the dead components.
One day, Yu Zhou was playing ancient go with Su Lu at home. It's Yu Zhou's move now. But they had to go for an emergency military action. Little Qiao looked at the game board and
would like to know whether Yu Zhou has a move to kill at least one of Su Lu's chess.
Input
The first line of the input gives the number of test cases, (). test cases follow. Test cases are separated by an empty line. Each test case consist of
lines represent the game board. Each line consists of characters. Each character represents a cell on the game board. .
represents an empty cell. x
represents a
cell with black chess which owned by Yu Zhou. o
represents a cell with white chess which owned by Su Lu.
Output
For each test case, output one line containing Case #x: y
, where is the test case number (starting from ) and is Can kill in one move!!!
if Yu Zhou
has a move to kill at least one of Su Lu's components. Can not kill in one move!!!
otherwise.
Sample Input
2
…….xo
………
………
..x……
.xox….x
.o.o…xo
..o……
…..xxxo
….xooo.
……ox.
…….o.
…o…..
..o.o….
…o…..
………
…….o.
…x…..
……..o
Sample Output
Case #1: Can kill in one move!!!
Case #2: Can not kill in one move!!!
Hint
In the first test case, Yu Zhou has different ways to kill Su Lu's component.
In the second test case, there is no way to kill Su Lu's component.
题目大意:
有两个人在下围棋,然后给定一个棋局,让你判断X是否能赢。。。
解题思路;
很明显这是一个DFS搜索,但是需要用两次。又因为棋盘式9*9的
所以暴力做就可以,但是怎么暴力呢。首先一个搜索dfs1判断是不是有'.'
然后是另一个dfs,判断是不是能够赢。。
直接上代码:
<span style="font-size:14px;">#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
#include <set>
using namespace std;
#define MM(a) memset(a,0,sizeof(a))
typedef long long LL;
typedef unsigned long long ULL;
const int maxn = 15;
const int mod = 1000000007;
const double eps = 1e0-7;
int dx[4] = {-1, 1, 0, 0};
int dy[4] = {0, 0, 1, -1};
bool vis[maxn][maxn];
char str[maxn][maxn];
bool dfs1(int x, int y)
{
vis[x][y] = 1;
if(x<0 || y<0 || x>=9 || y>=9)
return 0;
for(int i=0; i<4; i++)
{
int xx = dx[i] + x;
int yy = dy[i] + y;
if(xx<0 || yy<0 || xx>=9 || yy>=9 || vis[xx][yy])
continue;
if(str[xx][yy] == '.')
return 1;
if(str[xx][yy] == 'o')
if(dfs1(xx, yy))
return 1;
}
return 0;
}
bool dfs(int x, int y)
{
if(str[x][y] != '.')
return 0;
str[x][y] = 'x';
for(int i=0; i<4; i++)
{
int xx = dx[i] + x;
int yy = dy[i] + y;
if(xx<0 || yy<0 || xx>=9 || yy>=9)
continue;
if(str[xx][yy] == 'o')
{
MM(vis);
if(!dfs1(xx, yy))
return 1;
}
}
str[x][y] = '.';
return 0;
}
int main()
{
int T;
scanf("%d",&T);
for(int cas=1; cas<=T; cas++)
{
for(int i=0; i<9; i++)
cin>>str[i];
bool ok = false;
for(int i=0; i<9; i++)
{
for(int j=0; j<9; j++)
{
if(str[i][j]=='o' || str[i][j]=='x')
continue;
if(dfs(i, j))
{
ok = true;
break;
}
}
if(ok)
break;
}
if(ok)
printf("Case #%d: Can kill in one move!!!\n",cas);
else
printf("Case #%d: Can not kill in one move!!!\n",cas);
}
return 0;
}
</span>