[解题报告]374 - Big Mod

 Big Mod 

Calculate

 

displaymath25

 

for large values of BP, and M using an efficient algorithm. (That's right, this problem has a time dependency !!!.)

 

Input

Three integer values (in the order BPM) will be read one number per line. B and P are integers in the range 0 to 2147483647 inclusive. M is an integer in the range 1 to 46340 inclusive.

 

Output

The result of the computation. A single integer.

 

Sample Input

 

3
18132
17

17
1765
3

2374859
3029382
36123

 

Sample Output

 

13
2
13195



关键是(A*B)%C=(A%C)*(B%C)
#include <stdio.h>
int bigmod( int b, int p, int m )
{
    if(p==0) return 1;
    if (p==1) return b;
    int a=bigmod(b,p/2,m);
    if (p%2)
        return (((a*a)%m)*b)%m;
    else return (a*a)%m;
}

int main()
{
    int b,p,m;
    while(scanf("%d%d%d",&b,&p,&m)!=EOF)
        printf("%d\n",bigmod(b%m,p,m));
    return 0;
}

 

 

转载于:https://www.cnblogs.com/TheLaughingMan/archive/2013/02/24/2924842.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值