【进制问题】【HDU2056】A + B Again

A + B Again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15772    Accepted Submission(s): 6847


Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !
 

Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.
 

Output
For each test case,print the sum of A and B in hexadecimal in one line.
 

Sample Input
 
  
+A -A +1A 12 1A -9 -1A -12 1A -AA
 

Sample Output
 
  
0 2C 11 -2C -90
 

Author
linle
 

Source



1.%I64X 输入

2.%I64X 不能输出负数

3.%I64O 也不能输出负数

4.如果x 为小写 输出的16进制为小写,为大写,输出大写

#include <cstdio>  
#include <cstdlib>  
#include <cmath>  
#include <cstring>  
#include <ctime>  
#include <algorithm>  
#include <iostream>
#include <sstream>
#include <string>
#define oo 0x13131313   
using namespace std;
int main()
{
	long long A;long long B;
	while(scanf("%I64O%I64O",&A,&B)!=EOF)
	{
		long long C=A+B;
	//	if(C<0) 
	//	printf("-%I64X\n",-C);
		 printf("%I64o\n",C);
	}
	return 0;
}
  



转载于:https://www.cnblogs.com/zy691357966/p/5480436.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值