字符相等(E - 暴力求解、DFS)

判断字符相等 

 

Description

Today on a lecture about strings Gerald learned a new definition of string equivalency. Two strings a and b of equal length are called equivalent in one of the two cases:

  1. They are equal.
  2. If we split string a into two halves of the same size a1 and a2, and string b into two halves of the same size b1 and b2, then one of the following is correct:            
    1. a1 is equivalent to b1, and a2 is equivalent to b2
    2. a1 is equivalent to b2, and a2 is equivalent to b1

As a home task, the teacher gave two strings to his students and asked to determine if they are equivalent.

Gerald has already completed this home task. Now it's your turn!

Input

The first two lines of the input contain two strings given by the teacher. Each of them has the length from 1 to 200 000 and consists of lowercase English letters. The strings have the same length.

Output

Print "YES" (without the quotes), if these two strings are equivalent, and "NO" (without the quotes) otherwise.

Sample Input

 
Input
aaba abaa
Output
YES
Input
aabb abab
Output
NO

Sample Output

 

Hint

In the first sample you should split the first string into strings "aa" and "ba", the second one — into strings "ab" and "aa". "aa" is equivalent to "aa"; "ab" is equivalent to "ba" as "ab" = "a" + "b", "ba" = "b" + "a".

In the second sample the first string can be splitted into strings "aa" and "bb", that are equivalent only to themselves. That's why string "aabb" is equivalent only to itself and to string "bbaa".

 

题意:

两个字符串a,b等长称为相等。

1.a,b是直接相等的

2.a,b可以分为相同大小的两半,a1.a2.b1.b2,下面有一个是正确的:

            1.a1=b1  且 a2=b2

            2.a1=b2且a2=b1

判断两个字符串是否相等。

 

分析:

1.DFS(深度优先搜索)

2.字符串长度为奇数时直接比较两个字符串相不相等;字符串长度为偶数时,平分字符串,比较,如果不相等继续分,一直到字符串长度为奇数。

 

代码:

 1  1 #include<cstdio>
 2  2 #include<iostream>
 3  3 #include<cstring>
 4  4 using namespace std;
 5  5 const int maxn=200001;
 6  6 
 7  7 char a[maxn],b[maxn];
 8  8 
 9  9 bool dfs(char *p1,char *p2,int len)
10 10 {
11 11     if(!strncmp(p1,p2,len))
12 12         return true;
13 13     if(len%2)       //判断字符串长度是奇是偶
14 14         return false;
15 15     int n=len/2;    //将字符串平均分为两部分
16 16     if(dfs(p1,p2+n,n)&&dfs(p1+n,p2,n)) 
17 17         return true;
18 18     if(dfs(p1,p2,n)&&dfs(p1+n,p2+n,n)) //字符串比较
19 19         return true;
20 20     return false;
21 21 
22 22 }
23 23 
24 24 int main()
25 25 {
26 26     scanf("%s%s",a,b);
27 27     printf("%s\n",dfs(a,b,strlen(a))?"YES":"NO");
28 28     return 0;
29 29 }
30 View Code
View Code


又是看了别人的代码。好想自己写出来。

转载于:https://www.cnblogs.com/ttmj865/p/4690525.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值