HDU - 2199 Can you solve this equation? 二分 简单题

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22742    Accepted Submission(s): 9865


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
 
  
2 100 -4
 

Sample Output
 
  
1.6152 No solution!


二分求解

#include<stdio.h>
const double eps = 1e-8;//精度大胆设高些

double cal(double x,double y)
{
	double m;
	m = 8 * x*x*x*x + 7 * x*x*x + 2 * x*x + 3 * x + 6 - y;
	return m;
}

double bsearch(double y)
{
	double left = 0, right = 100;
	double mid;
	while (right - left > eps)
	{
		mid = (left + right) / 2;
		if (cal(mid, y)>0)
		{
			right = mid;
		}
		else
		{
			left = mid;
		}
	}
	return mid;
}

int main()
{
	int T;
	scanf("%d", &T);
	double M,n;
	while (T--)
	{
		scanf("%lf", &M);
		if (M < 6 || M>807020306)//注意上下界
		{
			printf("No solution!\n");
		}
		else
		{
			n=bsearch(M);
			printf("%.4lf\n", n);
		}
	}
	return 0;
}


转载于:https://www.cnblogs.com/csu-lmw/p/9124474.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值