R1:
hostname R1
no ip domain-lookup
interface FastEthernet0/0
ip address 192.168.10.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial1/0
no ip address
encapsulation frame-relay
!
interface Serial1/0.1 point-to-point
ip address 192.168.1.1 255.255.255.0
frame-relay interface-dlci 102
!
interface Serial1/0.2 point-to-point
ip address 192.168.2.1 255.255.255.0
frame-relay interface-dlci 103
!
interface Serial1/1
no ip address
shutdown
!
interface Serial1/2
no ip address
shutdown
!
interface Serial1/3
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router eigrp 1
network 192.168.1.0
network 192.168.2.0
network 192.168.10.0
no auto-summary
!
ip classless
!
line con 0
exec-timeout 0 0
logging synchronous
line vty 0 4
login
!
end
R2:

hostname R2
!
!
no ip domain-lookup
!
interface FastEthernet0/0
ip address 192.168.10.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial1/0
no ip address
encapsulation frame-relay
!
interface Serial1/0.1 point-to-point
ip address 192.168.1.1 255.255.255.0
frame-relay interface-dlci 102
!
interface Serial1/0.2 point-to-point
ip address 192.168.2.1 255.255.255.0
frame-relay interface-dlci 103
!
interface Serial1/1
no ip address
shutdown
!
interface Serial1/2
no ip address
shutdown
!
interface Serial1/3
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router eigrp 1
network 192.168.1.0
network 192.168.2.0
network 192.168.10.0
no auto-summary
!
ip classless
!
line con 0
exec-timeout 0 0
logging synchronous
line vty 0 4
login
!
end

R3:
hostname R3

no ip domain-lookup
!
interface FastEthernet0/0
ip address 192.168.30.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial1/0
no ip address
encapsulation frame-relay
!
interface Serial1/0.1 point-to-point
ip address 192.168.2.2 255.255.255.0
frame-relay interface-dlci 301
!
interface Serial1/0.2 point-to-point
ip address 192.168.3.2 255.255.255.0
frame-relay interface-dlci 302
!
interface Serial1/1
no ip address
shutdown
!
interface Serial1/2
no ip address
shutdown
!
interface Serial1/3
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router eigrp 1
network 192.168.2.0
network 192.168.3.0
network 192.168.30.0
no auto-summary
!
ip classless
!
line con 0
exec-timeout 0 0
logging synchronous
line vty 0 4
login
!
end