POJ2100 Graveyard Design【尺取法】

Time Limit: 10000MS Memory Limit: 64000K
Total Submissions: 7094 Accepted: 1733
Case Time Limit: 2000MS

Description

King George has recently decided that he would like to have a new design for the royal graveyard. The graveyard must consist of several sections, each of which must be a square of graves. All sections must have different number of graves.  
After a consultation with his astrologer, King George decided that the lengths of section sides must be a sequence of successive positive integer numbers. A section with side length s contains s 2  graves. George has estimated the total number of graves that will be located on the graveyard and now wants to know all possible graveyard designs satisfying the condition. You were asked to find them.

Input

Input file contains n --- the number of graves to be located in the graveyard (1 <= n <= 10 14  ).

Output

On the first line of the output file print k --- the number of possible graveyard designs. Next k lines must contain the descriptions of the graveyards. Each line must start with l --- the number of sections in the corresponding graveyard, followed by l integers --- the lengths of section sides (successive positive integer numbers). Output line's in descending order of l.

Sample Input

2030

Sample Output

2
4 21 22 23 24
3 25 26 27

Source

Northeastern Europe 2004, Northern Subregion


问题链接POJ2100 Graveyard Design

题意简述:对于输入的n,求一段连续的正整数,使得其平方和等于n。

问题分析

采用尺取法解决。

step1.从1开始,先求出最前面的子序列,使之平方和大于或等于n;

step2.重复step3和step4,直到整数的平方小于n为止;

step3.若子序列平方和等于n,则先把解放入向量变量中;去掉子序列的第1个元素,子序列的后面再加上后续整数的平方和;

step4.将向量中的解取出,输出结果。

程序说明:需要注意数据类型,需要注意起始整数。


AC的C++语言程序如下:

/* POJ2100 Graveyard Design */

#include <iostream>
#include <vector>
#include <stdio.h>

using namespace std;

vector<pair<long long, long long> > ans;

void solve(long long n)
{
    ans.clear();

    long long start = 1, end = 1, sum = 0;
    while (start * start <= n) {
        while (end * end <= n && sum < n) {
            sum += end * end;
            end++;
        }

        if (sum == n)
            ans.push_back(make_pair(start, end));

        sum -= start * start;
        start++;
    }

    int len = ans.size();
    printf("%d\n", len);
    for (int i = 0; i < len; i++) {
        printf("%lld", ans[i].second - ans[i].first);
        for (int j = ans[i].first; j < ans[i].second; j++)
            printf(" %d", j);
        printf("\n");
    }
}

int main()
{
    long long n;

    while(scanf("%lld", &n) != EOF)
        solve(n);

    return 0;
}




转载于:https://www.cnblogs.com/tigerisland/p/7563660.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值