(1)配置路由器R1
R1(config)#router eigrp 1
R1(config-router)#no auto-summary
R1(config-router)#network 192.168.14.0
R1(config-router)#network 192.168.12.0
(2)配置路由器R2
R2(config)#router eigrp 1
R2(config-router)#no auto-summary
R2(config-router)#network 192.168.12.0
R2(config-router)#network 192.168.23.0
R2(config-router)#network 2.2.2.0 255.255.255.0
(3)配置路由器R3
R3(config)#router eigrp 1
R3(config-router)#no auto-summary
R3(config-router)#network 192.168.23.0
R3(config-router)#network 192.168.34.0
(4)配置路由器R4
R4(config)#router eigrp 1
R4(config-router)#no auto-summary
R4(config-router)#network 4.4.4.0 255.255.255.0
R4(config-router)#network 192.168.34.0
R4(config-router)#network 192.168.14.0
调试
(1)按照上面的配置,在R4 查看路由表:
R4#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
D 192.168.12.0/24
[90/20514560] via 192.168.14.1, 00:00:15, GigabitEthernet0/0
2.0.0.0/24 is subnetted, 1 subnets
D 2.2.2.0 [90/20642560] via 192.168.14.1, 00:00:15, GigabitEthernet0/0
C 192.168.14.0/24 is directly connected, GigabitEthernet0/0
4.0.0.0/24 is subnetted, 1 subnets
C 4.4.4.0 is directly connected, Loopback0
D 192.168.23.0/24 [90/21024000] via 192.168.34.3, 00:00:15, Serial0/0/0
C 192.168.34.0/24 is directly connected, Serial0/0/0
本实验只关注路由器R2 的Loopback 0,虽然路由器R4 到达路由器R2 的Loopback 0
有两条路径,但是路由器会将FD 最小的放入路由表,选择走g0/0 接口。那么另外一条路径是不是可行后继路由呢?在路由器R4 上查看拓扑表如下:
R4#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(4.4.4.4)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 2.2.2.0/24, 1 successors, FD is 20642560
via 192.168.14.1 (20642560/20640000), GigabitEthernet0/0
via 192.168.34.3 (21152000/20640000), Serial0/0/0
P 4.4.4.0/24, 1 successors, FD is 128256
via Connected, Loopback0
P 192.168.34.0/24, 1 successors, FD is 20512000
via Connected, Serial0/0/0
P 192.168.12.0/24, 1 successors, FD is 20514560
via 192.168.14.1 (20514560/20512000), GigabitEthernet0/0
P 192.168.14.0/24, 1 successors, FD is 28160
via Connected, GigabitEthernet0/0
P 192.168.23.0/24, 1 successors, FD is 21024000
via 192.168.34.3 (21024000/20512000), Serial0/0/0
从上面的输出中可以看到,第二条路径(走s0/0/0 接口)的AD 为20640000,而最优
路由(走g0/0 接口)的FD 为20642560,AD<FD,满足可行性条件,所以第二条路径(走s0/0/0接口)是最优路由(走g0/0 接口)的可行后继。

(2)通过适当的配置,使得在路由器R4 上看R2 的Loopback 0 的路由条目为等价路由,从而实现等价负载均衡。根据前面讲的EIGRP 度量值的计算公式,这两条路径的最小带宽是相同的,只要它们的延迟之和相同,就是等价路由,为此,在路由器R4 上做如下的配置:
R4(config)#interface gigabitEthernet 0/0
R4(config-if)#delay 2000
【提示】
在接口下用delay 命令修改的延迟,在计算度量值时,不需要再除以10。
在R4 上查看路由表:
R4#show ip route eigrp
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
D 192.168.12.0/24
[90/21024000] via 192.168.14.1, 00:00:15, GigabitEthernet0/0
2.0.0.0/24 is subnetted, 1 subnets
D 2.2.2.0 [90/21152000] via 192.168.34.3, 00:00:15, Serial0/0/0
[90/21152000] via 192.168.14.1, 00:00:15, GigabitEthernet0/0
D 192.168.23.0/24 [90/21024000] via 192.168.34.3, 00:00:15, Serial0/0/0
以上输出表明路由条目“2.2.2.0”确实有两条等价路径,表明EIGRP 是支持等价负载
均衡的。
(3)将R4 的以太口g0/0 的delay 恢复到原来的值,通过 “variance”命令来研究
EIGRP 的非等价负载均衡。在(1)的结果中发现,对于“2.2.2.0”路由条目,在路由器R4的拓扑结构数据库中存在如下的记录:
P 2.2.2.0/24, 1 successors, FD is 20642560
via 192.168.14.1 (20642560/20640000), GigabitEthernet0/0
via 192.168.34.3 (21152000/20640000), Serial0/0/0
现在只需要在R4 的路由器上调整variance 的值,使得这两条路径在路由表中都可见和可用,R4 上的配置如下:
R4(config)#router eigrp 1
R4(config-router)#variance 2
在R4 上查看路由表:
R4#show ip route eigrp
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
D 192.168.12.0/24
[90/20514560] via 192.168.14.1, 00:00:02, GigabitEthernet0/0
2.0.0.0/24 is subnetted, 1 subnets
D 2.2.2.0 [90/21152000] via 192.168.34.3, 00:00:02, Serial0/0/0
[90/20642560] via 192.168.14.1, 00:00:02, GigabitEthernet0/0
D 192.168.23.0/24 [90/21024000] via 192.168.34.3, 00:00:02, Serial0/0/0
以上输出表明路由条目“2.2.2.0”有两条路径可达,但是它们的度量值不同,这就是
所说的非等价路由,从而证明EIGRP 是支持非等价负载均衡的。
EIGRP 非等价负载均衡是通过“variance”命令实现的, “variance”默认是1(即代表等价路径的负载均衡), variance 值的范围是1-128.这个参数代表了可以接受的不等价路径的度量值的倍数,在这个范围内的链路都将被接受,并且被放入路由表中