HDU4381:Grid(类01背包)

Grid

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 903    Accepted Submission(s): 289


Problem Description
  There are n boxes in one line numbered 1 to n, at the beginning, all boxes are black. Two kinds of operations are provided to you:

1 a i x i :You can choose any x i black boxes in interval [1,a i], and color them white;
2 a i x i :You can choose any x i black boxes in interval [a i,n], and color them white;

  lcq wants to know if she use these operations in optimal strategy, the maximum number of white boxes she can get, and if she get maximum white boxes, the minimum number of operations she should use.
Tips: 
1. It is obvious that sometimes you can choose not to use some operations.
2. If the interval of one operation didn’t have enough black boxes, you can’t use this operation.
 

Input
  The first line contains one integer T, indicating the number of test case.
  The first line of each test case contains two integers N (1 <= N <= 1000) and M (1<=M<=1000), indicating that there are N grids and M operations in total. Then M lines followed, each of which contains three integers s i(1<=s i<=2) , a i and x i (0 <= x i <= N,1<=a i<=N), si indicating the type of this operation, a i and x i indicating that the interval is [1,a i] or [a i,n](depending on s i), and you can choose x i black boxes and color them white.
 

Output
  For each test case, output case number first. Then output two integers, the first one is the maximum boxes she can get, the second one is the minimum operations she should use.
 

Sample Input
 
  
1 5 2 2 3 3 1 3 3
 

Sample Output
 
  
Case 1: 3 1
 

Author
WHU
 

Source

题意:略。

思路:背包问题,两边分别处理,dp[i]表示变白前i个格的最小次数,显然有dp[i] = min(dp[i], dp[i-c[k].a]+1),i∈[c[k].a, c[k].x],左右都是这个方程,注意需要先排序,从小的开始计算,最后枚举下结果就行。

# include <stdio.h>
# include <string.h>
# define INF 0x3f3f3f3f
# include <algorithm>
using namespace std;
struct node
{
    int x, a;
}l[1001], r[1001];
bool cmp(node a, node b) {return a.x < b.x;}
int dpr[1001], dpl[1001];
int main()
{
    int t, n, m, x, a, s, cas = 1;
    scanf("%d",&t);
    while(t--)
    {
        int cntl = 0, cntr = 0;
        scanf("%d%d",&n,&m);
        for(int i=0; i<m; ++i)
        {
            scanf("%d%d%d",&s,&x,&a);
            if(s==1)
            {
                l[cntl].x = x;
                l[cntl++].a = a;
            }
            else
            {
                r[cntr].x = n+1-x;
                r[cntr++].a = a;
            }
        }
        sort(l, l+cntl, cmp);
        sort(r, r+cntr, cmp);
        for(int i=1; i<=n; ++i)
            dpl[i] = dpr[i] = INF;
        dpl[0] = dpr[0] = 0;
        for(int i=0; i<cntr; ++i)//涂左边
            for(int j=r[i].x; j>=r[i].a; --j)
                dpr[j] = min(dpr[j], dpr[j-r[i].a]+1);
        for(int i=0; i<cntl; ++i)//涂右边
            for(int j=l[i].x; j>=l[i].a; --j)
                dpl[j] = min(dpl[j], dpl[j-l[i].a]+1);
        int imax=-INF, imin=INF;
        for(int i=0; i<=n; ++i)//枚举结果
        {
            for(int j=n-i; j>=0; --j)
            {
                if(dpl[i]!=INF && dpr[j]!=INF)
                {
                    if(i+j > imax)
                    {
                        imax = i+j;
                        imin = dpl[i] + dpr[j];
                    }
                    else if(i+j==imax)
                        imin = min(imin, dpl[i]+dpr[j]);
                    break;
                }
            }
        }
        printf("Case %d: %d %d\n",cas++, imax, imin);
    }
    return 0;
}



转载于:https://www.cnblogs.com/junior19/p/6730040.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值