2017级寒假讲座二分三分训练题A - Cable master (浮点数二分法将其转化成整数进行)...

题目:A - Cable master
Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.
Input
The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.
Output
Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).
Sample Input
4 11
8.02
7.43
4.57
5.39
Sample Output
2.00

大意:就是从所给出的每个绳子,要分出11段完全相同的,然后输出能分的最大的长度;

思路:这里用二分法进行,能分出来的长度只可能从0到最大的绳子的长度之间,所以二分时只需要在这个范围内二分即可;然后二分出来的值看能否让其凑出11段;

注意:这个因为是要求比较精确的情况,即保留两位小数点的时候,所以尽量避免直接用浮点数来进行,而是要转换成整型来进行;(因为浮点数的精度问题会很难受,所以要特别注意!)(这个转化成整型,即成100来进行);

新技巧:以后对于这类的浮点数的二分时,将其转化成整型进行二分;(如果扩大倍数的,之后别忘再缩回来);

代码:

#include <iostream>
#include<cstring>
#include<stdio.h>
using namespace std;
        int len[10005];
int main(){
    long n,k,ks,i;
    while(scanf("%ld%ld",&n,&k)!=EOF){
        int  ans,left=0,maxs=0,mid;

        double input[10005];
        for(i=0;i<n;i++){
            scanf("%lf",&input[i]);
            len[i]=input[i]*100;
            maxs=maxs>len[i]?maxs:len[i];
        }
        while(maxs>=left){
            ks=0;
            ans=(maxs+left)/2;
            if(!ans){
                mid=ans;
                break;
            }
            for(i=0;i<n;i++)
                ks+=len[i]/ans;
            if(ks>=k){
                left=ans+1;
                mid=ans;
            }
            else
                maxs=ans-1;
        }
        printf("%.2f\n",(double)mid/100);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值