Eddy's digital Roots

http://acm.hdu.edu.cn/showproblem.php?pid=1163

Eddy's digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5203    Accepted Submission(s): 2910


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

The Eddy's easy problem is that : give you the n,want you to find the n^n's digital Roots.
 

Input
The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000).
 

Output
Output n^n's digital root on a separate line of the output.
 

Sample Input
 
   
2 4 0
 

Sample Output
 
   
4 4
 

Author
eddy
 
提醒一下。由于最后的答案是每一位相加,所以在前面计算的过程中个位和十位是没啥差别的。能够先相加起来在计算也是对的。自己体会。当然这一题也能够同九余数定理。

#include <cstdio>
int fun(int n)
{
    int ans=1;
    for(int i=0;i<n;i++){
        ans*=n;
        while(ans>=10){
        int sum=0;
        while(ans){
            sum+=ans%10;
            ans/=10;
           }
        ans=sum;
        }
    }
    return ans;
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF){
        if(n==0)break;
        printf("%d\n",fun(n));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值