UVA - 11754 Code Feat

Hooray!  Agent Bauer has shot the terrorists, blown upthe bad guy base, saved the hostages, exposed the moles in the government,prevented an environmental catastrophe, and found homes for three orphanedkittens, all in the span of 19 consecutive hours.  But now, he only has 5 hours remaining todeal with his final challenge: an activated nuclear bomb protected by asecurity code.  Can you help him figureout the code and deactivate it?  Eventsoccur in real time.

The governmenthackers at CTU (Counter-Terrorist Unit) have learned some things about thecode, but they still haven't quite solved it.They know it's a single, strictly positive, integer.  They also know several clues of the form "whendivided by X, the remainder is one of {Y1, Y2, Y3, ...,Yk}".There are multiple solutions to these clues, but the code is likely tobe one of the smallest ones.  So they'dlike you to print out the first few solutions, in increasing order.

The world iscounting on you!

Input

Input consistsof several test cases.  Each test casestarts with a line containing C, the number of clues (1 <= C <= 9), andS, the number of desired solutions (1 <= S <= 10).  The next C lines each start with two integersX (2 <= X) and k (1 <= k <= 100), followed by the k distinct integersY1, Y2, ..., Yk (0 <= Y1,Y2, ..., Yk < X).

You may assumethat the Xs in each test case are pairwise relativelyprime (ie, they have no common factor except 1).  Also, the product of the Xs will fit into a32-bit integer.

The last testcase is followed by a line containing two zeros.

Output

For each testcase, output S lines containing the S smallest positive solutions to the clues,in increasing order.

Print a blankline after the output for each test case.

Sample Input                              

Sample Output

 

3 2

2 1 1

5 2 0 3

3 2 1 2

0 0

5

13

 

 

Problem Setter: Derek Kisman, Special Thanks: Samee Zahur

题意:有一个正整数N满足C个条件,每一个条件都如“它除以X的余数在集合{Y1,Y2...YK}中”,全部条件中的X两两互素。求最小的S个解

思路:刘汝佳入门经典的例题。两种思路,当余数组合的可能性太大的话,我们用枚举搜索的方法,否则就是採用中国剩余定理的方法。枚举搜索的方法是:我们知道可能的答案一定是满足某个条件的某个余数的,所以我们枚举这个,为了加高速度,我们找X尽量大,并且K尽量小的,也就是找X/k最大的

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <map>
#include <vector>
#include <set>
typedef long long ll;
using namespace std;
const int maxc = 9;
const int maxk = 100;
const int LIMIT = 10000;

set<int> values[maxc];
vector<ll> sol; 
int C, X[maxc], k[maxc];
int Y[maxc][maxk];
int a[maxc];

void solve_enum(int S, int bc) {
	for (int c = 0; c < C; c++)
		if (c != bc) {
			values[c].clear();
			for (int i = 0; i < k[c]; i++)
				values[c].insert(Y[c][i]);
		}
	for (int t = 0; S != 0; t++) {
		for (int i = 0; i < k[bc]; i++) {
			ll n = (ll) X[bc]*t + Y[bc][i];
			if (n == 0)
				continue;
			int ok = 1;
			for (int c = 0; c < C; c++) if (c != bc)
				if (!values[c].count(n % X[c])) {
					ok = 0;
					break;
				}
			if (ok) {
				printf("%lld\n", n);
				if (--S == 0)
					break;
			}
		}
	}
}

void gcd(ll a, ll b, ll &d, ll &x, ll &y)  {
	if (!b) {
		d = a, x = 1, y = 0;
	}
	else {
		gcd(b, a%b, d, y, x);
		y -= x*(a/b);
	}
}

ll china(int n, int *a, int *m) {
	ll M = 1, d, y, x = 0;
	for (int i = 0; i < n; i++)
		M *= m[i];
	for (int i = 0; i < n; i++) {
		ll w = M / m[i];
		gcd(m[i], w, d, d, y);
		x = (x + y*w*a[i]) % M;
	}
	return (x + M) % M;
}

void dfs(int dep) {
	if (dep == C)
		sol.push_back(china(C, a, X));
	else for (int i = 0; i < k[dep]; i++) {
		a[dep] = Y[dep][i];
		dfs(dep+1);
	}

}

void solve_china(int S) {
	sol.clear();
	dfs(0);
	sort(sol.begin(), sol.end());

	ll M = 1;
	for (int i = 0; i < C; i++)
		M *= X[i];

	vector<ll> ans;
	for (int i =0; S != 0; i++) {
		for (int j = 0; j < sol.size(); j++) {
			ll n = M * i + sol[j];
			if (n > 0) {
				printf("%lld\n", n);
				if (--S == 0)
					break;
			}
		}
	}
}

int main() {
	int S;
	while (scanf("%d%d", &C, &S) != EOF && C) {
		ll tot = 1;
		int bestc = 0;
		for (int c = 0; c < C; c++) {
			scanf("%d%d", &X[c], &k[c]);
			tot *= k[c];
			for (int i = 0; i < k[c]; i++)
				scanf("%d", &Y[c][i]);
			sort(Y[c], Y[c]+k[c]);
			if (k[c]*X[bestc] < k[bestc]*X[c])
				bestc = c;
		}
		if (tot > LIMIT) 
			solve_enum(S, bestc);
		else solve_china(S);
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值