HDU - 4758 Walk Through Squares (AC自己主动机+DP)

Description


  On the beaming day of 60th anniversary of NJUST, as a military college which was Second Artillery Academy of Harbin Military Engineering Institute before, queue phalanx is a special landscape.
  
  Here is a M*N rectangle, and this one can be divided into M*N squares which are of the same size. As shown in the figure below:
  01--02--03--04
  || || || ||
  05--06--07--08
  || || || ||
  09--10--11--12
  Consequently, we have (M+1)*(N+1) nodes, which are all connected to their adjacent nodes. And actual queue phalanx will go along the edges.
  The ID of the first node,the one in top-left corner,is 1. And the ID increases line by line first ,and then by column in turn ,as shown in the figure above.
  For every node,there are two viable paths:
  (1)go downward, indicated by 'D';
  (2)go right, indicated by 'R';
  The current mission is that, each queue phalanx has to walk from the left-top node No.1 to the right-bottom node whose id is (M+1)*(N+1).
In order to make a more aesthetic marching, each queue phalanx has to conduct two necessary actions. Let's define the action:
  An action is started from a node to go for a specified travel mode.
  So, two actions must show up in the way from 1 to (M+1)*(N+1).

  For example, as to a 3*2 rectangle, figure below:
    01--02--03--04
    || || || ||
    05--06--07--08
    || || || ||
    09--10--11--12
  Assume that the two actions are (1)RRD (2)DDR

  As a result , there is only one way : RRDDR. Briefly, you can not find another sequence containing these two strings at the same time.
  If given the N, M and two actions, can you calculate the total ways of walking from node No.1 to the right-bottom node ?

 

Input

  The first line contains a number T,(T is about 100, including 90 small test cases and 10 large ones) denoting the number of the test cases.
  For each test cases,the first line contains two positive integers M and N(For large test cases,1<=M,N<=100, and for small ones 1<=M,N<=40). M denotes the row number and N denotes the column number.
  The next two lines each contains a string which contains only 'R' and 'D'. The length of string will not exceed 100. We ensure there are no empty strings and the two strings are different.
 

Output

  For each test cases,print the answer MOD 1000000007 in one line.
 

Sample Input

 
     
2 3 2 RRD DDR 3 2 R D
 

Sample Output

 
   
1 10
题意:给你两串,求用m个R。n个D能组成多少个包括这两个串

思路:先构造一个AC自己主动机记录每一个状态包括两个串的状态,然后利用dp[i][j][k][s]表示i个R,j个D。此时AC自己主动机状态位置到k的时候,状态为s时的个数进行转移

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;
const int mod = 1e9+7;

int dp[110][110][220][4];
int n,m;
int nxt[420][2],fail[420],end[420];
int root,cnt;

inline int change(char ch) {
	if (ch == 'R')
		return 0;
	else return 1;
}

inline int newNode() {
	for (int i = 0; i < 2; i++)
		nxt[cnt][i] = -1;
	end[cnt++] = 0;
	return cnt-1;
}

inline void init() {
	cnt = 0;
	root = newNode();
}

inline void insert(char buf[], int id) {
	int len = strlen(buf);
	int now = root;
	for (int i = 0; i < len; i++) {
		if (nxt[now][change(buf[i])] == -1)
			nxt[now][change(buf[i])] = newNode();
		now = nxt[now][change(buf[i])];
	}
	end[now] |= (1<<id);
}

inline void build() {
	queue<int> q;
	fail[root] = root;
	for (int i = 0; i < 2; i++)
		if (nxt[root][i] == -1)
			nxt[root][i] = root;
		else {
			fail[nxt[root][i]] = root;
			q.push(nxt[root][i]);
		}

	while (!q.empty()) {
		int now = q.front();
		q.pop();
		end[now] |= end[fail[now]];
		for (int i = 0; i < 2; i++)
			if (nxt[now][i] == -1)
				nxt[now][i] = nxt[fail[now]][i];
			else {
				fail[nxt[now][i]] = nxt[fail[now]][i];
				q.push(nxt[now][i]);
			}
	}
}

inline int solve() {
	dp[0][0][0][0] = 1;
	for (int x = 0; x <= n; x++)
		for (int y = 0; y <= m; y++)
			for (int i = 0; i < cnt; i++)
				for (int k = 0; k < 4; k++) {
					if (dp[x][y][i][k] == 0)
						continue;
					if (x < n) {
						int cur = nxt[i][0];
						dp[x+1][y][cur][k|end[cur]] += dp[x][y][i][k];
						dp[x+1][y][cur][k|end[cur]] %= mod;;
					}
					if (y < m) {
						int cur = nxt[i][1];
						dp[x][y+1][cur][k|end[cur]] += dp[x][y][i][k];
						dp[x][y+1][cur][k|end[cur]] %= mod;
					}
				}
	int ans = 0;
	for (int i = 0; i < cnt; i++) {
		ans += dp[n][m][i][3];
		ans %= mod;
	}
	return ans;
}

char str[210];

int main() {
	int t;
	scanf("%d", &t);
	while (t--) {
		scanf("%d%d", &n, &m);
		init();
		for (int i = 0; i < 2; i++) {
			scanf("%s", str);
			insert(str, i);
		}

		build();
		for (int i = 0; i <= n; i++)
			for (int j = 0; j <= m; j++) 
				for (int x = 0; x < cnt; x++)
					for (int y = 0; y < 4; y++)
						dp[i][j][x][y] = 0;

		printf("%d\n", solve());
	}
	return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值