hdu4976 A simple greedy problem.

A simple greedy problem.

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 476    Accepted Submission(s): 193


Problem Description

Victor and Dragon are playing DotA. Bored of normal games, Victor challenged Dragon with a competition of creep score (CS). In this competition, there are N enemy creeps for them. They hit the enemy one after another and Dragon takes his turn first. Victor uses a strong melee character so that in his turn, he will deal 1 damage to all creeps. Dragon uses a flexible ranged character and in his turn, he can choose at most one creep and deal 1 damage. If a creep take 1 damage, its health will reduce by 1. If a creep’s current health hits zero, it dies immediately and the one dealt that damage will get one score. Given the current health of each creep, Dragon wants to know the maximum CS he can get. Could you help him?
 

 

Input
The first line of input contains only one integer T(<=70), the number of test cases. 

For each case, the first line contains 1 integer, N(<=1000), indicating the number of creeps. The next line contain N integers, representing the current health of each creep(<=1000).
 

 

Output
Each output should occupy one line. Each line should start with "Case #i: ", with i implying the case number. For each case, just output the maximum CS Dragon can get.
 

 

Sample Input
2 5 1 2 3 4 5 5 5 5 5 5 5
 

 

Sample Output
Case #1: 5 Case #2: 2
 

 

Author
BJTU
 

 

Source
 

 

 

 

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=1005;
int T,n,cas,a[N],b[N];
int f[N][N];
int main(){
    for(scanf("%d",&T);T--;){
        scanf("%d",&n);memset(b,-1,sizeof b);
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        sort(a+1,a+n+1);
        for(int i=1;i<=n;i++){
            for(int j=a[i];j;j--){
                if(b[j]==-1){
                    b[j]=a[i];break;
                }
            }
        }
        memset(f,-1,sizeof f);
        f[0][0]=0;
        for(int i=0,t;i<a[n];i++){
            for(int j=0;j<=i+1;j++){
                f[i+1][j+1]=f[i][j];
                if((~b[i+1])&&(t=j-b[i+1]+i+1)>=0)f[i+1][t]=max(f[i+1][t],f[i][j]+1);
            }
        }
        int ans=0;
        for(int i=0;i<=a[n];i++){
            ans=max(ans,f[a[n]][i]);
        }
        printf("Case #%d: %d\n",++cas,ans);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/shenben/p/6720280.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值