HDU 4791 Alice's Print Service 水二分


Alice's Print Service

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1084    Accepted Submission(s): 240


Problem Description
Alice is providing print service, while the pricing doesn't seem to be reasonable, so people using her print service found some tricks to save money.
For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It's easy to figure out that if you want to print 99 pages, the best choice is to print an extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.
Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.
 

Input
The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.
Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 10 5 ). The second line contains 2n integers s 1, p 1 , s 2, p 2 , ..., s n, p n (0=s 1 < s 2 < ... < s n ≤ 10 9 , 10 9 ≥ p 1 ≥ p 2 ≥ ... ≥ p n ≥ 0).. The price when printing no less than s i but less than s i+1 pages is p i cents per page (for i=1..n-1). The price when printing no less than s n pages is p n cents per page. The third line containing m integers q 1 .. q m (0 ≤ q i ≤ 10 9 ) are the queries.
 

Output
For each query q i, you should output the minimum amount of money (in cents) to pay if you want to print q i pages, one output in one line.
 

Sample Input
 
    
1 2 3 0 20 100 10 0 99 100
 

Sample Output
 
    
0 1000 1000
 

Source
 

先逆序求出最小。然后二分查找要求的位置。
//484MS	2556K
#include<stdio.h>
#include<algorithm>
#define inf 1e13
using namespace std;
__int64 s[100007];
__int64 x[100007],y[100007];
int main()
{
    //freopen("in.txt","r",stdin);
    int t;
    scanf("%d",&t);
    while(t--)
    {
        __int64 mi;
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
            scanf("%I64d %I64d",&x[i],&y[i]);
        for(int i=1;i<=n;i++)s[i]=x[i]*y[i];
        s[n+1]=inf;
        mi=s[n+1];
        for(int i=n;i>=1;i--)
        {
            mi=min(s[i],mi);
            s[i]=mi;
        }
        while(m--)
        {
            __int64 q,minn;
            scanf("%I64d",&q);
            int pos=lower_bound(x+1,x+n+1,q)-x;//在first和last中的前闭后开区间进行二分查找。返回大于或等于val的第一个元素位置。假设全部元素都小于val。则返回last的位置
            minn=min(q*y[pos],s[pos+1]);
            printf("%I64d\n",minn);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值