Random Sequence 2011ACM福州赛区网络赛

Random Sequence

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 202    Accepted Submission(s): 124


Problem Description
There is a random sequence L whose element are all random numbers either -1 or 1 with the same possibility. Now we define MAVS, the abbreviate of Maximum Absolute Value Subsequence, to be any (if more than one) subsequences of L whose absolute value is maximum among all subsequences. Given the length of L, your task is to find the expectation of the absolute value of MAVS.
 

Input
There is only one input file. The first line is the number of test cases T. T positive integers follow, each of which contains one positive number not greater than 1500 denoted the length of L.
 

Output
For each test case, output the expectation you are required to calculate. Answers are rounded to 6 numbers after the decimal point.(as shown in the sample output)
 

Sample Input
3 1 5 10
 

Sample Output
Case 1: 1.000000 Case 2: 2.750000 Case 3: 4.167969
 

Source
 

Recommend
lcy
 
 
数论神题啊!!!!
卡特兰数
#include<iostream>
#include<iomanip>
#include<cstring>
#include<cmath>
using namespace std;
long double a[2000];
long double p;
long double C(int n){
long double t=1;
for(int i=n+1;i<=2*n+1;i++){

t*=i;
t/=i-n;

}
// for(int i=1;i<=n+1;i++) t/=i;
return t;
}

int main(){
int t,n,cnt=0;
a[1]=1;
for(int i=2;i<=1500;i++){
if(i%2==0) a[i]=(a[i-1]*2+C(i/2-1));
else a[i]=(a[i-1]*2+C(i/2-1)*2);
//cout<<"i="<<i<<","<<a[i]<<endl;
}

cin>>t;
while(t--){
cin>>n;
p=pow(2.0,n-1);

cout<<"Case "<<++cnt<<": "<<fixed<<setprecision(6)<<a[n]/p<<endl;
}
// system("pause");
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值