3、EIGRP配置实验之路由注入

1、实验拓扑

wKiom1ZVHj-Ak7AwAAA_MKMtVCE910.png

2、基础配置

R1

interface Serial0/0

 ip address 12.1.1.1 255.255.255.0


R2

interface Serial0/0

 ip address 12.1.1.2 255.255.255.0

interface Serial0/1

 ip address 23.1.1.2 255.255.255.0

router eigrp 90

 network 23.1.1.0 0.0.0.255

 no auto-summary


R3

interface Serial0/0

 ip address 34.1.1.3 255.255.255.0

 serial restart-delay 0

interface Serial0/1

 ip address 23.1.1.3 255.255.255.0

 serial restart-delay 0

router eigrp 90

 network 23.1.1.0 0.0.0.255

 network 34.1.1.0 0.0.0.255

 auto-summary


R4

interface Serial0/0

 ip address 34.1.1.4 255.255.255.0

router eigrp 90

 network 34.1.1.0 0.0.0.255

 auto-summary


3、三种路由注入3中方法方法

重分布:添加一条0.0.0.0默认路由,,在EIGRP路由进程中重分布该默认路由

通  告:添加一条0.0.0.0默认路由,在EIGRP路由进程中network通告该默认路由

ip default-network:

首先,ip default-network后面的网络必须是外网口所在网段的主类网络

其次,在EIGRP路由进程中network通告该主类网络

最后,必须存在到该主类网络的路由,没有的话,可以手动添加


4、重分布配置

R2(config)#ip route 0.0.0.0 0.0.0.0 s0/0

R2(config)#router eigrp 90

R2(config-router)#redistribute static 


R3#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route


Gateway of last resort is 23.1.1.2 to network 0.0.0.0


     34.0.0.0/24 is subnetted, 1 subnets

C       34.1.1.0 is directly connected, Serial0/0

     23.0.0.0/24 is subnetted, 1 subnets

C       23.1.1.0 is directly connected, Serial0/1

D*EX 0.0.0.0/0 [170/2681856] via 23.1.1.2, 00:00:04, Serial0/1

R3#


R4#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route


Gateway of last resort is 34.1.1.3 to network 0.0.0.0


     34.0.0.0/24 is subnetted, 1 subnets

C       34.1.1.0 is directly connected, Serial0/0

     23.0.0.0/24 is subnetted, 1 subnets

D       23.1.1.0 [90/2681856] via 34.1.1.3, 00:01:51, Serial0/0

D*EX 0.0.0.0/0 [170/3193856] via 34.1.1.3, 00:00:12, Serial0/0

R4#

重分布进来的静态路由属外部路由,故其AD为170


5、通告配置

R2(config)#ip route 0.0.0.0 0.0.0.0 s0/0

R2(config)#router eigrp 90

R2(config-router)#network 0.0.0.0


R3#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route


Gateway of last resort is 23.1.1.2 to network 0.0.0.0


     34.0.0.0/24 is subnetted, 1 subnets

C       34.1.1.0 is directly connected, Serial0/0

     23.0.0.0/24 is subnetted, 1 subnets

C       23.1.1.0 is directly connected, Serial0/1

     12.0.0.0/24 is subnetted, 1 subnets

D       12.1.1.0 [90/2681856] via 23.1.1.2, 00:00:02, Serial0/1

D*   0.0.0.0/0 [90/2681856] via 23.1.1.2, 00:00:02, Serial0/1

R3#


R4#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route


Gateway of last resort is 34.1.1.3 to network 0.0.0.0


     34.0.0.0/24 is subnetted, 1 subnets

C       34.1.1.0 is directly connected, Serial0/0

     23.0.0.0/24 is subnetted, 1 subnets

D       23.1.1.0 [90/2681856] via 34.1.1.3, 00:03:29, Serial0/0

     12.0.0.0/24 is subnetted, 1 subnets

D       12.1.1.0 [90/3193856] via 34.1.1.3, 00:00:28, Serial0/0

D*   0.0.0.0/0 [90/3193856] via 34.1.1.3, 00:00:28, Serial0/0

R4#

network通告进来的静态路由属内部路由,故其AD为90


6、ip default-network配置

R2(config)#ip default-network 12.0.0.0 

R2(config)#router eigrp 90

R2(config-router)#network 12.0.0.0 0.255.255.255

R2(config-router)#exit

R2(config)#ip route 12.0.0.0 255.0.0.0 null 0 


R3#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route


Gateway of last resort is 23.1.1.2 to network 12.0.0.0


     34.0.0.0/24 is subnetted, 1 subnets

C       34.1.1.0 is directly connected, Serial0/0

     23.0.0.0/24 is subnetted, 1 subnets

C       23.1.1.0 is directly connected, Serial0/1

     12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

D       12.1.1.0/24 [90/2681856] via 23.1.1.2, 00:01:28, Serial0/1

D*      12.0.0.0/8 [90/2169856] via 23.1.1.2, 00:00:35, Serial0/1

R3#


R4#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route


Gateway of last resort is 34.1.1.3 to network 12.0.0.0


     34.0.0.0/24 is subnetted, 1 subnets

C       34.1.1.0 is directly connected, Serial0/0

     23.0.0.0/24 is subnetted, 1 subnets

D       23.1.1.0 [90/2681856] via 34.1.1.3, 00:06:38, Serial0/0

     12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

D       12.1.1.0/24 [90/3193856] via 34.1.1.3, 00:01:59, Serial0/0

D*      12.0.0.0/8 [90/2681856] via 34.1.1.3, 00:01:07, Serial0/0

R4#




      本文转自开源殿堂 51CTO博客,原文链接:http://blog.51cto.com/kaiyuandiantang/1716642,如需转载请自行联系原作者






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值