POJ 3349:Snowflake Snow Snowflakes 六片雪花找相同的 哈希

Snowflake Snow Snowflakes
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 35642 Accepted: 9373

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.

题意是有很多片雪花,每一个雪花有六片,问这些雪花中是否有相同的雪花,注意雪花可以旋转,即可以循环向前移动或是向后移动,变成相等的情况。

两两比对会TLE,哈希做,六个值的和mod一个质数 作为key,然后有 和相等 的情况下,逐一比对是否含有完全相等的情况。

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#include <map>
#pragma warning(disable:4996)
using namespace std;

const int N1 = 15000;
const int N2 = 100;
int num,m[15000];

struct no {
	int sno[7];
}node[N1][N2];

bool check(no node_one,int pos, int x)
{
	int i, j;
	bool flag = false;
	for (j = 0; j < 6; j++)
	{
		for (i = 1; i <= 6; i++)
		{
			if (node_one.sno[i] != node[pos][x].sno[(i + j) % 6 + 1])
			{
				break;
			}
			if (i == 6)
			{
				return true;
			}
		}
	}
	
	for (j = 7; j >= 2 ; j--)
	{
		for (i = 1; i <= 6; i++)
		{
			if (node_one.sno[i] != node[pos][x].sno[(j-i+6)%6+1])
			{
				break;
			}
			if (i == 6)
				return true;
		}
	}
	return flag;
}

int main()
{

	int i,j,pos;
	bool flag = true;
	no node_one;

	memset(m, 0, sizeof(m));
	scanf("%d", &num);

	for (i = 1; i <= num; i++)
	{
		for (j = 1; j <= 6; j++)
		{
			scanf("%d",&node_one.sno[j]);
		}
		pos = (node_one.sno[1] + node_one.sno[2] + node_one.sno[3] + node_one.sno[4] + node_one.sno[5] + node_one.sno[6])%14997;

		for (j = 0; j < m[pos]; j++)
		{
			if (check(node_one,pos,j))
			{
				puts("Twin snowflakes found.");
				return 0;
			}
		}
			node[pos][m[pos]] = node_one;
			m[pos]++;
	}
	puts("No two snowflakes are alike.");
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

转载于:https://www.cnblogs.com/lightspeedsmallson/p/4928117.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值