###Apache web server###
SAMP -Solaris Apache Mysql PHP/Perl
LAMP -Linux Apache Mysql Php/perl
Modular & reliable
2 version (1.3.33&2.0.50) are included with solaris 10
svcs -a | grep -i apache
#svcs -a | grep  -i apache
#pkginfo -x | grep -i apache
#pkgchk -l SUNWapach2d | grep -i pathname
#pkgchk -l SUNWapach2r | grep -i pathname
#ls -ltr /etc/apache
#ls -ltr /etc/apache2
Note: Apache2 documentation is available@:
http://localhost/manual
steps to invoke Apache on solaris 10
1. cp /etc/apache2/httpd.conf-example
/etc/apache2/httpd.conf
2. update servername & server name admin directives for
main server
3. svcadm enable appache2
4, netstat -anP tcp| grep 80 && http://localhost/
# pkgchk -l SUNWapach2u| grep -i pathname
# cd /etc/appache2
# ls -ltr
# cp httpd.conf-example httpd.conf
#vi httpd.conf
servername linuxcbt.internal.com
DocumentRoot "/var/apache2/htdocs"
ServerAdmin webmaster@linuxcbt.internal.com
# ls -ltr /var/apache2/htdocs
#svcadm enable apache2
#svcs -l apache2
#netstat -anP tcp| grep 80
# pkginfo -x | grep -i apache
#pkgchk -SUNWapache2r | grep -i pathname
#vi /etc/httpd.conf
Note: typical classes of web server erorrs:
200 - ok
300  -redirect to different page
400  -client error
500 -server errors
Note: Apache always maitains a default host.configur is in
httpd.conf and outside of any and all virtual hosts
contaciners
Note: Apache requires the following info.for DEFAULT
HOST
1. ServerName  www.example.com
2.ServerAdmin  root@sun1.example.com
3.DocumentRoot -where to server content from
4.Ip address: port to bind to - optional
5. logging information -custom/combined & error logs
#ServerRoot "/