Spreading the Wealth uva 11300

A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

The Input

 

    There is a number of inputs. Each input begins withn(n<1000001), the number of people in the village.nlines follow, giving the number of coins of each person in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

The Output

 

    For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input

 3

100

100

100

4

1

2

5

4

 

Sample Output

 

0
4

题意:n个人坐成一圈,每个人有一些钱,现在要平分这些钱,每个人只能把钱给周围的人,问最少要转移多少钱才能平分。

 

    思路:推导,每个人最终得钱数可以算出为M,对于第i个人来说,Xi为他给上一个人的钱,如此一来 X(i+1) = M - Ai + Xi;X2 = M - A1 + X1 = X1 - C1.依次类推,Xi + 1 = X1 - Ci. Ci数组是可以递推出来的,然后答案就是X1 + |X1 - C1| + |X1 - C2| 。。。。 + |X1 - Cn -1|。中位数为最佳答案。

#include<cstring>
#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<set>
#define maxn 1000010
using namespace std;
long long c[maxn],a[maxn],m;
int main()
{
    int n;
    while(cin >> n)
    {
        long long sum = 0;
        for(int i=1;i<=n;i++)
        {
            cin >> a[i];
            sum += a[i];
        }
        m = sum / n;
        c[0] = 0;
        for(int i=1;i<=n;i++)
            c[i] = c[i-1] + a[i] - m;//跟新c[i]为x1-m,即第一个借出的钱减去平均值
        sort(c,c+n);//排序,贪心要用的
        long long x1 = c[n/2],ans = 0;//求出中位数
        for(int i=0;i<n;i++)
            ans += abs(x1-c[i]);//求最少值,所有点到中点的距离和是最小的
        cout << ans << endl;
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/l609929321/p/6856302.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值