Rikka with Graph(联通图取边,暴力)

Rikka with Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 190    Accepted Submission(s): 78

Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:
Yuta has a non-direct graph with n vertices and n+1 edges. Rikka can choose some of the edges (at least one) and delete them from the graph.
Yuta wants to know the number of the ways to choose the edges in order to make the remaining graph connected.
It is too difficult for Rikka. Can you help her?
 

 

Input
The first line contains a number  T(T30)——The number of the testcases.
For each testcase, the first line contains a number n(n100).
Then n+1 lines follow. Each line contains two numbers u,v , which means there is an edge between u and v.
 

 

Output
For each testcase, print a single number.
 

 

Sample Input
1 3 1 2 2 3 3 1 1 3
 

 

Sample Output
9
 

题解:题目问的是去掉边使图仍然联通。很简单的一道图论题,我竟然用prime错了半天。。。最后还是改了krustra,让找有多少中取法,直接暴力取边

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
using namespace std;
const int INF=0x3f3f3f3f;
#define mem(x,y) memset(x,y,sizeof(x))
#define SI(x) scanf("%d",&x)
#define PI(x) printf("%d",x)
#define SD(x,y) scanf("%lf%lf",&x,&y)
#define P_ printf(" ")
typedef long long LL;
const int MAXN=110;
int pre[MAXN];
int s[MAXN],e[MAXN];
int N,ans;
int find(int r){
    return pre[r]= pre[r]==r?r:find(pre[r]);
}
int check(int a,int b){
    for(int i=1;i<=N;i++)pre[i]=i;
    for(int i=0;i<=N;i++){
        if(i==a||i==b)continue;
        int f1=find(s[i]),f2=find(e[i]);
        //printf("%d %d\n",f1,f2);
        if(f1!=f2)pre[f1]=f2;
    }
    int cnt=0;
    for(int i=1;i<=N;i++){
        if(pre[i]==i)cnt++;
    //    if(cnt>1)printf("%d\n",cnt);
        if(cnt>1)return 0;
    }
    return 1;
}
int main(){
    int T;
    SI(T);
    while(T--){
        SI(N);
        for(int i=0;i<=N;i++)
            SI(s[i]),SI(e[i]);
            int ans=0;
        for(int i=0;i<=N;i++)
            for(int j=i;j<=N;j++){//相等代表的是取一条边。 
                ans+=check(i,j);
            }
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值