PAT 1010

1010. Radix (25)

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag" is 1, or of N2 if "tag" is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.

Sample Input 1:
6 110 1 10 
Sample Output 1:
2 
Sample Input 2:
1 ab 1 2 
Sample Output 2:
Impossible 

刚开始以为此题的范围会超过long long int,试过后发现并没有。另外题目说字符串里面的数字只有{0-9,a-z},让我以为radix的范围不会超过36,后来发现错了。更改后提交,发现有一个case超时了,估计这个case里的radix非常大,于是radix也采用long long int,并且采用二分搜索,这才解决超时问题。注意这VS下long long int应该定义成__int64,输入输出格式为%I64d。

 

代码

  1  #define __int64 long long
  2 #include <stdio.h>
  3 #include < string.h>
  4 
  5  long  long calculateFunc( char *, long  long);
  6  int maxDigit( char *);
  7  int char2num( char);
  8  int main()
  9 {
 10      long  long N1,N2,radix;
 11      int tag;
 12      char str1[ 12],str2[ 12];
 13      char *p1,*p2;
 14      while(scanf( " %s %s ",str1,str2) != EOF){
 15         scanf( " %d%I64d ",&tag,&radix);
 16          if(tag ==  1){
 17             p1 = str1;
 18             p2 = str2;
 19         }
 20          else{
 21             p1 = str2;
 22             p2 = str1;
 23         }
 24         N1 = calculateFunc(p1,radix);
 25          int radixMin = maxDigit(p2) +  1;
 26          if (radixMin <  2)
 27             radixMin =  2;
 28          int strN = strlen(p2);
 29          if(strN ==  1){
 30             N2 = char2num(*p2);
 31              if(N2 == N1){
 32                 printf( " %I64d\n ",N2+ 1);
 33             }
 34              else{
 35                 printf( " Impossible\n ");
 36             }
 37              continue;
 38         }
 39          long  long i = radixMin;
 40         N2 = calculateFunc(p2,i);
 41          int flag =  0;
 42          while(N2 <= N1){
 43              if(N1 == N2){
 44                 printf( " %I64d\n ",i);
 45                 flag =  1;
 46                  break;
 47             }
 48             i *=  2;
 49             N2 = calculateFunc(p2,i);
 50         }
 51          if(!flag){
 52              long  long s = i /  2,e = i;
 53              long  long mid;
 54                while(e >= s){
 55                 mid = (s + e) /  2;
 56                 N2 = calculateFunc(p2,mid);
 57                  if(N1 == N2){
 58                     printf( " %I64d\n ",mid);
 59                     flag =  1;
 60                      break;
 61                 }
 62                  else  if (N1 > N2){
 63                     s = mid +  1;
 64                 }
 65                  else{
 66                     e = mid -  1;
 67                 }
 68               }
 69              if(!flag){
 70                 printf( " Impossible\n ");
 71             }
 72         }
 73     }
 74      return  0;
 75 }
 76 
 77  long  long calculateFunc( char *p, long  long radix)
 78 {
 79      int n = strlen(p);
 80      int i;
 81      long  long N =  0;
 82      for(i= 0;i<n;++i){
 83         N = N * radix + char2num(*(p+i));
 84     }
 85      return N;
 86 }
 87 
 88  int maxDigit( char *p)
 89 {
 90      int n = strlen(p);
 91      int i;
 92      int m = - 1;
 93      int t;
 94      for(i= 0;i<n;++i){
 95         t = char2num(*(p+i));
 96          if (t > m)
 97             m = t;
 98     }
 99      return m;
100 }
101 
102  int char2num( char c)
103 {
104      if(c >=  ' 0 ' && c <=  ' 9 ')
105          return c -  ' 0 ';
106      else  if(c >=  ' a ' && c <=  ' z ')
107          return c -  ' a ' +  10;
108      else
109          return - 1;
110 }

 

posted on 2014-02-13 12:43 Boostable 阅读( ...) 评论( ...) 编辑 收藏

转载于:https://www.cnblogs.com/boostable/p/pat_1010.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值