SDUT 2613 This is an A+B Problem

 

This is an A+B Problem

Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
As usual, there will be an A+B problem in warming up, this problem is:
Given two integers A and B, your job is to calculate the sum of A + B.
Input
 Th ere are several test cases, For each test case:
There are two integers A, B for each case (0  A , B < 101000).
Output
 For each test case, output one line containing the result of A+B. 
Sample Input
1 2
11111111111 11111111111
Sample Output
3
22222222222

提示:这个题看似非常简单,其实他说是A+B Problem,但是其实看样例就满满的恶意,10的1000次方,用long long也过不了,
所以这不是一个简单的A+B Problem,所以这道题要用到大数模拟,即用字符串数组模拟来完成两数相加的操作。
代码实现如下(g++):
#include <bits/stdc++.h>

using namespace std;

char s1[1010];
char s2[1010];
int ab[1010];//因为是1000次方,所以只需开1010的数组即可

int main()
{
    int i,j;
    int len1,len2,a,b;
    memset(s1,'\0',sizeof(s1));
    memset(s2,'\0',sizeof(s2));
    memset(ab,0,sizeof(ab));//重置数组
    while(~scanf("%s %s",s1,s2))
    {
        len1=strlen(s1);
        len2=strlen(s2);
        if(len1==1&&s1[0]=='0'&&len2==1&&s2[0]=='0')//当出现0+0=0时
        {
            printf("0\n");
            continue;
        }                                        
        int y=0;
        for(i=len1-1,j=len2-1; i>=0||j>=0; i--,j--)
        {
            if(i>=0)
            {
                a=s1[i]-'0';
            }
            else
            {
                a=0;
            }
            if(j>=0)
            {
                b=s2[j]-'0';
            }
            else
            {
                b=0;
            }
            ab[y++]=a+b;
        }
        for(i=0; i<y; i++)
        {
            ab[i+1]+=(ab[i]/10);
            ab[i]%=10;//数组储存每一位
        }
        i=y;
        while(ab[i]==0)
        {
            i--;
        }
        for(; i>=0; i--)
        {
            printf("%d",ab[i]);
        }
        printf("\n");
        memset(s1,'\0',sizeof(s1));
        memset(s2,'\0',sizeof(s2));
        memset(ab,0,sizeof(ab));//必须重置数组
    }
    return 0;
}


/***************************************************
Result: Accepted
Take time: 0ms
Take Memory: 156KB
****************************************************/

 

转载于:https://www.cnblogs.com/jkxsz2333/p/9608343.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值