在局域网内开辟一个属于自己的局域网

         如果大家住集体宿舍,看看自己的IP地址是不是192.168.*.*?一般情况下我们只是老实的通过网络室路由器或服务器进行NAT地址转换畅游Internet的。如果想在自己宿舍组建一个小网吧,岂不妙哉?(实验可以做,如果真的这样在实际中做了,小心领导雷哦~)
        今天,我们就来在自己的宿舍做做网管们在空调机房干的事情吧~
        拓扑图:
在四个路由器上的配置信息(大家主要看R0和R1吧,因为这个实验主要还是PAT的应用。同时路由器R1与公网相连的接口也通过DHCP得到IP地址的。):
路由器R0上的配置:
R0#sh run
Building configuration...
Current configuration : 645 bytes
!
version 12.4
no service password-encryption
!
hostname R0
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
 ip address dhcp  (自动获取IP)

  ip nat outside
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.2.254 255.255.255.0
 ip nat inside

 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip nat inside source list 2 interface FastEthernet0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 

!
!
access-list 2 permit 192.168.2.0 0.0.0.255
!
!
ip dhcp pool tiger
 network 192.168.2.0 255.255.255.0
 default-router 192.168.2.254
 dns-server 200.1.3.1
!
line con 0
line vty 0 4
 login
!
!
end
路由器R1上的配置:
R1#sh run
Building configuration...
Current configuration : 661 bytes
!
version 12.4
no service password-encryption
!
hostname R1
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
 ip address 200.1.1.2 255.255.255.0
 ip nat outside

 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.1.254 255.255.255.0
 ip nat inside

 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip nat inside source list 1 interface FastEthernet0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 

!
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
!
ip dhcp pool R1
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.254
 dns-server 200.1.3.1

!
line con 0
line vty 0 4
 login
!
!
end
路由器R2上的设置(动态路由RIPv2的建立,及建立一个公网的DHCP地址池,供R1获取IP):
R2#sh run
Building configuration...
Current configuration : 454 bytes
!
version 12.4
no service password-encryption
!
hostname R2
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
 ip address 200.1.2.1 255.255.255.0

 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 200.1.1.1 255.255.255.0

 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 version 2
 network 200.1.1.0
 network 200.1.2.0
 no auto-summary

!
ip classless
!
!
line con 0
line vty 0 4
 login
!
!
end
路由器R3的配置(就当复习RIPv2吧~):
R3#sh run
Building configuration...
Current configuration : 456 bytes
!
version 12.4
no service password-encryption
!
hostname R3
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
 ip address 200.1.2.2 255.255.255.0

 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 200.1.3.254 255.255.255.0

 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 version 2
 network 200.1.2.0
 network 200.1.3.0
 no auto-summary

!
ip classless
!
!
line con 0
line vty 0 4
 login
!
!
end
          服务器在这个实验中充当着HTTP服务器和DNS服务器的双重任务。
          看一下在DNS上的配置吧:
        实验中的主机都是通过DHCP来获得自己的IP地址、网关地址、DNS服务器地址的,看看吧~
        在原来局域网中主机的IP:
          在宿舍局域网中的主机IP:
         验证一下:
         在局域网192.168.1.0/24找一台主机PC0打开 [url]www.cisco.com[/url]的网页:
         在局域网192.168.2.0/24找一台主机PC3打开 [url]www.cisco.com[/url]的网页:
        成功!(从此以后你就是宿舍网吧的老板了!)
现在在路由器R1和R0使用命令sh ip nat translation来看看PAT的过程吧~
R1上的结果:
R1# sh ip nat translations 
Pro  Inside global     Inside local       Outside local      Outside global
udp 200.1.1.2:1025     192.168.1.1:1025   200.1.3.1:53       200.1.3.1:53
udp 200.1.1.2:1026     192.168.1.1:1026   200.1.3.1:53       200.1.3.1:53
udp 200.1.1.2:1027     192.168.1.1:1027   200.1.3.1:53       200.1.3.1:53
udp 200.1.1.2:1028     192.168.1.1:1028   200.1.3.1:53       200.1.3.1:53
udp 200.1.1.2:1035     192.168.1.2:1035   200.1.3.1:53       200.1.3.1:53
tcp 200.1.1.2:1024     192.168.1.1:1024   200.1.3.1:80       200.1.3.1:80
tcp 200.1.1.2:1024     192.168.1.1:1025   200.1.3.1:80       200.1.3.1:80
tcp 200.1.1.2:1027     192.168.1.1:1026   200.1.3.1:80       200.1.3.1:80
tcp 200.1.1.2:1027     192.168.1.1:1027   200.1.3.1:80       200.1.3.1:80
tcp 200.1.1.2:1029     192.168.1.1:1028   200.1.3.1:80       200.1.3.1:80
tcp 200.1.1.2:1029     192.168.1.1:1029   200.1.3.1:80       200.1.3.1:80
tcp 200.1.1.2:1031     192.168.1.1:1030   200.1.3.1:80       200.1.3.1:80
tcp 200.1.1.2:1031     192.168.1.1:1031   200.1.3.1:80       200.1.3.1:80
tcp 200.1.1.2:1030     192.168.1.2:1025   200.1.3.1:80       200.1.3.1:80
tcp 200.1.1.2:1025     192.168.1.4:1025   200.1.3.1:80       200.1.3.1:80
tcp 200.1.1.2:1026     192.168.1.4:1026   200.1.3.1:80       200.1.3.1:80
tcp 200.1.1.2:1028     192.168.1.4:1027   200.1.3.1:80       200.1.3.1:80
R0上的结果:
R0# sh ip nat translations 
Pro  Inside global     Inside local       Outside local      Outside global
udp 192.168.1.1:1025   192.168.2.1:1025   200.1.3.1:53       200.1.3.1:53
udp 192.168.1.1:1026   192.168.2.1:1026   200.1.3.1:53       200.1.3.1:53
udp 192.168.1.1:1027   192.168.2.1:1027   200.1.3.1:53       200.1.3.1:53
udp 192.168.1.1:1028   192.168.2.1:1028   200.1.3.1:53       200.1.3.1:53
tcp 192.168.1.1:1024   192.168.2.1:1025   200.1.3.1:80       200.1.3.1:80
tcp 192.168.1.1:1029   192.168.2.1:1026   200.1.3.1:80       200.1.3.1:80
tcp 192.168.1.1:1030   192.168.2.1:1027   200.1.3.1:80       200.1.3.1:80
tcp 192.168.1.1:1031   192.168.2.1:1028   200.1.3.1:80       200.1.3.1:80
tcp 192.168.1.1:1025   192.168.2.3:1025   200.1.3.1:80       200.1.3.1:80
tcp 192.168.1.1:1026   192.168.2.3:1026   200.1.3.1:80       200.1.3.1:80
tcp 192.168.1.1:1027   192.168.2.3:1027   200.1.3.1:80       200.1.3.1:80
tcp 192.168.1.1:1028   192.168.2.3:1028   200.1.3.1:80       200.1.3.1:80
        如果偶尔网页打不开就重新获取一下IP吧~
        其他的乐趣大家慢慢挖掘吧~玩的开心!




本文转自 tiger506 51CTO博客,原文链接:http://blog.51cto.com/tiger506/113984,如需转载请自行联系原作者

表情包
插入表情
评论将由博主筛选后显示,对所有人可见 | 还能输入1000个字符
相关推荐
<p> 欢迎参加英特尔® OpenVINO™工具套件初级课程 !本课程面向零基础学员,将从AI的基本概念开始,介绍人工智能与视觉应用的相关知识,并且帮助您快速理解英特尔® OpenVINO™工具套件的基本概念以及应用场景。整个课程包含了视频的处理,深度学习的相关知识,人工智能应用的推理加速,以及英特尔® OpenVINO™工具套件的Demo演示。通过本课程的学习,将帮助您快速上手计算机视觉的基本知识和英特尔® OpenVINO™ 工具套件的相关概念。 </p> <p> 为保证您顺利收听课程参与测试获取证书,还请您于<strong>电脑端</strong>进行课程收听学习! </p> <p> 为了便于您更好的学习本次课程,推荐您免费<strong>下载英特尔® OpenVINO™工具套件</strong>,下载地址:https://t.csdnimg.cn/yOf5 </p> <p> 收听课程并完成章节测试,可获得本课程<strong>专属定制证书</strong>,还可参与<strong>福利抽奖</strong>,活动详情:https://bss.csdn.net/m/topic/intel_openvino </p> <p> 8月1日-9月30日,学习完成【初级课程】的小伙伴,可以<span style="color:#FF0000;"><strong>免费学习【中级课程】</strong></span>,中级课程免费学习优惠券将在学完初级课程后的7个工作日内发送至您的账户,您可以在:<a href="https://i.csdn.net/#/wallet/coupon">https://i.csdn.net/#/wallet/coupon</a>查询优惠券情况,请大家报名初级课程后尽快学习哦~ </p> <p> <span style="font-size:12px;">请注意:点击报名即表示您确认您已年满18周岁,并且同意CSDN基于商务需求收集并使用您的个人信息,用于注册OpenVINO™工具套件及其课程。CSDN和英特尔会为您定制最新的科学技术和行业信息,将通过邮件或者短信的形式推送给您,您也可以随时取消订阅不再从CSDN或Intel接收此类信息。 查看更多详细信息请点击CSDN“<a href="https://passport.csdn.net/service">用户服务协议</a>”,英特尔“<a href="https://www.intel.cn/content/www/cn/zh/privacy/intel-privacy-notice.html?_ga=2.83783126.1562103805.1560759984-1414337906.1552367839&elq_cid=1761146&erpm_id=7141654/privacy/us/en/">隐私声明</a>”和“<a href="https://www.intel.cn/content/www/cn/zh/legal/terms-of-use.html?_ga=2.84823001.1188745750.1560759986-1414337906.1552367839&elq_cid=1761146&erpm_id=7141654/privacy/us/en/">使用条款</a>”。</span> </p> <p> <br /> </p>
<p> <br /> </p> <p> <br /> </p> <p> <br /> </p> <p> <b><span style="background-color:#FFE500;">【超实用课程内容】</span></b> </p> <p> <span>本课程根据实际开发中总结出来的一些学习思路,从零开始详细讲解</span><span>Flutter</span><span>的基础知识点。从简到难,从浅入深,逐步带领大家了解</span><span>Flutter</span><span>,熟悉</span><span>Flutter</span><span>的组成部分,并且带领大家学习如何使用</span><span>Flutter</span><span>实现</span><span>UI</span><span>功能编写。通过对本视频的学习,你将会掌握</span><span>Flutter</span><span>常用组件和常用布局构建复杂布局、</span><span>Flutter</span><span>路由导航实现多页面构建和交互、</span><span>Flutetr</span><span>手势处理和动画实现动态交互效果,以及如何使用音视频、图片、文字、字体等资源。除此之外,你还可以收获每一章节遇到的重难点问题的解决方案。</span> </p> <p style="font-family:Helvetica;color:#3A4151;font-size:14px;background-color:#FFFFFF;"> <b><span style="background-color:#FFE500;">【课程如何观看?】</span></b> </p> <p style="font-family:Helvetica;color:#3A4151;font-size:14px;background-color:#FFFFFF;"> PC端:<a href="https://edu.csdn.net/course/detail/26277"></a><a href="https://edu.csdn.net/course/detail/26150"></a><a href="https://edu.csdn.net/course/detail/26150"></a><a href="https://edu.csdn.net/course/detail/27286"></a><a href="https://edu.csdn.net/course/detail/26858"></a><a href="https://edu.csdn.net/course/detail/26227">https://edu.csdn.net/course/detail/26227</a> </p> <p style="font-family:Helvetica;color:#3A4151;font-size:14px;background-color:#FFFFFF;"> 移动端:CSDN 学院APP(注意不是CSDN APP哦) </p> <p style="font-family:Helvetica;color:#3A4151;font-size:14px;background-color:#FFFFFF;"> 本课程为录播课,课程永久有效观看时长,大家可以抓紧时间学习后一起讨论哦~ </p> <p class="ql-long-24357476" style="font-family:"color:#3A4151;font-size:14px;background-color:#FFFFFF;"> <strong><span style="background-color:#FFE500;">【学员专享增值服务】</span></strong> </p> <p class="ql-long-24357476" style="font-family:"color:#3A4151;font-size:14px;background-color:#FFFFFF;"> <b>源码开放</b> </p> <p class="ql-long-24357476" style="font-family:"color:#3A4151;font-size:14px;background-color:#FFFFFF;"> 课件、课程案例代码完全开放给你,你可以根据所学知识,自行修改、优化 </p> <p class="ql-long-24357476" style="font-family:"color:#3A4151;font-size:14px;background-color:#FFFFFF;"> 下载方式:电脑登录<a href="https://edu.csdn.net/course/detail/26277"></a><a href="https://edu.csdn.net/course/detail/26150"></a><a href="https://edu.csdn.net/course/detail/27286"></a><a href="https://edu.csdn.net/course/detail/26858"></a><a href="https://edu.csdn.net/course/detail/26227">https://edu.csdn.net/course/detail/26227</a>,点击右下方课程资料、代码、课件等打包下载 </p> <p> <br /> </p>
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页