Elevator http://acm.hdu.edu.cn/showproblem.php?pid=1008

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 34433    Accepted Submission(s): 18770

Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 
Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 
Output
Print the total time on a single line for each test case.  
 
Sample Input
1 2
3 2 3 1 0
 
Sample Output
17
41
 
Author
ZHENG, Jianqiang
 
Source
 
Recommend
JGShining
 
#include<stdio.h>
int main()
{
	int n;
	while(scanf("%d",&n),n!=0)
	{
		int i,m,start=0,sum=0;
		for(i=0;i<n;i++)
		{
			scanf("%d",&m);
			if(m>start)
				sum+=6*(m-start)+5;
			else
			{
				sum+=4*(start-m)+5;
			}
			start=m;
		}
		printf("%d\n",sum);
	}
	return 0;
}

题目比较简单,意思就是坐电梯,上去一层用6秒,如果中间停了,时间间隔就是5秒,下去一层用4秒。第一个数据n为输入的个数,后面是n个数。第一个层数从0层开始算。

转载于:https://www.cnblogs.com/wangyouxuan/p/3265745.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值