poj1087 A Plug for UNIX(最大流)

A Plug for UNIX
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18110 Accepted: 6273

Description

You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas on the Internet as cumbersome and bureaucratic as possible.
Since the room was designed to accommodate reporters and journalists from around the world, it is equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances in all of the countries that existed when the room was built. Unfortunately, the room was built many years ago when reporters used very few electric and electronic devices and is equipped with only one receptacle of each type. These days, like everyone else, reporters require many such devices to do their jobs: laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling
irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the meeting is likely to be long and tedious, you want to be able to plug in as many as you can.
Before the meeting begins, you gather up all the devices that the reporters would like to use, and attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle. You wonder if these devices are from countries that didn't exist when the room was built. For some receptacles, there are several devices that use the corresponding plug. For other receptacles, there are no devices that use the corresponding plug.
In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to be plugged into other adapters. The store does not have adapters for all possible combinations of plugs and receptacles, but there is essentially an unlimited supply of the ones they do have.

Input

The input will consist of one case. The first line contains a single positive integer n (1 <= n <= 100) indicating the number of receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle type consists of a string of at most 24 alphanumeric characters. The next line contains a single positive integer m (1 <= m <= 100) indicating the number of devices you would like to plug in. Each of the next m lines lists the name of a device followed by the type of plug it uses (which is identical to the type of receptacle it requires). A device name is a string of at most 24 alphanumeric
characters. No two devices will have exactly the same name. The plug type is separated from the device name by a space. The next line contains a single positive integer k (1 <= k <= 100) indicating the number of different varieties of adapters that are available. Each of the next k lines describes a variety of adapter, giving the type of receptacle provided by the adapter, followed by a space, followed by the type of plug.

Output

A line containing a single non-negative integer indicating the smallest number of devices that cannot be plugged in.

Sample Input

4 
A 
B 
C 
D 
5 
laptop B 
phone C 
pager B 
clock B 
comb X 
3 
B X 
X A 
X D 

Sample Output

1

题意:提供N种插座,每种插座只有一个,再给出M种电器(每种一个)以及对应的插座,
即第i种电器只能通过第i种插座通电,注意每种电器对应的插座可能前面没有提供,
最后给出K行,每行两个字符x,y表示插座x可以插在插座y上,相当于x和y之间有转换器,
并且商店提供无数个转换器,问有多少种电器不能接上电源。


分析:最大流。建图,N个插头,M个电器,K种转换,源点0->电器的边容量为1,电器->插座的边容量为1,
插座->插座(转换)的边容量为INF(商店提供无数个转换器),插座->汇点T的边容量为1(注意这里的插座必须是
刚开始提供的插座才能与汇点连边),最后上模板=_=......

#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<queue>
#include<iostream>
#include<map>
#define INF 99999999
using namespace std;
int T;
int G[400][400];
map<string,int> m;
string s[200];
int p[400],vis[400],a[200];
int EK(int N)
{
    int ans=0;//ans表示最大流,初始化为0 
    while(true)
    {
        queue<int> q;//寻找增广路 
        memset(p,-1,sizeof(p));
        memset(vis,false,sizeof(vis));
        q.push(0);vis[0]=true;
        while(!q.empty())
        {
            int u=q.front();
            if(u==N) break;
            q.pop();
            for(int i=0;i<=N;i++)
            {
                if(G[u][i]&&!vis[i])//当前边容量非零,且增广点未标记 
                {
                    vis[i]=true;
                    p[i]=u;//记录点i的前一个结点v
                    q.push(i); 
                }
            }
        }
        if(p[N]==-1) break;//没有找到增广路 
        int k=N,MAX=INF;//MAX为增广路中的最大流 
        while(p[k]!=-1)
        {
            MAX=min(MAX,G[p[k]][k]);
            k=p[k];
        }
        ans+=MAX;//累加进最大流 
        
        k=N;//修改路径上的边容量 
        while(p[k]!=-1)
        {
            G[p[k]][k]-=MAX;
            G[k][p[k]]+=MAX;
            k=p[k];
        }
    }
    return ans;
}


int main()
{
    int N,M,K;//N个插头,M个电器,K种转换 
    string temp;
    scanf("%d",&N);
    for(int i=1;i<=N;i++) {cin>>temp;m[temp]=i;}
    scanf("%d",&M);
    for(int i=1;i<=M;i++)
    {
        cin>>s[i]>>temp;
        G[0][i]=1;//源点->电器 
        //电器->插座
        if(m[temp]==0) {N++;m[temp]=N;a[N]=1;}
        G[i][m[temp]+M]=1;
    }
    scanf("%d",&K);
    for(int i=1;i<=K;i++)
    {
        string s1,s2;
        cin>>s1>>s2;
        G[m[s1]+M][m[s2]+M]=INF;//插座->插座 
    }
    T=N+M+1;//T是汇点
    for(int i=1;i<=N;i++)//插座->汇点 
    if(!a[i]) G[i+M][T]=1;
    
    printf("%d\n",M-EK(T));
    
    return 0;
}
View Code

 







转载于:https://www.cnblogs.com/ACRykl/p/8849907.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值