java写的大数算法

用例子阐述:    
    例题:

         
n POJ 1503   Integer Inquiry
– Description
省略
– Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.
– Output
Your program should output the sum of the VeryLongIntegers given in the input.
– Sample Input
• 123456789012345678901234567890
• 123456789012345678901234567890
• 123456789012345678901234567890
• 0
– Sample Output
• 370370367037037036703703703670


题解:
      
import java.io.*;
import java.util.*;
import java.math.BigInteger;
public class Main {
public static void main(String[] args){
BigInteger sum=new BigInteger("0");
BigInteger num;
Scanner cin=new Scanner(System.in);
for(;;)
{
num=cin.nextBigInteger();
if(num.toString()=="0")break;
sum=sum.add(num);
}
System.out.println(sum.toString());
}
}

补方法如下:


add
 public  add( val) throws 
返回一个 BigInteger ,其值是 (this + val) 。

 

subtract
 public  subtract( val)
返回一个 BigInteger ,其值是 (this - val) 。

 

multiply
 public  multiply( val)
返回一个 BigInteger ,其值是 (this * val) 。

 

divide
 public  divide( val) throws 
返回一个 BigInteger ,其值是 (this / val) 。 如果 val == 0 ,则抛出 ArithmeticException 。

 

remainder
 public  remainder( val) throws 
返回一个 BigInteger ,其值是 (this % val) 。 如果 val == 0,则抛出 ArithmeticException 。
42846.html

hobo 2008-04-27 22:19 发表评论

转载于:https://www.cnblogs.com/zhouweiwei/archive/2008/04/27/1866507.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值