ytvfirewall# sh run
: Saved
:
PIX Version 6.3(2)
interface ethernet0 auto
interface ethernet1 auto
interface ethernet2 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 dmz security50
enable password 2KFQnbNIdI.2KYOU encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname ytvfirewall
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol ftp 4500
fixup protocol ftp 4501
fixup protocol ftp 4502
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol http 8080
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
no fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
no fixup protocol tftp 69
names
access-list 101 permit ip 10.65.128.0 255.255.128.0 192.168.30.0 255.255.255.0
access-list 101 permit ip 10.63.128.0 255.255.255.0 192.168.30.0 255.255.255.0
access-list 101 permit ip 172.19.104.0 255.255.255.0 192.168.30.0 255.255.255.0
//建立×××通道,使得192.168.30.0可以访问10.65.128.0、10.63.128.0、172.19.104.0

access-list 109 deny ip host 10.65.161.105 any
access-list 109 deny ip host 10.65.161.106 any
access-list 109 permit ip any any
//拒绝105和106两IP(客服IP)访问外网

pager lines 23
logging on
logging timestamp
logging standby
logging trap debugging
logging history debugging
logging host inside 10.65.155.18
//防火墙日志服务器

mtu outside 1500
mtu inside 1500
mtu dmz 1500
ip address outside 61.167.*.240 255.255.255.0
ip address inside 172.19.104.1 255.255.255.0
ip address dmz 192.168.100.1 255.255.255.0
//设置外网口、内网口和DMZ口IP

ip audit info action alarm
ip audit attack action alarm
ip local pool cisco 192.168.30.1-192.168.30.254
//×××地址池

no failover
failover timeout 0:00:00
failover poll 15
no failover ip address outside
no failover ip address inside
no failover ip address dmz
pdm history enable
arp timeout 14400
global (outside) 2 61.167.*.236 netmask 255.255.255.0
global (outside) 3 61.167.*.237 netmask 255.255.255.0
global (outside) 4 61.167.*.234 netmask 255.255.255.0
global (outside) 1 61.167.*.235 netmask 255.255.255.0
global (dmz) 1 192.168.100.100 netmask 255.255.255.0
//配置nat映到外网的IP地址

nat (inside) 0 access-list 101
nat (inside) 3 172.16.0.0 255.255.192.0 0 0
nat (inside) 2 10.21.0.0 255.255.128.0 0 0
nat (inside) 4 10.65.128.0 255.255.128.0 0 0
nat (dmz) 1 0.0.0.0 0.0.0.0 0 0
//nat内部地址设置

alias (inside) 61.167.*.161 192.168.100.161 255.255.255.255
alias (inside) 10.65.156.25 61.167.*.158 255.255.255.255
alias (inside) 10.65.156.160 61.167.*.228 255.255.255.255
alias (inside) 10.65.170.50 61.167.*.191 255.255.255.255
alias (inside) 10.65.160.102 61.167.*.193 255.255.255.255
//设置别名

static (inside,outside) 61.167.*.158 10.65.156.25 netmask 255.255.255.255 0 0
static (inside,outside) 61.167.*.191 10.65.170.50 netmask 255.255.255.255 0 0
static (inside,outside) 61.167.*.193 10.65.160.102 netmask 255.255.255.255 0 0
static (inside,outside) 61.167.*.228 10.65.156.160 netmask 255.255.255.255 0 0
//静态nat配置

access-group 109 in interface inside
//将109访问列表应用到内口

conduit permit tcp host 61.167.*.158 eq www any
conduit permit tcp host 61.167.*.158 eq 10000 any
conduit permit tcp host 61.167.*.158 eq ftp any
conduit permit tcp host 61.167.*.191 eq www any
conduit permit tcp host 61.167.*.191 eq 7552 any
conduit permit tcp host 61.167.*.191 eq 7562 any
conduit permit tcp host 61.167.*.193 eq 3389 any
conduit permit tcp host 61.167.*.191 eq 20984 any
conduit permit udp host 61.167.*.191 eq 57441 any
conduit permit udp host 61.167.*.228 eq 8012 any
conduit permit tcp host 61.167.*.228 eq 8012 any
conduit permit tcp host 61.167.*.228 eq 8880 any
conduit permit udp host 61.167.*.228 eq 8880 any
conduit permit udp host 61.167.*.228 eq 8003 any
conduit permit tcp host 61.167.*.228 eq 8003 any
conduit permit tcp host 61.167.*.228 eq 8010 any
conduit permit udp host 61.167.*.228 eq 8010 any
conduit permit tcp host 61.167.*.228 eq 8000 any
conduit permit icmp any any
//设置访问权限

route outside 0.0.0.0 0.0.0.0 61.167.*.252 1
route inside 10.21.0.0 255.255.128.0 172.19.104.2 1
route inside 10.63.128.4 255.255.255.255 172.19.104.2 1
route inside 10.63.128.40 255.255.255.255 172.19.104.2 1
route inside 10.63.128.46 255.255.255.255 172.19.104.2 1
route inside 10.63.128.82 255.255.255.255 172.19.104.2 1
route inside 10.65.128.0 255.255.128.0 172.19.104.2 1
route inside 172.16.0.0 255.255.192.0 172.19.104.2 1
route inside 172.16.40.0 255.255.255.0 172.19.104.2 1
route inside 172.16.56.0 255.255.255.0 172.19.104.2 1
//设置路由

timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
snmp-server host inside 10.65.156.18
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-pptp
sysopt noproxyarp inside
telnet 10.65.156.0 255.255.255.255 inside
telnet 10.65.150.2 255.255.255.255 inside
telnet 10.65.160.102 255.255.255.255 inside
telnet 10.65.160.58 255.255.255.255 inside
telnet 172.19.104.0 255.255.255.0 inside
telnet 10.65.160.118 255.255.255.255 inside
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group 1 accept dialin pptp
vpdn group 1 ppp authentication pap
vpdn group 1 ppp authentication chap
vpdn group 1 ppp authentication mschap
vpdn group 1 ppp encryption mppe 40
vpdn group 1 client configuration address local cisco
vpdn group 1 client configuration dns 10.65.156.161
vpdn group 1 pptp echo 60
vpdn group 1 client authentication local
vpdn username duxianfeng password *********
vpdn username sunruichao password *********
vpdn username shidequan password *********
vpdn username zhonglinjie password *********
vpdn username longgang password *********
vpdn username longnan password *********
vpdn username ranghulu password *********
vpdn username yinlang password *********
vpdn username babaishang password *********
vpdn username chengfen password *********
vpdn username chengfeng password *********
vpdn username bl password *********
vpdn username liuy password *********
vpdn username zhangtiejiang password *********
vpdn username xiaotiexi password *********
vpdn username liuze password *********
vpdn username xgh password *********
vpdn username xingwujing password *********
vpdn enable outside
//×××的配置

terminal width 80
Cryptochecksum:4f856c7fa02abd31dbdd2395711adb61
: end