[高斯消元] POJ 2345 Central heating

Central heating
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 614 Accepted: 286

Description

Winter has come, but at the Ural State University heating is not turned on yet. There's one little problem: the University is heated only if all of the valves are opened. There are some technicians at the University. Each of them is responsible for one or more valves. There may be several technicians responsible for the same valve. When a technician gets an instruction to turn on the heating he goes round all of his valves and turns them. It means that if a valve was opened then he closes it, and if it was closed then he opens it. It is well known that every technician earns his money not in vain so it's impossible to replace any technician by any combination of other technicians. 
Your task is to determine who of the technicians is to get an instruction "to turn on the heating" in order to heat all the Ural State University. Note that there are N technicians and N valves at the University (1 <= N <= 250). 

Input

The first line of an input contains the number N. The next N lines contain lists of the valves in charge of each of the technicians. It means that a line number i + 1 contains numbers of the valves that the i-th technician is responsible for. Each list of valves is followed by –1.

Output

An output should contain a list of technicians' numbers sorted in ascending order. If several lists are possible, you should send to an output the shortest one. If it's impossible to turn on the heating at the University, you should write "No solution" .

Sample Input

4
1 2 -1
2 3 4 -1
2 -1
4 -1

Sample Output

1 2 3

Source

原题大意: 有n个人,n个阀门。给n组数,每i组一-1结束,代表第i个人管理这组数中正数编号的阀门。
              问:能否确定几个人,使得所有阀门都开着。
解题思路: 不知道为啥是高斯消元,明明线性代数用的比较多。
              由于同一个人,开偶数次与不开是一样的,开奇数次与开1次是一样的。
              于是对于一个人,只有两种情况,不开和开一次。
              既然如此,我们可以把每个人的状态做成n维列向量,再做成增广矩阵,如题中所示。
             1  0  0  0  |  1
             1  1  1  0  |  1
             0  1  0  0  |  1
             0  1  0  1  |  1
             这样,解这个增广矩阵就可以了。
             值得一提的是,原文中有 it's impossible to replace any technician by any combination of other technicians. 
             什么意思呢,也就是说,这个系数矩阵分成向量后是线性无关的。
             也就是说,系数矩阵是n!必定有唯一的解。于是就可以无视原题中的无解和多解情况了。
#include<stdio.h>
#include<string.h>
int a[270][270],ans[270],n;
void swap(int *a,int *b)
  {
  	 int cnt=0,c[270],i;
  	 for(cnt=1;cnt<=n+1;++cnt)
	   {
	     c[cnt]=*a;
	     *a++=*(b+cnt-1);
       }
  	 for(i=1;i<=n+1;++i) *b++=c[i]; 
  }
void XOR(int col,int *a,int *b)
  {
  	 int i;
  	 for(i=col;i<=n+1;++i) *b++^=*a++;
  }
void init()
  {
  	 int col=0,x,i;
  	 for(i=1;i<=n;++i) a[i][n+1]=1;
  	 for(col=1;col<=n;++col) while(~scanf("%d",&x)&&x!=-1) a[x][col]=1;
  }
void solved()
  {
  	 int col,row,node;
  	 for(col=1;col<=n;++col)
  	   {
  	   	  node=0;
  	   	  for(row=col;row<=n;++row)
  	   	    {
  	   	       if(a[row][col]) 
  	   	         {
  	   	         	node=row;
  	   	         	break;
				 }
			}
		  if(node) swap(a[node]+1,a[col]+1);
		  for(row=col+1;row<=n;++row)
		    if(a[row][col]) XOR(col,a[col]+col,a[row]+col);
	   }
  }
void target()
  {
  	 int i,j;
  	 for(i=n;i>=1;--i)
  	   {
  	   	  ans[i]=a[i][n+1];
  	   	  for(j=n-1;j>=1;--j) a[j][n+1]^=(ans[i] & a[j][i]);
	   }
     int first=1;
     for(i=1;i<=n;++i) if(ans[i]) printf("%d ",i);
	 printf("\n");
  }
int main()
  {
  	 int t,x,col=0;
  	 scanf("%d",&n);
  	 init();
  	 solved();
  	 target();
  	 return 0;
  }

  

             

转载于:https://www.cnblogs.com/fuermowei-sw/p/6249979.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Go语言(也称为Golang)是由Google开发的一种静态强类型、编译型的编程语言。它旨在成为一门简单、高效、安全和并发的编程语言,特别适用于构建高性能的服务器和分布式系统。以下是Go语言的一些主要特点和优势: 简洁性:Go语言的语法简单直观,易于学习和使用。它避免了复杂的语法特性,如继承、重载等,转而采用组合和接口来实现代码的复用和扩展。 高性能:Go语言具有出色的性能,可以媲美C和C++。它使用静态类型系统和编译型语言的优势,能够生成高效的机器码。 并发性:Go语言内置了对并发的支持,通过轻量级的goroutine和channel机制,可以轻松实现并发编程。这使得Go语言在构建高性能的服务器和分布式系统时具有天然的优势。 安全性:Go语言具有强大的类型系统和内存管理机制,能够减少运行时错误和内存泄漏等问题。它还支持编译时检查,可以在编译阶段就发现潜在的问题。 标准库:Go语言的标准库非常丰富,包含了大量的实用功能和工具,如网络编程、文件操作、加密解密等。这使得开发者可以更加专注于业务逻辑的实现,而无需花费太多时间在底层功能的实现上。 跨平台:Go语言支持多种操作系统和平台,包括Windows、Linux、macOS等。它使用统一的构建系统(如Go Modules),可以轻松地跨平台编译和运行代码。 开源和社区支持:Go语言是开源的,具有庞大的社区支持和丰富的资源。开发者可以通过社区获取帮助、分享经验和学习资料。 总之,Go语言是一种简单、高效、安全、并发的编程语言,特别适用于构建高性能的服务器和分布式系统。如果你正在寻找一种易于学习和使用的编程语言,并且需要处理大量的并发请求和数据,那么Go语言可能是一个不错的选择。
Go语言(也称为Golang)是由Google开发的一种静态强类型、编译型的编程语言。它旨在成为一门简单、高效、安全和并发的编程语言,特别适用于构建高性能的服务器和分布式系统。以下是Go语言的一些主要特点和优势: 简洁性:Go语言的语法简单直观,易于学习和使用。它避免了复杂的语法特性,如继承、重载等,转而采用组合和接口来实现代码的复用和扩展。 高性能:Go语言具有出色的性能,可以媲美C和C++。它使用静态类型系统和编译型语言的优势,能够生成高效的机器码。 并发性:Go语言内置了对并发的支持,通过轻量级的goroutine和channel机制,可以轻松实现并发编程。这使得Go语言在构建高性能的服务器和分布式系统时具有天然的优势。 安全性:Go语言具有强大的类型系统和内存管理机制,能够减少运行时错误和内存泄漏等问题。它还支持编译时检查,可以在编译阶段就发现潜在的问题。 标准库:Go语言的标准库非常丰富,包含了大量的实用功能和工具,如网络编程、文件操作、加密解密等。这使得开发者可以更加专注于业务逻辑的实现,而无需花费太多时间在底层功能的实现上。 跨平台:Go语言支持多种操作系统和平台,包括Windows、Linux、macOS等。它使用统一的构建系统(如Go Modules),可以轻松地跨平台编译和运行代码。 开源和社区支持:Go语言是开源的,具有庞大的社区支持和丰富的资源。开发者可以通过社区获取帮助、分享经验和学习资料。 总之,Go语言是一种简单、高效、安全、并发的编程语言,特别适用于构建高性能的服务器和分布式系统。如果你正在寻找一种易于学习和使用的编程语言,并且需要处理大量的并发请求和数据,那么Go语言可能是一个不错的选择。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值