phpstudy 环境使用Composer安装thinkphp并指定版本

 参考网址:https://www.cnblogs.com/finalanddistance/p/8932042.html

1.为当前使用的php版本,设置环境变量

图片中地址设置环境变量

 

2,下载composer文件

下载地址:https://getcomposer.org/download/

点击下载或者右键另存为

把文件放入到下载到的文件夹

我要放到www文件夹所以我放在了

3.打开命令窗口:win+R然后输入cmd按回车

进入到放置文件的文件夹

检查安装是否成功  php.exe composer.phar -V

设置镜像为国内 php.exe composer.phar config repo.packagist composer https://packagist.phpcomposer.com

没有返回就是成功

4.下载自己需要的版本

第一个是自己下载下来后的项目名,第二个是想要下载的版本

5.测试运行

进入下载后的项目目录 执行   php think run

 

 

 

 然后 访问地址就能看到

 

转载于:https://www.cnblogs.com/kehaimin/p/11121466.html

评论将由博主筛选后显示,对所有人可见 | 还能输入1000个字符 “速评一下”
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页