POJ 3254 & POJ 1185(状压DP入门)

Corn Fields
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 16773 Accepted: 8860

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

Source

【题意】一块n*m的区域,有些地方草比较肥沃,有些地方贫瘠,现在要在肥沃的地方放羊,相邻的土地不能同时放羊,问有多少种放法,n,m<=12。
【分析】看到数据范围容易想到状压,然后枚举当前行和前一行状态 即可,dp[i][j]表示第i行使用j状态的总方法 数。
 
#include <cstdio>
#include <cstring>
#define inf 0x3f3f3f3f
#define met(a,b) memset(a,b,sizeof a)
#define pb push_back
#define mp make_pair
#define rep(i,l,r) for(int i=(l);i<=(r);++i)
#define inf 0x3f3f3f3f
using namespace std;
typedef long long ll;
const int N = 13;;
const int M = 1e5;
const int mod = 19260817;
const int mo=123;
//const double pi= acos(-1.0);
//typedef pair<int,int>pii;
int n,m,cas;
int sta[N],a[M],dp[N][M];
int main(){
    scanf("%d%d",&n,&m);
    for(int i=0;i<n;i++){
        for(int j=0,x;j<m;j++){
            scanf("%d",&x);
            if(!x)sta[i]+=(1<<j);
        }
    }
    int cnt=0;
    for(int i=0;i<(1<<m);i++){
        if(i&(i<<1))continue;
        a[cnt++]=i;
        if(i&sta[0])continue;
        dp[0][cnt-1]++;
    }
    for(int i=1;i<n;i++){
        for(int j=0;j<cnt;j++){
            if(a[j]&sta[i])continue;
            for(int k=0;k<cnt;k++){
                if(a[j]&a[k]||a[k]&sta[i-1])continue;
                dp[i][j]+=dp[i-1][k];
            }
        }
    }
    int ans=0;
    for(int i=0;i<cnt;i++){
        ans+=dp[n-1][i];
        ans%=1000000000;
    }
    printf("%d\n",ans);
    return 0;
}

 

 
炮兵阵地
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 29369 Accepted: 11377

Description

司令部的将军们打算在N*M的网格地图上部署他们的炮兵部队。一个N*M的地图由N行M列组成,地图的每一格可能是山地(用"H" 表示),也可能是平原(用"P"表示),如下图。在每一格平原地形上最多可以布置一支炮兵部队(山地上不能够部署炮兵部队);一支炮兵部队在地图上的攻击范围如图中黑色区域所示: 

如果在地图中的灰色所标识的平原上部署一支炮兵部队,则图中的黑色的网格表示它能够攻击到的区域:沿横向左右各两格,沿纵向上下各两格。图上其它白色网格均攻击不到。从图上可见炮兵的攻击范围不受地形的影响。 
现在,将军们规划如何部署炮兵部队,在防止误伤的前提下(保证任何两支炮兵部队之间不能互相攻击,即任何一支炮兵部队都不在其他支炮兵部队的攻击范围内),在整个地图区域内最多能够摆放多少我军的炮兵部队。 

Input

第一行包含两个由空格分割开的正整数,分别表示N和M; 
接下来的N行,每一行含有连续的M个字符('P'或者'H'),中间没有空格。按顺序表示地图中每一行的数据。N <= 100;M <= 10。

Output

仅一行,包含一个整数K,表示最多能摆放的炮兵部队的数量。

Sample Input

5 4
PHPP
PPHH
PPPP
PHPP
PHHP

Sample Output

6

Source

【题意】在一个格子中放置炮弹将影响上下左右两格,两枚炮弹不能炸到彼此,问 最多可以放置多少炮弹。
【分析】跟上一题很像,需要枚举三行状态,d[i][j][k]表示第i行j状态,第i-1行k状态获得的最大值。
 
#include <cstdio>
#include <map>
#include <algorithm>
#include <vector>
#include <iostream>
#include <set>
#include <queue>
#include <string>
#include <cstdlib>
#include <cstring>
#include <cmath>
#define inf 0x3f3f3f3f
#define met(a,b) memset(a,b,sizeof a)
#define pb push_back
#define mp make_pair
#define rep(i,l,r) for(int i=(l);i<=(r);++i)
#define inf 0x3f3f3f3f
using namespace std;
typedef long long ll;
const int N = 13;;
const int M = 165;
const int mod = 19260817;
const int mo=123;
const double pi= acos(-1.0);
typedef pair<int,int>pii;
int n,m,cas;
char str[15];
int sta[105],a[M],dp[105][M][M];
int sum[M];
int getsum(int x){
    int ret=0;
    for(int i=0;i<m;i++){
        if(x&(1<<i))ret++;
    }
    return ret;
}
int main(){
    scanf("%d%d",&n,&m);
    for(int i=0;i<n;i++){
        scanf("%s",str);
        for(int j=0;j<m;j++){
            if(str[j]=='H')sta[i]+=(1<<j);
        }
    }
    int cnt=0;
    for(int i=0;i<(1<<m);i++){
        if(i&(i<<1)||i&(i<<2))continue;
        a[cnt++]=i;
        if(i&sta[0])continue;
        dp[0][cnt-1][0]=getsum(i);
    }
    for(int i=0;i<cnt;i++){
        sum[i]=getsum(a[i]);
        if(a[i]&sta[1])continue;
        int res=0;
        for(int j=0;j<cnt;j++){
            if(a[i]&a[j])continue;
            dp[1][i][j]= dp[0][j][0] + getsum(a[i]);
        }
    }
    for(int i=2;i<n;i++){
        for(int j=0;j<cnt;j++){
            if(a[j]&sta[i])continue;
            for(int k=0;k<cnt;k++){
                if(a[j]&a[k]||a[k]&sta[i-1])continue;
                for(int l=0;l<cnt;l++){
                    if(a[j]&a[l]||a[l]&sta[i-2]||a[k]&a[l])continue;
                    dp[i][j][k]=max(dp[i-1][k][l]+sum[j],dp[i][j][k]);
                }
            }
        }

    }
    int ans=0;
    for(int i=0;i<cnt;i++){
        for(int j=0;j<cnt;j++){
            ans=max(ans,dp[n-1][i][j]);
        }
    }
    printf("%d\n",ans);
    return 0;
}

 

转载于:https://www.cnblogs.com/jianrenfang/p/7616785.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值