r1 配置
router>en
router#conf t
router(config)#host r1
r1(config)#ena sec 123
r1(config)#no ip domain-lookup
r1(config)#ban mot #Welcome to r1#
r1(config)#line vty 0 4
r1(config-line)#no login
r1(config-line)#line con 0
r1(config-line)#no exec-time
r1(config-line)#ipv6 unicast-routing
r1(config)#ipv6 cef
r1(config-if)#int lo0
r1(config-if)#des test ip
r1(config-if)#ipv6 add fec0:0:0:3::1/128
r1(config-if)#int f 0/0
r1(config-if)#des link to r2
r1(config-if)#ipv6 add fec0:0:0:1::/64 eui-64
r1(config-if)#no shut
r1(config-if)#int f 1/0
r1(config-if)#des link to r2 for back
r1(config-if)#ipv6 add fec0:0:0:2::/64 eui-64
r1(config-if)#no shut
r1(config-if)#exit
r1(config)#ipv6 route fec0:0:0:4::/64 fec0::1:c800:2ff:fe14:0
r1(config)#ipv6 route fec0:0:0:5::/64 fec0::1:c800:2ff:fe14:0
r1(config)#ipv6 route fec0:0:0:6::/64 fec0::1:c800:2ff:fe14:0
r1(config)#ipv6 route fec0:0:0:4::/64 fec0::2:c800:2ff:fe14:1c 50
r1(config)#ipv6 route fec0:0:0:5::/64 fec0::2:c800:2ff:fe14:1c 50
r1(config)#ipv6 route fec0:0:0:6::/64 fec0::2:c800:2ff:fe14:1c 50

r1(config)#end
r1#

r1 配置
router>en
router#conf t
router(config)#host r2
r2(config)#ena sec 123
r2(config)#no ip domain-lookup
r2(config)#ban mot #Welcome to r2#
r2(config)#line vty 0 4
r2(config-line)#no login
r2(config-line)#line con 0
r2(config-line)#no exec-time
r2(config-line)#ipv6 unicast-routing
r2(config)#ipv6 cef
r2(config-if)#int lo0
r2(config-if)#des test ip
r2(config-if)#ipv6 add fec0:0:0:4::1/128
r2(config-if)#int f 0/0
r2(config-if)#des link to r1
r2(config-if)#ipv6 add fec0:0:0:1::/64 eui-64
r2(config-if)#no shut
r2(config-if)#int f 1/0
r2(config-if)#des link to r1 for back
r2(config-if)#ipv6 add fec0:0:0:2::/64 eui-64
r2(config-if)#no shut
r2(config-if)#int f 2/0
r2(config-if)#des link to r3
r2(config-if)#ipv6 add fec0::5:c800:2ff:fe14:38
r2(config-if)#no shut
r2(config-if)#exit
r2(config)#ipv6 route fec0:0:0:3::/64 fec0::1:c800:2ff:fec8:0
r2(config)#ipv6 route fec0:0:0:6::/64 fec0::5:c800:5ff:fea4:0
r2(config)#ipv6 route fec0:0:0:3::/64 fec0::2:c800:2ff:fec8:1c 50
r2(config)#end
r2#
r3 配置
router>en
router#conf t
router(config)#host r3
r3(config)#ena sec 123
r3(config)#no ip domain-lookup
r3(config)#ban mot #Welcome to r3#
r3(config)#line vty 0 4
r3(config-line)#no login
r3(config-line)#line con 0
r3(config-line)#no exec-time
r3(config-line)#ipv6 unicast-routing
r3(config)#ipv6 cef
r3(config-if)#int lo0
r3(config-if)#des test ip
r3(config-if)#ipv6 add fec0:0:0:6::1/128
r3(config-if)#int f 0/0
r3(config-if)#des link to r2
r3(config-if)#ipv6 add fec0:0:0:5::/64 eui-64
r3(config-if)#no shut
r3(config-if)#exit
r3(config)#ipv6 route fec0:0:0:1::/64 fec0::5:c800:2ff:fe14:38
r3(config)#ipv6 route fec0:0:0:2::/64 fec0::5:c800:2ff:fe14:38
r3(config)#ipv6 route fec0:0:0:3::/64 fec0::5:c800:2ff:fe14:38
r3(config)#ipv6 route fec0:0:0:4::/64 fec0::5:c800:2ff:fe14:38
r3(config)#end
r3#
 
Weclome to r1
r1>show run
Password:
r1#show run
Building configuration...
Current configuration : 1197 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$ZJdq$sXB/we0Xn5mXCf6njEMcL1
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 description test ip
 no ip address
 ipv6 address FEC0:0:0:3::1/128
!
interface FastEthernet0/0
 description link to r2
 no ip address
 duplex half
 ipv6 address FEC0:0:0:1::/64 eui-64
!
interface FastEthernet1/0
 description link to r2 for back
 no ip address
 duplex half
 ipv6 address FEC0:0:0:2::/64 eui-64
!
ip classless
no ip http server
!
!
ipv6 route FEC0:0:0:4::/64 FEC0::2:C800:2FF:FE14:1C 50
ipv6 route FEC0:0:0:4::/64 FEC0::1:C800:2FF:FE14:0
ipv6 route FEC0:0:0:5::/64 FEC0::2:C800:2FF:FE14:1C 50
ipv6 route FEC0:0:0:5::/64 FEC0::1:C800:2FF:FE14:0
ipv6 route FEC0:0:0:6::/64 FEC0::2:C800:2FF:FE14:1C 50
ipv6 route FEC0:0:0:6::/64 FEC0::1:C800:2FF:FE14:0
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
banner motd ^CWeclome to r1^C
!
line con 0
 exec-timeout 0 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 no login
!
!
end
r1#show ipv6 route
IPv6 Routing Table - 10 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
L   FE80::/10 [0/0]
     via ::, Null0
C   FEC0:0:0:1::/64 [0/0]
     via ::, FastEthernet0/0
L   FEC0::1:C800:2FF:FEC8:0/128 [0/0]
     via ::, FastEthernet0/0
C   FEC0:0:0:2::/64 [0/0]
     via ::, FastEthernet1/0
L   FEC0::2:C800:2FF:FEC8:1C/128 [0/0]
     via ::, FastEthernet1/0
LC  FEC0:0:0:3::1/128 [0/0]
     via ::, Loopback0
S   FEC0:0:0:4::/64 [1/0]
     via FEC0::1:C800:2FF:FE14:0
S   FEC0:0:0:5::/64 [1/0]
     via FEC0::1:C800:2FF:FE14:0
S   FEC0:0:0:6::/64 [1/0]
     via FEC0::1:C800:2FF:FE14:0

L   FF00::/8 [0/0]
     via ::, Null0
r1#telnet fec0::1:c800:2ff:fe14:0
Trying FEC0::1:C800:2FF:FE14:0 ... Open
Welcome to r2
r2>en
Password:
r2#show run
Building configuration...
Current configuration : 1153 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$gNIo$TyIsx2FDaXRAMbJkkiwgm0
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 description test ip
 no ip address
 ipv6 address FEC0:0:0:4::1/128
!
interface FastEthernet0/0
 description link to r1
 no ip address
 duplex half
 ipv6 address FEC0:0:0:1::/64 eui-64
!
interface FastEthernet1/0
 description link to r1 for back
 no ip address
 duplex half
 ipv6 address FEC0:0:0:2::/64 eui-64
!
interface FastEthernet2/0
 description link to r3
 no ip address
 duplex half
 ipv6 address FEC0:0:0:5::/64 eui-64
!
ip classless
no ip http server
!
!
ipv6 route FEC0:0:0:3::/64 FEC0::2:C800:2FF:FEC8:1C 50
ipv6 route FEC0:0:0:3::/64 FEC0::1:C800:2FF:FEC8:0
ipv6 route FEC0:0:0:6::/64 FEC0::5:C800:5FF:FEA4:0
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
banner motd ^CWelcome to r2^C
!
line con 0
 exec-timeout 0 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 no login
!
!
end
r2#show ipv6 route
IPv6 Routing Table - 11 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
L   FE80::/10 [0/0]
     via ::, Null0
C   FEC0:0:0:1::/64 [0/0]
     via ::, FastEthernet0/0
L   FEC0::1:C800:2FF:FE14:0/128 [0/0]
     via ::, FastEthernet0/0
C   FEC0:0:0:2::/64 [0/0]
     via ::, FastEthernet1/0
L   FEC0::2:C800:2FF:FE14:1C/128 [0/0]
     via ::, FastEthernet1/0
S   FEC0:0:0:3::/64 [1/0]
     via FEC0::1:C800:2FF:FEC8:0

LC  FEC0:0:0:4::1/128 [0/0]
     via ::, Loopback0
C   FEC0:0:0:5::/64 [0/0]
     via ::, FastEthernet2/0
L   FEC0::5:C800:2FF:FE14:38/128 [0/0]
     via ::, FastEthernet2/0
S   FEC0:0:0:6::/64 [1/0]
     via FEC0::5:C800:5FF:FEA4:0

L   FF00::/8 [0/0]
     via ::, Null0
r2#telnet fec0::5:c800:5ff:fea4:0
Trying FEC0::5:C800:5FF:FEA4:0 ... Open
Welcome to r3
r3>en
Password:
r3#show run
Building configuration...
Current configuration : 1026 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r3
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$BaqM$DhvX6kzvNAUr7C7pnyQ0l1
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 description test ip
 no ip address
 ipv6 address FEC0:0:0:6::/128
!
interface FastEthernet0/0
 description link to r2
 no ip address
 duplex half
 ipv6 address FEC0:0:0:5::/64 eui-64
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex half
!
ip classless
no ip http server
!
!
ipv6 route FEC0:0:0:1::/64 FEC0::5:C800:2FF:FE14:38
ipv6 route FEC0:0:0:2::/64 FEC0::5:C800:2FF:FE14:38
ipv6 route FEC0:0:0:3::/64 FEC0::5:C800:2FF:FE14:38
ipv6 route FEC0:0:0:4::/64 FEC0::5:C800:2FF:FE14:38
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
banner motd ^CWelcome to r3^C
!
line con 0
 exec-timeout 0 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 no login
!
!
end
r3#show ipv6 route
IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
L   FE80::/10 [0/0]
     via ::, Null0
S   FEC0:0:0:1::/64 [1/0]
     via FEC0::5:C800:2FF:FE14:38
S   FEC0:0:0:2::/64 [1/0]
     via FEC0::5:C800:2FF:FE14:38
S   FEC0:0:0:3::/64 [1/0]
     via FEC0::5:C800:2FF:FE14:38
S   FEC0:0:0:4::/64 [1/0]
     via FEC0::5:C800:2FF:FE14:38

C   FEC0:0:0:5::/64 [0/0]
     via ::, FastEthernet0/0
L   FEC0::5:C800:5FF:FEA4:0/128 [0/0]
     via ::, FastEthernet0/0
LC  FEC0:0:0:6::/128 [0/0]
     via ::, Loopback0
L   FF00::/8 [0/0]
     via ::, Null0
r3#
 
 
模拟fec0::1/64链路断开
 
r1#show ipv6 route
IPv6 Routing Table - 8 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
L   FE80::/10 [0/0]
     via ::, Null0
C   FEC0:0:0:2::/64 [0/0]
     via ::, FastEthernet1/0
L   FEC0::2:C800:2FF:FEC8:1C/128 [0/0]
     via ::, FastEthernet1/0
LC  FEC0:0:0:3::1/128 [0/0]
     via ::, Loopback0
S   FEC0:0:0:4::/64 [50/0]
     via FEC0::2:C800:2FF:FE14:1C
S   FEC0:0:0:5::/64 [50/0]
     via FEC0::2:C800:2FF:FE14:1C
S   FEC0:0:0:6::/64 [50/0]
     via FEC0::2:C800:2FF:FE14:1C

L   FF00::/8 [0/0]
     via ::, Null0
r1#telnet fec0::2:c800:2ff:fe14:1c
Trying FEC0::2:C800:2FF:FE14:1C ... Open
Welcome to r2
r2>en
Password:
r2#show ipv6 route
IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
L   FE80::/10 [0/0]
     via ::, Null0
C   FEC0:0:0:2::/64 [0/0]
     via ::, FastEthernet1/0
L   FEC0::2:C800:2FF:FE14:1C/128 [0/0]
     via ::, FastEthernet1/0
S   FEC0:0:0:3::/64 [50/0]
     via FEC0::2:C800:2FF:FEC8:1C

LC  FEC0:0:0:4::1/128 [0/0]
     via ::, Loopback0
C   FEC0:0:0:5::/64 [0/0]
     via ::, FastEthernet2/0
L   FEC0::5:C800:2FF:FE14:38/128 [0/0]
     via ::, FastEthernet2/0
S   FEC0:0:0:6::/64 [1/0]
     via FEC0::5:C800:5FF:FEA4:0
L   FF00::/8 [0/0]
     via ::, Null0
r2#telnet fec0::5:c800:5ff:fea4:0
Trying FEC0::5:C800:5FF:FEA4:0 ... Open
Welcome to r3
r3>en
Password:
r3#show ipv6 route
IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
L   FE80::/10 [0/0]
     via ::, Null0
S   FEC0:0:0:1::/64 [1/0]
     via FEC0::5:C800:2FF:FE14:38
S   FEC0:0:0:2::/64 [1/0]
     via FEC0::5:C800:2FF:FE14:38
S   FEC0:0:0:3::/64 [1/0]
     via FEC0::5:C800:2FF:FE14:38
S   FEC0:0:0:4::/64 [1/0]
     via FEC0::5:C800:2FF:FE14:38
C   FEC0:0:0:5::/64 [0/0]
     via ::, FastEthernet0/0
L   FEC0::5:C800:5FF:FEA4:0/128 [0/0]
     via ::, FastEthernet0/0
LC  FEC0:0:0:6::/128 [0/0]
     via ::, Loopback0
L   FF00::/8 [0/0]
     via ::, Null0
r3#