hdu 5317 RGCDQ

RGCDQ

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 309    Accepted Submission(s): 156


Problem Description
Mr. Hdu is interested in Greatest Common Divisor (GCD). He wants to find more and more interesting things about GCD. Today He comes up with Range Greatest Common Divisor Query (RGCDQ). What’s RGCDQ? Please let me explain it to you gradually. For a positive integer x, F(x) indicates the number of kind of prime factor of x. For example F(2)=1. F(10)=2, because 10=2*5. F(12)=2, because 12=2*2*3, there are two kinds of prime factor. For each query, we will get an interval [L, R], Hdu wants to know  maxGCD(F(i),F(j))  (Li<jR)
 

Input
There are multiple queries. In the first line of the input file there is an integer T indicates the number of queries.
In the next T lines, each line contains L, R which is mentioned above.

All input items are integers.
1<= T <= 1000000
2<=L < R<=1000000
 

Output
For each query。output the answer in a single line. 
See the sample for more details.
 

Sample Input
 
   
2 2 3 3 5
 

Sample Output
 
   
1 1
 

Source
 

Recommend



/*
dp[i][j]记录小于等于i的含有不同质因子的个数

*/

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define bug printf("hihi\n")

#define eps 1e-8
typedef __int64 ll;

using namespace std;


#define INF 0x3f3f3f3f
#define N 1000005
#define M 8

int dp[N][M];
int pri[9]={2,3,5,7,11,13,17,19,23};
int a[N];

void inint()
{
    int i,j;
     for(i=2;i<N;i++)
        if(!a[i])
         for(j=1;i*j<N;j++)
            a[i*j]++;

   for(i=1;i<M;i++)
      for(j=1;j<N;j++)
         if(a[j]==i) dp[j][i]=dp[j-1][i]+1;
           else  dp[j][i]=dp[j-1][i];
}

int main()
{
   inint();
   int i,j,t;
   scanf("%d",&t);
   int le,ri;
   int ans;
   while(t--)
   {
       scanf("%d%d",&le,&ri);

       for(i=8;i>=1;i--)
       {
           if(dp[ri][i]-dp[le-1][i]>1)
           {
               ans=i;
               break;
           }
           for(j=i+i;j<8;j+=i)
           {
               if(dp[ri][j])
               {
                   ans=i;
                   i=10;
                   break;
               }
           }
       }
       printf("%d\n",ans);
   }
   return 0;
}


转载于:https://www.cnblogs.com/yutingliuyl/p/6791539.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值