2014 ACM/ICPC Asia Regional 北京 Online

G - Grade

Ted is a employee of Always Cook Mushroom (ACM). His boss Matt gives him a pack of mushrooms and ask him to grade each mushroom according to its weight. Suppose the weight of a mushroom is w, then it’s grade s is 

s = 10000 - (100 - w)^2

What’s more, Ted also has to report the mode of the grade of these mushrooms. The mode is the value that appears most often. Mode may not be unique. If not all the value are the same but the frequencies of them are the same, there is no mode.
InputThe first line of the input contains an integer T, denoting the number of testcases. Then T test cases follow. 

The first line of each test cases contains one integers N (1<=N<=10^6),denoting the number of the mushroom. 

The second line contains N integers, denoting the weight of each mushroom. The weight is greater than 0, and less than 200.OutputFor each test case, output 2 lines. 

The first line contains "Case #x:", where x is the case number (starting from 1) 

The second line contains the mode of the grade of the given mushrooms. If there exists multiple modes, output them in ascending order. If there exists no mode, output “Bad Mushroom”.Sample Input
3
6
100 100 100 99 98 101
6
100 100 100 99 99 101
6
100 100 98 99 99 97
Sample Output
Case #1:
10000
Case #2:
Bad Mushroom
Case #3:
9999 10000

这个题实际就是hash查找,单他竟然卡了cin,应该是数据加强了,或者我的算法不是很好
#include <bits/stdc++.h>
using namespace std;
int cnt[10005];
int main() {
    int T,k=1;
    scanf("%d",&T);
    while(T--){
        memset(cnt,0,sizeof(cnt));
        int n;scanf("%d",&n);
        for(int i=0;i<n;i++){
            int x;scanf("%d",&x);
            cnt[10000-(100-x)*(100-x)]++;
        }
        int ma=INT_MIN;
        for(int i=0;i<=10000;i++)
            ma=max(cnt[i],ma);
        int f=0;
        for(int i=0;i<=10000;i++)
        if(cnt[i]&&cnt[i]<ma){
            f=1;break;
        }
         printf("Case #%d:\n",k++);
        if(ma<n&&!f)printf("Bad Mushroom\n");
        else{
            int f1=0;
            for(int i=0;i<=10000;i++){
                if(cnt[i]==ma){
                    if(f1)printf(" ");
                    printf("%d",i);
                    f1=1;
                }
            }
            printf("\n");
        }
    }
    return 0;
}

 

F - Frog

Once upon a time, there is a little frog called Matt. One day, he came to a river. 

The river could be considered as an axis.Matt is standing on the left bank now (at position 0). He wants to cross the river, reach the right bank (at position M). But Matt could only jump for at most L units, for example from 0 to L. 

As the God of Nature, you must save this poor frog.There are N rocks lying in the river initially. The size of the rock is negligible. So it can be indicated by a point in the axis. Matt can jump to or from a rock as well as the bank. 

You don't want to make the things that easy. So you will put some new rocks into the river such that Matt could jump over the river in maximal steps.And you don't care the number of rocks you add since you are the God. 

Note that Matt is so clever that he always choose the optimal way after you put down all the rocks.

InputThe first line contains only one integer T, which indicates the number of test cases. 

For each test case, the first line contains N, M, L (0<=N<=2*10^5,1<=M<=10^9, 1<=L<=10^9). 

And in the following N lines, each line contains one integer within (0, M) indicating the position of rock.OutputFor each test case, just output one line “Case #x: y", where x is the case number (starting from 1) and y is the maximal number of steps Matt should jump.Sample Input

2
1 10 5
5
2 10 3
3
6

Sample Output

Case #1: 2
Case #2: 4

贪心下就可以了
#include <bits/stdc++.h>
using namespace std;
const int N=1000010;
int a[N];
int main() {
    int t,n,m,l,k=1;
    scanf("%d",&t);
    while(t--) {
        scanf("%d%d%d",&n,&m,&l);
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        sort(a,a+n);
        int fr=0,ans=0,pre=-l,now;
        a[n]=m;
        for (int i=0; i <=n; i++) {
            now=a[i];
            int t2=(now-fr)/(l + 1);
            pre+=t2*(l + 1);
            ans+=t2*2;
            if (now-pre>l) {
                pre=fr+t2*(l+1);
                fr=now;
                ans++;
            } else fr=now;
        }
        printf("Case #%d: %d\n",k++,ans);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/BobHuang/p/7254037.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值