2015杭电多校第二场

Buildings

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1622    Accepted Submission(s): 460


Problem Description
Your current task is to make a ground plan for a residential building located in HZXJHS. So you must determine a way to split the floor building with walls to make apartments in the shape of a rectangle. Each built wall must be paralled to the building's sides.

The floor is represented in the ground plan as a large rectangle with dimensions n×m, where each apartment is a smaller rectangle with dimensions a×b located inside. For each apartment, its dimensions can be different from each other. The number a and b must be integers.

Additionally, the apartments must completely cover the floor without one 1×1 square located on (x,y). The apartments must not intersect, but they can touch.

For this example, this is a sample of n=2,m=3,x=2,y=2.



To prevent darkness indoors, the apartments must have windows. Therefore, each apartment must share its at least one side with the edge of the rectangle representing the floor so it is possible to place a window.

Your boss XXY wants to minimize the maximum areas of all apartments, now it's your turn to tell him the answer.
 

 

Input
There are at most 10000 testcases.
For each testcase, only four space-separated integers, n,m,x,y(1n,m108,n×m>1,1xn,1ym).
 

 

Output
For each testcase, print only one interger, representing the answer.
 

 

Sample Input
2 3 2 2 3 3 1 1
 

 

Sample Output
1 2
Hint
Case 1 :
You can split the floor into five 1×1 apartments. The answer is 1. Case 2:
You can split the floor into three 2×1 apartments and two 1×1 apartments. The answer is 2.
If you want to split the floor into eight 1×1 apartments, it will be unacceptable because the apartment located on (2,2) can't have windows.
 

 

Source
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int  main()
{
    //fropen("in","r",stdin);
   // fropen("out","w",stdin);
    int n,m,a,b;

    while(scanf("%d%d%d%d",&n,&m,&a,&b)!=EOF)
    {
        int d,f,h;
        int v1,v2,v3,v4,k,l;
        v1=n/2+n%2;
        f=m/2+m%2;
        h=min(v1,f);
        d=max(v1,f);
        if(n==m&&n%2==1&&m%2==1&&h==min(a,b)&&d==max(a,b))
        {
            printf("%d\n",h-1);
            continue;
        }
        if(h==v1)
        {
            k=max(a-1,n-a);

            v2=min(k,min(m-b+1,b));
        }
        else
        {
            k=max(b-1,m-b);

            v2=min(k,min(n-a+1,a));
        }
        v2=max(v2,h);
        printf("%d\n",v2);
    }
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/ya-cpp/p/4678006.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值