Hit 2255 Not Fibonacci

今天下午刚起来眼睛就比較涨,,并且还有点恶心,唉。结果一直不在状态。并且这个题太坑了。。

。。


点击此处即可传送 Hit 2255

Maybe ACMers of HIT are always fond of fibonacci numbers, because it is so beautiful. Don't you think so? At the same time, fishcanfly always likes to change and this time he thinks about the following series of numbers which you can guess is derived from the definition of fibonacci number. 

The definition of fibonacci number is: 

f(0) = 0, f(1) = 1, and for n>=2, f(n) = f(n - 1) + f(n - 2) 

We define the new series of numbers as below: 

f(0) = a, f(1) = b, and for n>=2, f(n) = p*f(n - 1) + q*f(n - 2),where p and q are integers. 

Just like the last time, we are interested in the sum of this series from the s-th element to the e-th element, that is, to calculate ."""" 

Great!Let's go! 

Input 

The first line of the input file contains a single integer t (1 <= t <= 30), the number of test cases, followed by the input data for each test case. 

Each test case contains 6 integers a,b,p,q,s,e as concerned above. We know that -1000 <= a,b <= 1000,-10 <= p,q <= 10 and 0 <= s <= e <= 2147483647. 

Output 

One line for each test case, containing a single interger denoting S MOD (10^7) in the range [0,10^7) and the leading zeros should not be printed. 

Sample Input 
2
0 1 1 -1 0 3
0 1 1 1 2 3


Sample Output 
2
3

题目大意:
就是给你好几个数,分别表示什么意思,看题即可了;

解题思路:矩阵乘法,递推公式,

注意了,注意了,千万不要用全局变量
if(ans < 0)
ans += mod;
printf(“%lld\n”,ans);
}
return 0;
}

!!!!

!!

/*
2015 - 8 - 14 下午
Author: ITAK

今天很很的不顺心啊。。。。

今日的我要超越昨日的我,明日的我要胜过今日的我,
以创作出更好的代码为目标。不断地超越自己。
*/
#include <iostream>
#include <cstdio>
using namespace std;
const int maxn = 3;
const int mod = 1e7;
typedef long long LL;
typedef struct
{
    LL m[maxn][maxn];
} Matrix;
// LL a, b, s, e, q, p;千万不要用全局变量
Matrix P = {0,0,0,
            1,0,0,
            0,0,1
           };
Matrix I = {1,0,0,
            0,1,0,
            0,0,1
           };
Matrix matrix_mul(Matrix a, Matrix b)
{
    int i, j, k;
    Matrix c;
    for(i=0; i<maxn; i++)
    {
        for(j=0; j<maxn; j++)
        {
            c.m[i][j] = 0;
            for(k=0; k<maxn; k++)
            {
                a.m[i][k] = (a.m[i][k]%mod + mod) % mod;
                b.m[k][j] = (b.m[k][j]%mod + mod) % mod;
                c.m[i][j] += (a.m[i][k] * b.m[k][j]) % mod;
            }
            c.m[i][j] = (c.m[i][j]%mod + mod) % mod;
        }
    }
    return c;
}

Matrix quick_mod(LL m)
{
    Matrix ans = I, b = P;
    while(m)
    {
        if(m & 1)
            ans = matrix_mul(ans, b);
        m >>= 1;
        b = matrix_mul(b, b);
    }
    return ans;
}
int main()
{
    int t;
    LL a, b, q, p, e, s;
    scanf("%d",&t);
    while(t--)
    {


        Matrix tmp1, tmp2;
        LL ans, ans1, ans2;
        cin>>a>>b>>p>>q>>s>>e;
        P.m[0][0]=p;
        P.m[0][1]=q;
        P.m[2][0]=p;
        P.m[2][1]=q;
        if(s-2 > 0)
        {
            tmp1 = quick_mod(s-2);
            ans1 = (b*tmp1.m[2][0])%mod + (a*tmp1.m[2][1])%mod + ((a+b)*tmp1.m[2][2])%mod;
        }
        else
        {
            if(s == 0)
                ans1 = 0;
            if(s == 1)
                ans1 = a;
            if(s == 2)
                ans1 = a + b ;
        }
        if(e-1 > 0)
        {
            tmp2 = quick_mod(e-1);
            ans2 = (b*tmp2.m[2][0])%mod + (a*tmp2.m[2][1])%mod + ((a+b)*tmp2.m[2][2])%mod;
        }
        else
        {
            if(e == 0)
                ans2 = a;
            else
                ans2 = b+a;
        }
        ans1 = (ans1%mod+mod) % mod;
        ans2 = (ans2%mod+mod) % mod;
        //cout<<ans1<<" "<<ans2<<" ";
        ans = (ans2 - ans1 + mod) % mod;
        if(ans < 0)
            ans += mod;
        printf("%lld\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值