<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />


一、网络环境

5CISCO7204组成的网络,一台为P路由器,两台PE路由器,两台CE路由器;

二、网络描述

P和两台PE路由器这间通过OSPF动态路由协议完成MPLS网络的建立,两台PE路由器这间启用BGP路由协议,在PE路由器上向所属的CE路由器指×××路由,在CE路由器中向PE路由器配置静态路由。

配置思路:

1 、在P和两台PE路由器这间通过OSPF动态路由协议,在PPE路由器两两互连的端口上启用MPLS,两台PE之间的路为备份路由,这属公网路由。

2 、两台PE路由器这间启用BGP路由协议,这使得属于×××IP地址能在两个网络(两台CE所属的网络)互相发布,这属私网(×××)路由。

3 、在PE路由器上向所属的CE路由器指×××路由,这打通了两个网络(两台CE所属的网络)之间的路由。

三、网络拓扑图

<?xml:namespace prefix = v ns = "urn:schemas-microsoft-com:vml" />

四、P路由器配置

p#SHOW RUN
Building configuration...

 

Current configuration : 1172 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname p
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
ip cef
ip audit po max-events 100
!
!
interface Loopback0
 ip address 202.98.4.3 255.255.255.255
!
interface FastEthernet0/0
 description to_r2
 ip address <?xml:namespace prefix = st1 ns = "urn:schemas-microsoft-com:office:smarttags" />10.1.1.10 255.255.255.252
 ip ospf cost 20
 duplex full
 tag-switching mtu 1508
 tag-switching ip
!
interface FastEthernet1/0
 description to_r3
 ip address 10.1.1.6 255.255.255.252
 ip ospf cost 20
 duplex full
 tag-switching mtu 1508
 tag-switching ip
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet3/0
 no ip address
 shutdown
 duplex half
!
router ospf 100
 log-adjacency-changes
 redistribute connected subnets
 redistribute static subnets
 network 10.1.1.6 0.0.0.0 area 0
 network 10.1.1.10 0.0.0.0 area 0
!
ip classless
no ip http server
no ip http secure-server
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
!
end

 

p#

 

五、PE1路由器配置

pe1#show run
Building configuration...

 

Current configuration : 1813 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname pe1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
ip vrf ***a
 rd 1:100
 route-target export 200:1
 route-target import 200:1
!        
ip cef
ip audit po max-events 100
!
!
interface Loopback0
 ip address 202.98.4.1 255.255.255.255
!        
interface FastEthernet0/0
 description to_r5
 ip vrf forwarding ***a
 ip address 172.16.1.1 255.255.255.252
 duplex full
 tag-switching ip
!
interface FastEthernet1/0
 description to_r1
 ip address 10.1.1.5 255.255.255.252
 ip ospf cost 20
 duplex full
 tag-switching mtu 1508
 tag-switching ip
!
interface FastEthernet2/0
 ip address 10.1.1.1 255.255.255.252
 ip ospf cost 100
 duplex full
 tag-switching mtu 1508
 tag-switching ip
!
interface FastEthernet3/0
 no ip address
 shutdown
 duplex half
!
router ospf 100
 log-adjacency-changes
 redistribute connected metric-type 1 subnets
 network 10.1.1.0 0.0.0.255 area 0
 network 202.98.4.0 0.0.0.255 area 0
!
router bgp 100
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 202.98.4.2 remote-as 100
 neighbor 202.98.4.2 update-source Loopback0
 neighbor 202.98.4.2 version 4
 !
 address-family ***v4
 neighbor 202.98.4.2 activate
 neighbor 202.98.4.2 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf ***a
 redistribute connected
 redistribute static
 no auto-summary
 no synchronization
 exit-address-family
!
ip classless
ip route vrf ***a 192.168.3.0 255.255.255.0 172.16.1.2
no ip http server
no ip http secure-server
!
ip ospf name-lookup
!
!
gatekeeper
 shutdown
!        
!
line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
!
end

 

pe1#

六、PE2路由器配置

pe2#show run
Building configuration...

 

Current configuration : 1725 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname pe2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
ip vrf ***a
 rd 1:100
 route-target export 200:1
 route-target import 200:1
!        
ip cef
ip audit po max-events 100
!
!
interface Loopback0
 ip address 202.98.4.2 255.255.255.255
!        
interface FastEthernet0/0
 description to_r1
 ip address 10.1.1.9 255.255.255.252
 ip ospf cost 20
 duplex full
 tag-switching ip
!
interface FastEthernet1/0
 ip vrf forwarding ***a
 ip address 172.16.2.1 255.255.255.0
 duplex full
 tag-switching ip
!
interface FastEthernet2/0
 ip address 10.1.1.2 255.255.255.252
 ip ospf cost 100
 duplex full
 tag-switching ip
!
interface FastEthernet3/0
 no ip address
 shutdown
 duplex half
!
router ospf 100
 log-adjacency-changes
 redistribute connected metric 1 subnets
 redistribute static metric-type 1 subnets
 network 10.1.1.0 0.0.0.255 area 0
!
router bgp 100
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 202.98.4.1 remote-as 100
 neighbor 202.98.4.1 update-source Loopback0
 neighbor 202.98.4.1 version 4
 !
 address-family ***v4
 neighbor 202.98.4.1 activate
 neighbor 202.98.4.1 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf ***a
 redistribute connected
 redistribute static
 no auto-summary
 no synchronization
 exit-address-family
!
ip classless
ip route vrf ***a 192.168.4.0 255.255.255.0 172.16.2.2
no ip http server
no ip http secure-server
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
!
End

七、CE1路由器配置

ce1#show run
Building configuration...

 

Current configuration : 892 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ce1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
ip cef
ip audit po max-events 100
!
!
interface Loopback0
 ip address 192.168.3.1 255.255.255.0
!
interface FastEthernet0/0
 description to_r3
 ip address 172.16.1.2 255.255.255.252
 duplex full
!        
interface FastEthernet1/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet3/0
 no ip address
 shutdown
 duplex half
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.1.1
no ip http server
no ip http secure-server
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
!
end

八、CE2路由器配置

Ce2#show run
Building configuration...

 

*Sep  3 13:53:56.167: %SYS-5-CONFIG_I: Configured from console by console
Current configuration : 888 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ce2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
ip cef
ip audit po max-events 100
!
!
interface Loopback0
 ip address 10.10.13.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!        
interface FastEthernet1/0
 description to_r2
 ip address 10.10.12.2 255.255.255.0
 duplex full
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet3/0
 no ip address
 shutdown
 duplex half
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.2.1
no ip http server
no ip http secure-server
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
!
end

 

九、业务测试

ce1# ping 172.16.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 96/190/324 ms
ce1#

 

ce2#ping 192.168.3.1

 

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 336/468/588 ms
ce2#