快速交换对递归查询进行了限制,仅对去往每个目标网络的第1个进行递归查询,从而有效地降低了这些不利的影响。
 
r1 配置
router>en
router#conf t
router(config)#host r1
r1(config)#ena sec 123
r1(config)#no ip domain-lookup
r1(config)#ban mot #Welcome to r1#
r1(config)#line vty 0 4
r1(config-line)#no login
r1(config-line)#line con 0
r1(config-line)#no exec-time
r1(config-line)#ipv6 unicast-routing
r1(config)#ipv6 cef
r1(config)#int f 0/0
r1(config-if)#ipv6 add fec0:0:0:1::/64 eui-64
r1(config-if)#des link to r2
r1(config-if)#no shut
r1(config-if)#exit
r1(config)#ipv6 route fec0:0:0:4::/64 fec0::3:c800:dff:fe84:0
r1(config)#ipv6 route fec0:0:0:3::/64 fec0::2:c800:dff:fe04:0
r1(config)#ipv6 route fec0:0:0:2::/64 fec0::1:c800:cff:fea4:0

r1(config)#end
r1#
r2 配置
router>en
router#conf t
router(config)#host r2
r2(config)#ena sec 123
r2(config)#no ip domain-lookup
r2(config)#ban mot #Welcome to r2#
r2(config)#line vty 0 4
r2(config-line)#no login
r2(config-line)#line con 0
r2(config-line)#no exec-time
r2(config-line)#ipv6 unicast-routing
r2(config)#ipv6 cef
r2(config)#int f 0/0
r2(config-if)#ipv6 add fec0:0:0:1::/64 eui-64
r2(config-if)#des link to r1
r2(config-if)#no shut
r2(config-if)#int f 1/0
r2(config-if)#ipv6 add fec0:0:0:2::/64 eui-64
r2(config-if)#des link to r3
r2(config-if)#no shut
r2(config-if)#exit
r2(config)#ipv6 route fec0:0:0:3::/64 fec0::2:c800:dff:fe04:0
r2(config)#ipv6 route fec0:0:0:4::/64 fec0::2:c800:dff:fe04:0
r2(config-if)#end
r2#
r3 配置
router>en
router#conf t
router(config)#host r3
r3(config)#ena sec 123
r3(config)#no ip domain-lookup
r3(config)#ban mot #Welcome to r3#
r3(config)#line vty 0 4
r3(config-line)#no login
r3(config-line)#line con 0
r3(config-line)#no exec-time
r3(config-line)#ipv6 unicast-routing
r3(config)#ipv6 cef
r3(config)#int f 0/0
r3(config-if)#ipv6 add fec0:0:0:2::/64 eui-64
r3(config-if)#des link to r2
r3(config-if)#no shut
r3(config-if)#int f 1/0
r3(config-if)#ipv6 add fec0:0:0:3::/64 eui-64
r3(config-if)#des link to r4
r3(config-if)#no shut
r3(config-if)#exit
r3(config)#ipv6 route fec0:0:0:1::/64 fec0::2:c800:cff:fea4:1c
r3(config)#ipv6 route fec0:0:0:4::/64 fec0::3:c800:dff:fe84:0
r3(config-if)#end
r3#
r4 配置
router>en
router#conf t
router(config)#host r4
r4(config)#ena sec 123
r4(config)#no ip domain-lookup
r4(config)#ban mot #Welcome to r4#
r4(config)#line vty 0 4
r4(config-line)#no login
r4(config-line)#line con 0
r4(config-line)#no exec-time
r4(config-line)#ipv6 unicast-routing
r4(config)#ipv6 cef
r4(config)#int f 0/0
r4(config-if)#ipv6 add fec0:0:0:3::/64 eui-64
r4(config-if)#des link to r3
r4(config-if)#no shut
r4(config-if)#int f 1/0
r4(config-if)#ipv6 add fec0:0:0:4::/64 eui-64
r4(config-if)#no shut
r4(config-if)#exit
r4(config)#ipv6 route fec0:0:0:1::/64 fec0::3:c800:dff:fe04:1c
r4(config)#ipv6 route fec0:0:0:2::/64 fec0::3:c800:dff:fe04:1c
r4(config)#end
r4#
 

r1#show run
Building configuration...
Current configuration : 816 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$P./B$Mmdovo6DzJCYqRjbdpaW2/
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description link to r2
 no ip address
 duplex half
 ipv6 address FEC0:0:0:1::/64 eui-64
!
ip classless
no ip http server
!
!
ipv6 route FEC0:0:0:2::/64 FEC0::1:C800:CFF:FEA4:0
ipv6 route FEC0:0:0:3::/64 FEC0::2:C800:DFF:FE04:0
ipv6 route FEC0:0:0:4::/64 FEC0::3:C800:DFF:FE84:0
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
banner motd ^CWelcome to r1^C
!
line con 0
 exec-timeout 0 0
 stopbits 1
line aux 0
 stopbits 1
 line vty 0 4
 no login
!
!
end
r1#show ipv6 route
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
L   FE80::/10 [0/0]
     via ::, Null0
C   FEC0:0:0:1::/64 [0/0]
     via ::, FastEthernet0/0
L   FEC0::1:C800:CFF:FE18:0/128 [0/0]
     via ::, FastEthernet0/0
S   FEC0:0:0:2::/64 [1/0]
     via FEC0::1:C800:CFF:FEA4:0
S   FEC0:0:0:3::/64 [1/0]
     via FEC0::2:C800:DFF:FE04:0
S   FEC0:0:0:4::/64 [1/0]
     via FEC0::3:C800:DFF:FE84:0
L   FF00::/8 [0/0]
     via ::, Null0
r1#telnet fec0::1:c800:cff:fea4:0
Trying FEC0::1:C800:CFF:FEA4:0 ... Open
Welcome to r2
r2>en
Password:
r2#show run
Building configuration...
Current configuration : 882 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$7bCs$E2aY3mS/77RQUjZ2QIvp//
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description link to r1
 no ip address
 duplex half
 ipv6 address FEC0:0:0:1::/64 eui-64
!
interface FastEthernet1/0
 description link to r2
 no ip address
 duplex half
 ipv6 address FEC0:0:0:2::/64 eui-64
!
ip classless
no ip http server
!
!
ipv6 route FEC0:0:0:3::/64 FEC0::2:C800:DFF:FE04:0
ipv6 route FEC0:0:0:4::/64 FEC0::2:C800:DFF:FE04:0
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
banner motd ^CWelcome to r2^C
!
 line con 0
 exec-timeout 0 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 no login
!
!
end
r2#show ipv6 route
IPv6 Routing Table - 8 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
L   FE80::/10 [0/0]
     via ::, Null0
C   FEC0:0:0:1::/64 [0/0]
     via ::, FastEthernet0/0
L   FEC0::1:C800:CFF:FEA4:0/128 [0/0]
     via ::, FastEthernet0/0
C   FEC0:0:0:2::/64 [0/0]
     via ::, FastEthernet1/0
L   FEC0::2:C800:CFF:FEA4:1C/128 [0/0]
     via ::, FastEthernet1/0
S   FEC0:0:0:3::/64 [1/0]
     via FEC0::2:C800:DFF:FE04:0
S   FEC0:0:0:4::/64 [1/0]
     via FEC0::2:C800:DFF:FE04:0
L   FF00::/8 [0/0]
     via ::, Null0
r2#telnet fec0::2:c800:dff:fe04:0
Trying FEC0::2:C800:DFF:FE04:0 ... Open
Welcome to r3
r3>en
Password:
r3#show run
Building configuration...
Current configuration : 883 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r3
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$vHu8$YklVh31cbXlIYk.wp0SrE/
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description link to r2
 no ip address
 duplex half
 ipv6 address FEC0:0:0:2::/64 eui-64
!
interface FastEthernet1/0
 description link to r4
 no ip address
 duplex half
 ipv6 address FEC0:0:0:3::/64 eui-64
!
ip classless
no ip http server
!
!
ipv6 route FEC0:0:0:1::/64 FEC0::2:C800:CFF:FEA4:1C
ipv6 route FEC0:0:0:4::/64 FEC0::3:C800:DFF:FE84:0
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
banner motd ^CWelcome to r3^C
!
 line con 0
 exec-timeout 0 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 no login
!
!
end
r3#show ipv6 route
IPv6 Routing Table - 8 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
L   FE80::/10 [0/0]
     via ::, Null0
S   FEC0:0:0:1::/64 [1/0]
     via FEC0::2:C800:CFF:FEA4:1C
C   FEC0:0:0:2::/64 [0/0]
     via ::, FastEthernet0/0
L   FEC0::2:C800:DFF:FE04:0/128 [0/0]
     via ::, FastEthernet0/0
C   FEC0:0:0:3::/64 [0/0]
     via ::, FastEthernet1/0
L   FEC0::3:C800:DFF:FE04:1C/128 [0/0]
     via ::, FastEthernet1/0
S   FEC0:0:0:4::/64 [1/0]
     via FEC0::3:C800:DFF:FE84:0
L   FF00::/8 [0/0]
     via ::, Null0
r3#telnet fec0::3:c800:dff:fe84:0
Trying FEC0::3:C800:DFF:FE84:0 ... Open
Welcome to r4
r4>en
Password:
r4#show run
Building configuration...
Current configuration : 873 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r4
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$uHj3$vaEbjlilbjQt0TTtei0ou.
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description link to r4
 no ip address
 duplex half
 ipv6 address FEC0:0:0:3::/64 eui-64
!
interface FastEthernet1/0
 no ip address
 duplex half
 ipv6 address FEC0:0:0:4::/64 eui-64
 no ipv6 cef
!
ip classless
no ip http server
!
!
ipv6 route FEC0:0:0:1::/64 FEC0::3:C800:DFF:FE04:1C
ipv6 route FEC0:0:0:2::/64 FEC0::3:C800:DFF:FE04:1C
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
banner motd ^CWelcome to r4^C
!
 line con 0
 exec-timeout 0 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 no login
!
!
end
r4#show ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
L   FE80::/10 [0/0]
     via ::, Null0
S   FEC0:0:0:1::/64 [1/0]
     via FEC0::3:C800:DFF:FE04:1C
S   FEC0:0:0:2::/64 [1/0]
     via FEC0::3:C800:DFF:FE04:1C
C   FEC0:0:0:3::/64 [0/0]
     via ::, FastEthernet0/0
L   FEC0::3:C800:DFF:FE84:0/128 [0/0]
     via ::, FastEthernet0/0
L   FF00::/8 [0/0]
     via ::, Null0
r4#exit
[Connection to fec0::3:c800:dff:fe84:0 closed by foreign host]
r3#exit
[Connection to fec0::2:c800:dff:fe04:0 closed by foreign host]
r2#exit
[Connection to fec0::1:c800:cff:fea4:0 closed by foreign host]
r1#ping ipv6 fec0::3:c800:dff:fe84:0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::3:C800:DFF:FE84:0, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 240/372/472 ms
r1#ping ipv6 fec0::3:c800:dff:fe04:1c
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::3:C800:DFF:FE04:1C, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 188/276/348 ms
r1#ping ipv6 fec0::2:c800:dff:fe04:0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::2:C800:DFF:FE04:0, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 144/285/420 ms
r1#