不同网段的直连怎么互通_细讲交换机配置,什么样的网络能互通,什么样的网络不能互通?...

我们曾多次提到交换机的配置,有部分朋友反映有点深了,有些内容不懂,今天我们就从基础到深入来了解网络间如何才能互通,如何才能不通,以案例的方式来详细讲解,一文了解清楚vlan的使用与配置,方便后面应用于项目中。

因为根据弱电VIP技术群朋友反映,华为交换机使用的比较多,所以本次以华为交换机为例,如果大家以前对vlan了解不深,那么这篇文章却是可以很好入门与深入。

一、什么样的网络才能互通

通常情况下,两台电脑如何能才互通呢?如何才能不能互相访问呢?

最简章方法就是利用网段来解决,我们来举例。

bd2502e6fff7e60ad3326b1f1341ec72.png

1、两台电脑不能互相访问

假设:

PC1 ip地址:192.168.1.1/24

PC2 ip地址:192.168.2.1/24

要测试PC1和PC2的连通性:最简单的方法就是用PC1去PingPC2,查看Ping的结果。

da3010e18eadc4271228809002440085.png

很明显ping不通,PC1和PC2的ip在不同的网段,不能ping通。

那么什么样的情况能ping通呢?

2、如何才能互访

假设:

PC1的ip地址:192.168.1.1/24

PC2的IP地址:192.168.1.2/24

PC3的ip地址: 192.168.1.3/24

都在同一个网段内,用测试pc1是否能互访pc2与pc3,直接用pc1去ping pc2与pc3就行。

pc1去ping pc2

191c31f73662978888af05cd387133d4.png

pc1去ping pc3

ae417495c1c1923bd34a5dbcfdb2c4f3.png

很明显,两个都是可以ping通的,因为PC1-PC5在同一个网段内,使用是相同的网关。

那么问题来了,如何让同一个网段的ip不能互通呢?如何让不同网段ip又能互通

?这里面我们就需要引进vlan了。

二、划分vlan,实现网络的互访与阻绝

上面我们已经演示了网络最简单的互通与不通的情况,在没有其它设置的情况下,同一个网段的ip地址,能互通,不同的网段的ip地址不能互通。而在实际项目中,并不是这么简单的,我们来看下不同vlan与不同网段之间的互通与阻绝如何实现。

还是这个拓扑图:

4e12f00f4b80bdca2a0cf923095666d5.png

假设:

PC1的ip地址:192.168.1.1/24 连接LSW1交换机端口Ethernet 0/0/1

PC2的IP地址:192.168.1.2/24 连接LSW1交换机端口Ethernet 0/0/2

PC3的ip地址: 192.168.1.3/24 连接LSW1交换机端口Ethernet 0/0/3

PC4的ip地址: 192.168.1.4/24 连接LSW2交换机端口Ethernet 0/0/1

现在要让pc1与pc2互访,p1与pc3不能互通,pc1与pc4也不能互访,如何来配置交换机?(今天我们就以华为交换机为例)。

交换机配置(以华为交换机为例)

1、配置LSW1

system-view //进入系统视图

[Huawei]sysname sw1 //给交换机命名

[sw1]vlan 10 //创建VLAN10

[sw1-vlan10]vlan 20 //创建VLAN20

[sw1-vlan20]display vlan //显示VLAN信息

[sw1-vlan20]quit //退回上一级视图

[sw1]interface Ethernet 0/0/1 //进入以太网接口0/0/1

[sw1-Ethernet0/0/1]port link-type access //配置接口类型为Access

[sw1-Ethernet0/0/1]port default vlan 10 //分配接口给VLAN10

[sw1-Ethernet0/0/1]quit //退回上一级视图

[sw1]interface Ethernet 0/0/2 //进入以太网接口0/0/2

[sw1-Ethernet0/0/2]port link-type access //配置接口类型为Access

[sw1-Ethernet0/0/2]port default vlan 10 //分配接口给VLAN10

[sw1-Ethernet0/0/2]quit //退回上一级视图

[sw1]interface Ethernet 0/0/3 //进入以太网接口0/0/3

[sw1-Ethernet0/0/3]port link-type access //配置接口类型为Access

[sw1-Ethernet0/0/3]port default vlan 20 //分配接口给VLAN20

[sw1-Ethernet0/0/3]display vlan //显示VLAN信息

小结:在LSW1中,把pc1与pc2分配在了vlan10,把pc3分配到了vlan20中。

2、LSW2交换机配置

命令与上面类似,就不一 一注释了,多看几篇就很容易理解。

system-view

[Huawei]sysname sw2

[sw2]vlan 10 //批量创建VLAN

[sw2]display vlan

[sw2]interface Ethernet 0/0/1 //进入pc4的以太网接口0/0/1

[sw2-Ethernet0/0/1]port link-type access //配置接口类型为Access

[sw2-Ethernet0/0/1]port default vlan 10 //分配接口给VLAN10

[sw2-Ethernet0/0/2]display vlan

在LSW2中,主要是把pc4划分给了vlan10

3、验证vlan

a、测试PC1和PC2的连通性。

f8e06fbc47b028bb836c4408cd914261.png

因为在同一个vlan且在相同的网段,所以PC1和PC2能够ping通。

b、测试PC1和PC3的连通性

8f1e67ed0067bda009e81581ab530b46.png

虽然pc1与pc3的ip地址在同一个网段里面,但PC1和PC3不在同一个vlan中,所以PC1和PC3不能ping通(pc1是属于vlan10,pc3是属于vlan20)。

c、测试PC1和PC4的连通性

d4fdd618e0da314b95d440fad128f804.png

很明显也pc1与pc4不能ping通,这个是为什么呢?

虽然PC1和PC4在同一个vlan且也在同一个网段中,但是Lsw1和Lsw2交换机没有配置trunk端口,access端口没有tag标记,通不过trunk端口,所以ping不通!

那么问题来了,如何才能让pc1与pc4互通呢?

二、如何使交换机间互相通信

上面我们提到了,pc1是属于LSW1交换机,pc4是属于SLW2交换机,虽然pc1与pc4是划分到了同一个vlan,且ip地址也在同一个网段,但仍然无法互相通信,主要是没有配置trunk接口,我们来配置下。

4e12f00f4b80bdca2a0cf923095666d5.png

1、LSW1的配置

[sw1]interface Ethernet 0/0/4 // 进入交换机1与交换机2连接的接口0/0/4

[sw1-Ethernet0/0/4]port link-type trunk //配置接口类型为trunk

[sw1-Ethernet0/0/4]port trunk allow-pass vlan 10 20 //trunk口允许通过的VLAN10与vlan20

2、LSW2的配置

[sw2]interface Ethernet 0/0/3 // 进入交换机1与交换机2连接的接口0/0/3

[sw2-Ethernet0/0/3]port link-type trunk //配置接口类型为trunk

[sw2-Ethernet0/0/3]port trunk allow-pass vlan 10 20

//trunk口允许通过的VLAN10与vlan20

3、验证trunk接口配置:

测试PC1和PC4的连通性,并解释原因。

6de9ff89a7291cc5a4c9ce634efe8e2b.png

PC1和PC4能够ping通,因为交换机之间设置了trunk接口,使得不同vlan之间能够通过其他的交换机!

最后总结下:

1、什么情况下,我们才会去划分VLAN。

让网络进行逻辑隔绝,才会划分vlan!不同的vlan中,即使在相同的网段也不能ping通,

2、什么情况下,我们才会去配置trunk接口。

要让交换机和交换机之间连通,需要设置trunk接口。

AI人工智能-安防课程,安防行业目前难得诚意的在线课程,点击左下角“ 了解更多”进行报名,系统化丰富您的“安防+AI”技术储备。

bd1006e59a2c249198a0352a171a6784.gif

点击下面“了解更多”试听课程。

已标记关键词 清除标记
表情包
插入表情
评论将由博主筛选后显示,对所有人可见 | 还能输入1000个字符
相关推荐
DirectX修复工具(DirectX Repair)是一款系统级工具软件,简便易用。本程序为绿色版,无需安装,可直接运行。 本程序的主要功能是检测当前系统的DirectX状态,如果发现异常则进行修复。程序主要针对0xc000007b问题设计,可以完美修复该问题。本程序中包含了最新版的DirectX redist(Jun2010),并且全部DX文件都有Microsoft的数字签名,安全放心。 本程序为了应对一般电脑用户的使用,采用了易用的一键式设计,只要点击主界面上的“检测并修复”按钮,程序就会自动完成校验、检测、下载、修复以及注册的全部功能,无需用户的介入,大大降低了使用难度。在常规修复过程中,程序还会自动检测DirectX加速状态,在异常时给予用户相应提示。 本程序适用于多个操作系统,如Windows XP(需先安装.NET 2.0,详情请参阅“致Windows XP用户.txt”文件)、Windows Vista、Windows 7、Windows 8、Windows 8.1、Windows 8.1 Update、Windows 10,同时兼容32位操作系统和64位操作系统。本程序会根据系统的不同,自动调整任务模式,无需用户进行设置。 本程序的V4.0版分为标准版、增强版以及在线修复版。所有版本都支持修复DirectX的功能,而增强版则额外支持修复c++的功能。在线修复版功能与标准版相同,但其所需的数据包需要在修复时自动下载。各个版本之间,主程序完全相同,只是其配套使用的数据包不同。因此,标准版和在线修复版可以通过补全扩展包的形式成为增强版。本程序自V3.5版起,自带扩展功能。只要在主界面的“工具”菜单下打开“选项”对话框,找到“扩展”标签,点击其中的“开始扩展”按钮即可。扩展过程需要Internet连接,扩展成功后新的数据包可自动生效。扩展用时根据网络速度不同不同,最快仅需数秒,最慢需要数分钟,烦请耐心等待。如扩展失败,可点击“扩展”界面左上角小锁图标切换为加密连接,即可很大程度上避免因防火墙或其他原因导致的连接失败。 本程序自V2.0版起采用全新的底层程序架构,使用了异步多线程编程技术,使得检测、下载、修复单独进行,互不干扰,快速如飞。新程序更改了自我校验方式,因此使用新版本的程序时不会再出现自我校验失败的错误;但并非取消自我校验,因此程序安全性与之前版本相同,并未降低。 程序有更新系统c++功能。由于绝大多数软件运行时需要c++的支持,并且c++的异常也会导致0xc000007b错误,因此程序在检测修复的同时,也会根据需要更新系统中的c++组件。自V3.2版本开始使用了全新的c++扩展包,可以大幅提高工业软件修复成功的概率。修复c++的功能仅限于增强版,标准版及在线修复版在系统c++异常时(非丢失时)会提示用户使用增强版进行修复。除常规修复外,新版程序还支持C++强力修复功能。当常规修复无效时,可以到本程序的选项界面内开启强力修复功能,可大幅提高修复成功率。请注意,请仅在常规修复无效时再使用此功能。 程序有两种窗口样式。正常模式即默认样式,适合绝大多数用户使用。另有一种简约模式,此时窗口将只显示最基本的内容,修复会自动进行,修复完成10秒钟后会自动退出。该窗口样式可以使修复工作变得更加简单快速,同时方便其他软件、游戏将本程序内嵌,即可进行无需人工参与的快速修复。开启简约模式的方法是:打开程序所在目录下的“Settings.ini”文件(如果没有可以自己创建),将其中的“FormStyle”一项的值改为“Simple”并保存即可。 新版程序支持命令行运行模式。在命令行中调用本程序,可以在路径后直接添加命令进行相应的设置。常见的命令有7类,分别是设置语言的命令、设置窗口模式的命令,设置安全级别的命令、开启强力修复的命令、设置c++修复模式的命令、控制Direct加速的命令、显示版权信息的命令。具体命令名称可以通过“/help”或“/?”进行查询。 程序有高级筛选功能,开启该功能后用户可以自主选择要修复的文件,避免了其他不必要的修复工作。同时,也支持通过文件进行辅助筛选,只要在程序目录下建立“Filter.dat”文件,其中的每一行写一个需要修复文件的序号即可。该功能仅针对高级用户使用,并且必须在正常窗口模式下才有效(简约模式时无效)。 本程序有自动记录日志功能,可以记录每一次检测修复结果,方便在出现问题时,及时分析和查找原因,以便找到解决办法。 程序的“选项”对话框中包含了7项高级功能。点击"常规”选项卡可以调整程序的基本运行情况,包括日志记录、安全级别控制、调试模式开启等。只有开启调试模式后才能在C
©️2020 CSDN 皮肤主题: 1024 设计师:白松林 返回首页