Ducci Sequence解题报告

A Ducci sequence is a sequence of n-tuples of integers. Given an n-tuple of integers (a1a2, ... an), the next n-tuple in the sequence is formed by taking the absolute differences of neighboring integers:

 

 

a 1a 2... a n$\displaystyle \rightarrow$ (|  a 1 -  a 2|,|  a 2 -  a 3|,  ... ,|  a n -  a 1|)

 

Ducci sequences either reach a tuple of zeros or fall into a periodic loop. For example, the 4-tuple sequence starting with 8,11,2,7 takes 5 steps to reach the zeros tuple:

 

 

(8, 11, 2, 7)  $\displaystyle \rightarrow$ (3, 9, 5, 1)  $\displaystyle \rightarrow$ (6, 4, 4, 2)  $\displaystyle \rightarrow$ (2, 0, 2, 4)  $\displaystyle \rightarrow$ (2, 2, 2, 2)  $\displaystyle \rightarrow$ (0, 0, 0, 0).

 

The 5-tuple sequence starting with 4,2,0,2,0 enters a loop after 2 steps:

 

 

(4, 2, 0, 2, 0)  $\displaystyle \rightarrow$ (2, 2, 2, 2, 4)  $\displaystyle \rightarrow$ (  0, 0, 0, 2, 2$\displaystyle \rightarrow$ (0, 0, 2, 0, 2)  $\displaystyle \rightarrow$ (0, 2, 2, 2, 2)  $\displaystyle \rightarrow$ (2, 0, 0, 0, 2)  $\displaystyle \rightarrow$

 

 

(2, 0, 0, 2, 0)  $\displaystyle \rightarrow$ (2, 0, 2, 2, 2)  $\displaystyle \rightarrow$ (2, 2, 0, 0, 0)  $\displaystyle \rightarrow$ (0, 2, 0, 0, 2)  $\displaystyle \rightarrow$ (2, 2, 0, 2, 2)  $\displaystyle \rightarrow$ (0, 2, 2, 0, 0)  $\displaystyle \rightarrow$

 

 

(2, 0, 2, 0, 0)  $\displaystyle \rightarrow$ (2, 2, 2, 0, 2)  $\displaystyle \rightarrow$ (0, 0, 2, 2, 0)  $\displaystyle \rightarrow$ (0, 2, 0, 2, 0)  $\displaystyle \rightarrow$ (2, 2, 2, 2, 0)  $\displaystyle \rightarrow$ (  0, 0, 0, 2, 2$\displaystyle \rightarrow$  ...

 

Given an n-tuple of integers, write a program to decide if the sequence is reaching to a zeros tuple or a periodic loop.

 

Input 

Your program is to read the input from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing an integer n(3$ \le$n$ \le$15), which represents the size of a tuple in the Ducci sequences. In the following line, n integers are given which represents the n-tuple of integers. The range of integers are from 0 to 1,000. You may assume that the maximum number of steps of a Ducci sequence reaching zeros tuple or making a loop does not exceed 1,000.

 

Output 

Your program is to write to standard output. Print exactly one line for each test case. Print `LOOP' if the Ducci sequence falls into a periodic loop, print `ZERO' if the Ducci sequence reaches to a zeros tuple.

The following shows sample input and output for four test cases.

 

Sample Input 

 

4 
4 
8 11 2 7 
5 
4 2 0 2 0 
7 
0 0 0 0 0 0 0 
6 
1 2 3 1 2 3

 

Sample Output 

 

ZERO 
LOOP 
ZERO 
LOOP


题意:给你一个数组,相邻数相加(最后一个数应该加第一个数),然后又可以得到一个新的数组,反复进行这样的步骤,结果会有两种,数组每个成员都是零,或者在这样的过程中出现了周期,即出现了和以前已经出现过的相同的项。
最后要求判断是哪一种情况

思路:
如果按照一般的解题思想,每得到一个新的数组都去判断是zero,还是loop。zero还好说,如果判断loop那就要每次遍历一遍数组,程序肯定会超时。、
所以~~~
反正结果只有两种可能,不是loop,就是zero,只判断zero就好了

代码:
#include <iostream>
#include <cstdio>
using namespace std;
const int maxn=16;
int a[2][maxn];
int n;
int iszero;

void Init()
{
    cin>>n;
    for(int i=0;i<n;i++)
    cin>>a[0][i];
}

bool judge()
{
    iszero=0;
    int now,form;
    for(int i=1;i<=200;i++)
    {
        if(i%2==1) now=1,form=0;
        else now=0,form=1;
       for(int j=0;j<n;j++)
       {
           if(j==n-1)
           {
               a[now][j]=a[form][j]+a[form][0];
           }
           else
           a[now][j]=a[form][j]+a[form][j+1];
       }
       int flag=0;
       for(int k=0;k<n;k++)
       if(a[now][k]!=0) {flag=1;break;}
       if(!flag) {iszero=1;break;}
    }
    if(iszero) return true;
    else       return false;
}

int main()
{
    int T;
    cin>>T;
    while(T--)
    {
     Init();
     if(judge()) cout<<"ZERO"<<endl;
     else cout<<"LOOP"<<endl;
    }
    return 0;
}
View Code

 

 

 

转载于:https://www.cnblogs.com/zsyacm666666/p/4652545.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值