R7:

ip dhcp use vrf connected

!

ip dhcp pool ×××_A_DHCP_POOL

vrf ×××_A

network 192.168.7.0 255.255.255.0

default-router 192.168.7.1

!

ip dhcp pool ×××_B_DHCP_POOL

vrf ×××_B

network 192.168.8.0 255.255.255.0

default-router 192.168.8.1

!

ip vrf ×××_A

rd 5678:71

route-target export 5678:71

route-target import 5678:81

route-target import 5678:71

!

ip vrf ×××_B

rd 5678:72

route-target export 5678:82

route-target export 5678:72

route-target import 5678:82

route-target import 5678:72

!

interface Loopback0

ip address 7.7.7.7 255.255.255.255

!

interface FastEthernet0/0

ip vrf forwarding ×××_A

ip address 192.168.7.1 255.255.255.0

duplex auto

speed auto

mpls ip

!

interface Serial0/0

ip address 57.0.0.7 255.255.255.0

mpls ip

clock rate 2000000

!

interface FastEthernet0/1

ip vrf forwarding ×××_B

ip address 192.168.8.1 255.255.255.0

duplex auto

speed auto

mpls ip

!

router ospf 100

router-id 7.7.7.7

log-adjacency-changes

passive-interface Loopback0

network 7.7.7.7 0.0.0.0 area 0

network 57.0.0.7 0.0.0.0 area 0

!

router bgp 5678

bgp router-id 7.7.7.7

no bgp default ipv4-unicast

bgp log-neighbor-changes

neighbor LOCAL_AS peer-group

neighbor LOCAL_AS remote-as 5678

neighbor LOCAL_AS update-source Loopback0

neighbor 8.8.8.8 peer-group LOCAL_AS

!

address-family ***v4

neighbor LOCAL_AS send-community extended

neighbor 8.8.8.8 activate

exit-address-family

!

address-family ipv4 vrf ×××_B

no auto-summary

no synchronization

network 192.168.8.0

exit-address-family

!

address-family ipv4 vrf ×××_A

no auto-summary

no synchronization

network 192.168.7.0

exit-address-family

!

 

 

ip dhcp use vrf connected

!

ip dhcp pool ×××_A_DHCP_POOL

vrf ×××_A

network 172.16.7.0 255.255.255.0

default-router 172.16.7.1

!

ip dhcp pool ×××_B_DHCP_POOL

vrf ×××_B

network 172.16.8.0 255.255.255.0

default-router 172.16.8.1

!

!

ip vrf ×××_A

rd 5678:81

route-target export 5678:71

route-target export 5678:81

route-target import 5678:71

route-target import 5678:81

!

ip vrf ×××_B

rd 5678:82

route-target export 5678:72

route-target export 5678:82

route-target import 5678:72

route-target import 5678:82

!

interface Loopback0

ip address 8.8.8.8 255.255.255.255

!

interface FastEthernet0/0

ip vrf forwarding ×××_A

ip address 172.16.7.1 255.255.255.0

duplex auto

speed auto

mpls ip

!

interface Serial0/0

ip address 68.0.0.8 255.255.255.0

mpls ip

clock rate 2000000

!

interface FastEthernet0/1

ip vrf forwarding ×××_B

ip address 172.16.8.1 255.255.255.0

duplex auto

speed auto

mpls ip

!

router ospf 100

router-id 8.8.8.8

log-adjacency-changes

passive-interface Loopback0

network 8.8.8.8 0.0.0.0 area 0

network 68.0.0.8 0.0.0.0 area 0

!

router bgp 5678

bgp router-id 8.8.8.8

no bgp default ipv4-unicast

bgp log-neighbor-changes

neighbor LOCAL_AS peer-group

neighbor LOCAL_AS remote-as 5678

neighbor LOCAL_AS update-source Loopback0

neighbor 7.7.7.7 peer-group LOCAL_AS

!

address-family ***v4

neighbor LOCAL_AS send-community extended

neighbor 7.7.7.7 activate

exit-address-family

!

address-family ipv4 vrf ×××_B

no auto-summary

no synchronization

network 172.16.8.0 mask 255.255.255.0

exit-address-family

!

address-family ipv4 vrf ×××_A

no auto-summary

no synchronization

network 172.16.7.0 mask 255.255.255.0

exit-address-family

!

R8: