Poj(3686),最小权匹配,多重匹配,KM

题目链接

The Windy's

| Time Limit: 5000MS | Memory Limit: 65536K |

| Total Submissions: 4939 | Accepted: 2080 |

Description

The Windy's is a world famous toy factory that owns M top-class workshop to make toys. This year the manager receives N orders for toys. The manager knows that every order will take different amount of hours in different workshops. More precisely, the i-th order will take Zij hours if the toys are making in the j-th workshop. Moreover, each order's work must be wholly completed in the same workshop. And a workshop can not switch to another order until it has finished the previous one. The switch does not cost any time.

The manager wants to minimize the average of the finishing time of the N orders. Can you help him?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N and M (1 ≤ N,M ≤ 50).
The next N lines each contain M integers, describing the matrix Zij (1 ≤ Zij ≤ 100,000) There is a blank line before each test case.

Output

For each test case output the answer on a single line. The result should be rounded to six decimal places.

Sample Input

3

3 4
100 100 100 1
99 99 99 1
98 98 98 1

3 4
1 100 100 100
99 1 99 99
98 98 1 98

3 4
1 100 100 100
1 99 99 99
98 1 98 98

Sample Output

2.000000
1.000000
1.333333

Source

POJ Founder Monthly Contest – 2008.08.31, windy7926778

题意:

有N个工件要在M个机器上加工,有一个N*M的矩阵描述其加工时间。同一时间内每个机器只能加工一个工件,问加工完所有工件后,使得平均加工时间最小。

分析:

1, 首先,这是一个最小权匹配,但是我没写过,然后看了一下网上的结题报告,又问了一下阳哥,发现,最小权匹配可以转换为最大权匹配,权值改为负数就可以了
2, 然后是拆点,分块,每一个机器都对应了nx个玩具。
3, 这里是最难的地方了。我也是看了结题报告才知道怎么处理这里,就是说可能一个机器加工多个玩具,比如说k个,耗时为a1,(a1+a2),(a1+a2+a3),......(a1+a2+......+ak);
那么,对于一个玩具(例如a1),他所贡献的时间其实为a1乘k,我们可以发现规律,对于倒数第k的玩具,他贡献的耗时为k*a1,那么拆点的时候,就应该是a1,a1乘2,......

当做模板好好学习吧!!!

Code(C++):

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>

using namespace std;

#define MAXN 55
#define inf 0x7ffffff

int w[MAXN][2555];
int lx[MAXN],ly[2555];
int linky[2555];
int visx[MAXN],visy[2555];
int slack[2555];
int nx,ny;
int n,m;

bool find(int x)
{
    visx[x]=1;
    for(int y=1;y<=ny;y++)
    {
        if(visy[y]) continue;
        int t=lx[x]+ly[y]-w[x][y];
        if(t==0)
        {
            visy[y]=1;
            if(linky[y] ==-1 || find(linky[y]))
            {
                linky[y]=x;
                return true;
            }
        }
        else if(slack[y] > t)
            slack[y]=t;
    }
    return false;
}

int KM()
{
    memset(linky,-1,sizeof(linky));
    memset(ly,0,sizeof(ly));
    for(int i=1;i<=nx;i++)
    {
        lx[i]=-inf;
        for(int j=1;j<=ny;j++)
            if(w[i][j] >lx[i])
                lx[i]=w[i][j];
    }
    for(int x=1;x<=nx;x++)
    {
        for(int i=1;i<=ny;i++)
            slack[i]=inf;
        while(1)
        {
            memset(visx,0,sizeof(visx));
            memset(visy,0,sizeof(visy));
            if(find(x)) break;
            int d=inf;
            for(int i=1;i<=ny;i++)
                if(!visy[i] && d>slack[i])
                    d=slack[i];
            for(int i=1;i<=nx;i++)
                if(visx[i])
                    lx[i]-=d;
            for(int i=1;i<=ny;i++)
                if(visy[i])
                    ly[i]+=d;
                else
                    slack[i]-=d;
        }
    }
    int ans=0;
    for(int i=1;i<=ny;i++)
        if(linky[i] >-1)
            ans+=w[linky[i]][i];
    return -ans;
}

void init()
{
    scanf("%d%d",&n,&m);
    nx=n;
    ny=n*m;
    int cost;
    for(int i=1;i<=n;i++)
    {
        int cnt=1;
        for(int j=1;j<=m;j++)
        {
            scanf("%d",&cost);
            for(int k=1;k<=n;k++)
            {
                w[i][cnt++]=-cost*k;
            }
        }
    }
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        init();
        double ans=1.0*KM()/n;
        printf("%.6f\n",ans);
    }
    return 0;
}

转载于:https://www.cnblogs.com/TreeDream/p/5771976.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值