hdu 1006 Tick and Tick 有技巧的暴力

Tick and Tick

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16707    Accepted Submission(s): 4083


Problem Description
The three hands of the clock are rotating every second and meeting each other many times everyday. Finally, they get bored of this and each of them would like to stay away from the other two. A hand is happy if it is at least D degrees from any of the rest. You are to calculate how much time in a day that all the hands are happy.
 

 

Input
The input contains many test cases. Each of them has a single line with a real number D between 0 and 120, inclusively. The input is terminated with a D of -1.
 

 

Output
For each D, print in a single line the percentage of time in a day that all of the hands are happy, accurate up to 3 decimal places.
 

 

Sample Input
0 120 90 -1
 

 

Sample Output
100.000 0.000 6.251
 

 

Author
PAN, Minghao
 

 

Source

 

 

计算出每两个指针满足要求的角度所需的时间,及周期,然后按周期循环。

#include<iostream>
#include<stdio.h>
using namespace std;
double max(double a,double b,double c)
{
    double temp=(a>b)?a:b;
    return (temp>c)?temp:c;
}
double min(double a,double b,double c)
{
    double temp=(a<b)?a:b;
    return (temp<c)?temp:c;
}
int main()
{
    double wh=360.0/12/3600;
    double wm=360.0/60/60;
    double ws=360.0/60;
    double whm=wm-wh;
    double whs=ws-wh;
    double wms=ws-wm;
    //cout<<whm<<endl<<whs<<endl<<wms<<endl;
    double n;
    while(~scanf("%lf",&n)&&n!=-1)
    {
        double stahm=n/whm;
        double stahs=n/whs;
        double stams=n/wms;
        double endhm=(360-n)/whm;
        double endhs=(360-n)/whs;
        double endms=(360-n)/wms;
        double shm,shs,sms,ehm,ehs,ems;
        const double T_hm=43200.0/11,T_hs=43200.0/719,T_ms=3600.0/59;   //Ïà¶ÔÖÜÆÚ
        double sum=0;
        //cout<<"do"<<endl;
        for(shm=stahm,ehm=endhm; ehm<43200.000001; shm+=T_hm,ehm+=T_hm)
        {
            //cout<<shm<<endl;
            for(shs=stahs,ehs=endhs; ehs<43200.000001; shs+=T_hs,ehs+=T_hs)
            {
                if(ehm<shs) break;
                if(shm>ehs) continue;
                for(sms=stams,ems=endms; ems<43200.000001; sms+=T_ms,ems+=T_ms)
                {
                    if(ehm<sms||ehs<sms) break;
                    if(shm>ems||shs>ems) continue;
                    //cout<<"doing"<<endl;
                    double xsta=max(shm,shs,sms);
                    double xend=min(ehm,ehs,ems);
                    if(xsta<xend)
                        sum+=(xend-xsta);

                }
            }
        }
        printf("%.3lf\n",sum/432);

    }
    return 0;
}
View Code

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值