Topology:

CE: R1, R2, R7, R8
PE: R3, R5, R6
P: R4
R1 connected to R3 and R6
R2 connected to R3 and R5
R7 connected to R5 and R6
R8 connected to R6 and R3

There are 4 links between R1&R2, R1&R8, R2&R7, R7&R8, over which I create sub interfaces to simulate the CE area and backdoor link.

×××1: 1-3-4-6-8 OSPF
rd(3456:100): 192.168.12.0/24, 172.16.13.0/24
rd(3456:800): 192.168.78.0/24, 172.16.68.0/24
backdoor(both): 192.168.27.0/24
×××2: 2-3-4-5-7 Connected, Static, RIP, eBGP
rd(3456:200): 172.16.23.0/24, 100.0.10.0/29, 100.0.20.0/24
rd(3456:700): 172.16.57.0/24, 100.0.70.0/24
×××3: 1-6-4-5-2 EIGRP
rd(3456:201): 172.16.25.0/24, 192.168.227.0/25
rd(3456:101): 172.16.16.0/24, 192.168.118.0/28
×××4: 8-3-4-6-7 ISIS: don't support in this p_w_picpath

Configuration:

R1:
R1-×××-1-3-CE#show run
Building configuration...

Current configuration : 1590 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1-×××-1-3-CE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
multilink bundle-name authenticated
!

!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!

interface Loopback0
ip address 192.168.100.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.138
encapsulation dot1Q 138
ip address 192.168.138.1 255.255.255.0
ip router isis 138
!
interface FastEthernet0/0.1652
encapsulation dot1Q 1652
ip address 192.168.118.1 255.255.255.240
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.1368
encapsulation dot1Q 1368
ip address 192.168.12.1 255.255.255.0
!
interface Ethernet1/0
ip address 172.16.16.1 255.255.255.0
half-duplex
!
interface Ethernet1/1
no ip address
shutdown
half-duplex
!
interface Ethernet1/2
no ip address
shutdown
half-duplex
!
interface Ethernet1/3
ip address 172.16.13.1 255.255.255.0
half-duplex
!
!
router eigrp 27
network 172.16.16.0 0.0.0.255
network 192.168.118.0 0.0.0.15
no auto-summary
!
router ospf 1368
log-adjacency-changes
network 172.16.13.1 0.0.0.0 area 0
network 192.168.12.1 0.0.0.0 area 1278
!
router isis 138
net 49.0138.0000.0000.0001.00
is-type level-2-only
!
ip http server
no ip http secure-server
ip forward-protocol nd
!
!
!
!
!
!

control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end





R2:
R2-×××-2-3-CE#show run
Building configuration...

Current configuration : 1735 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2-×××-2-3-CE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
multilink bundle-name authenticated
!

!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!

interface Loopback0
ip address 192.168.100.2 255.255.255.255
!
interface Loopback100
ip address 100.0.10.1 255.255.255.248
!
interface Loopback200
ip address 100.0.20.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.17
encapsulation dot1Q 1278
ip address 192.168.27.2 255.255.255.0
!
interface FastEthernet0/0.1652
encapsulation dot1Q 1652
ip address 192.168.227.2 255.255.255.128
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.1368
encapsulation dot1Q 1368
ip address 192.168.12.2 255.255.255.0
!
interface Ethernet1/0
ip address 172.16.25.2 255.255.255.0
half-duplex
!
interface Ethernet1/1
no ip address
shutdown
half-duplex
!
interface Ethernet1/2
no ip address
shutdown
half-duplex
!
interface Ethernet1/3
ip address 172.16.23.2 255.255.255.0
half-duplex
!
!
router eigrp 27
network 172.16.25.0 0.0.0.255
network 192.168.227.0 0.0.0.127
no auto-summary
!
router ospf 1368
log-adjacency-changes
network 192.168.12.2 0.0.0.0 area 1278
network 192.168.27.2 0.0.0.0 area 1278
!
router rip
version 2
network 100.0.0.0
network 172.16.0.0
no auto-summary
!
ip http server
no ip http secure-server
ip forward-protocol nd
!
!
!
!
ip access-list standard blockrip
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4

!
end







R3:
R3-×××-1-2-PE#show run
Building configuration...

Current configuration : 3193 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3-×××-1-2-PE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
ip vrf cus100
rd 3456:100
route-target export 100:800
route-target import 100:800
!
ip vrf cus200
rd 3456:200
route-target export 200:700
route-target import 200:700
!
ip vrf cus800
rd 3456:801
route-target export 700:800
route-target import 700:800
!
ip vrf forwarding
!
multilink bundle-name authenticated
!
!
!
!
!
!
!

!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface Loopback0
ip address 192.168.100.3 255.255.255.255
ip router isis 3456
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Ethernet1/0
ip vrf forwarding cus800
ip address 172.16.38.3 255.255.255.0
half-duplex
!
interface Ethernet1/1
ip vrf forwarding cus100
ip address 172.16.13.3 255.255.255.0
half-duplex
!
interface Ethernet1/2
ip vrf forwarding cus200
ip address 172.16.23.3 255.255.255.0
half-duplex
!
interface Ethernet1/3
ip address 10.0.34.3 255.255.255.0
ip router isis 3456
half-duplex
mpls ip
!
!
router ospf 1368 vrf cus100
router-id 192.168.100.3
log-adjacency-changes
area 0 sham-link 192.168.100.3 192.168.100.6
area 0 sham-link 10.0.34.3 10.0.46.6
redistribute bgp 3456 metric 10 subnets
network 172.16.13.3 0.0.0.0 area 0
!
router isis 3456
net 49.0003.0000.0000.0003.00
is-type level-2-only
!
router rip

address-family ipv4 vrf cus200
redistribute bgp 3456
network 172.16.0.0
default-metric 2
no auto-summary
version 2
exit-address-family
!
router bgp 3456
no synchronization
bgp log-neighbor-changes
neighbor iPE peer-group
neighbor iPE remote-as 3456
neighbor iPE update-source Loopback0
neighbor iPE next-hop-self
neighbor iPE send-community extended
neighbor 192.168.100.5 peer-group iPE
neighbor 192.168.100.6 peer-group iPE
no auto-summary
!
address-family ***v4
neighbor iPE send-community extended
neighbor 192.168.100.5 activate
neighbor 192.168.100.6 activate
exit-address-family
!
address-family ipv4 vrf forwarding
no synchronization
exit-address-family
!
address-family ipv4 vrf cus800
no synchronization
exit-address-family
!
address-family ipv4 vrf cus200
redistribute connected
redistribute static
redistribute rip route-map blockrip
no synchronization
exit-address-family
!
address-family ipv4 vrf cus100
redistribute connected
redistribute ospf 1368 vrf cus100 metric 10 match internal external 1 external 2 nssa-external 1 nssa-external 2
no synchronization
exit-address-family
!
ip http server
no ip http secure-server
ip forward-protocol nd
ip route vrf cus200 100.0.10.0 255.255.255.248 172.16.23.2
!
!
!
!
ip prefix-list blockrip seq 20 permit 172.16.0.0/16 le 20
ip prefix-list blockrip seq 30 permit 172.16.25.0/24
!
route-map blockrip deny 10
match ip address prefix-list blockrip
!
route-map blockrip permit 20
!
!
!
!
control-plane

!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end





R4:
R4-to-PE-3-5-6#show run
Building configuration...

Current configuration : 1446 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4-to-PE-3-5-6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
multilink bundle-name authenticated
!

!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!

interface Loopback0
ip address 192.168.100.4 255.255.255.255
ip router isis 3456
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Ethernet1/0
ip address 10.0.34.4 255.255.255.0
ip router isis 3456
half-duplex
mpls ip
!
interface Ethernet1/1
ip address 10.0.45.4 255.255.255.0
ip router isis 3456
half-duplex
mpls ip
!
interface Ethernet1/2
ip address 10.0.46.4 255.255.255.0
ip router isis 3456
half-duplex
mpls ip
!
interface Ethernet1/3
no ip address
shutdown
half-duplex
!
interface Ethernet2/0
no ip address
shutdown
half-duplex
!
interface Ethernet2/1
no ip address
shutdown
half-duplex
!
interface Ethernet2/2
no ip address
shutdown
half-duplex
!
interface Ethernet2/3
no ip address
shutdown
half-duplex
!
!
router isis 3456
net 49.0004.0000.0000.0004.00
is-type level-2-only
!
ip http server
no ip http secure-server
ip forward-protocol nd
!

!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end







R5:
R5-×××2-3-PE#show run
Building configuration...

Current configuration : 2684 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5-×××2-3-PE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
ip vrf cus200
rd 3456:201
route-target export 100:200
route-target import 100:200
!
ip vrf cus700
rd 3456:700
route-target export 200:700
route-target import 200:700
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive 
log config
hidekeys
!
!
!
!
!
!
!
!
interface Loopback0
ip address 192.168.100.5 255.255.255.255
ip router isis 3456
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Ethernet1/0
ip vrf forwarding cus700
ip address 172.16.57.5 255.255.255.0
half-duplex
!
interface Ethernet1/1
no ip address
shutdown
half-duplex
!
interface Ethernet1/2
ip vrf forwarding cus200
ip vrf sitemap setsoo
ip address 172.16.25.5 255.255.255.0
half-duplex
!
interface Ethernet1/3
ip address 10.0.45.5 255.255.255.0
ip router isis 3456
half-duplex
mpls ip
!
!
router eigrp 555
auto-summary
!
address-family ipv4 vrf cus200
redistribute bgp 3456 metric 1000 10000 255 1 1500
network 172.16.25.0 0.0.0.255
no auto-summary
autonomous-system 27
exit-address-family
!
router isis 3456
net 49.0005.0000.0000.0005.00
is-type level-2-only
!
router bgp 3456
no synchronization
bgp log-neighbor-changes
neighbor iPE peer-group
neighbor iPE remote-as 3456
neighbor iPE update-source Loopback0
neighbor iPE next-hop-self
neighbor iPE send-community extended
neighbor 192.168.100.3 peer-group iPE
neighbor 192.168.100.6 peer-group iPE
no auto-summary
!
address-family ***v4
neighbor iPE send-community extended
neighbor 192.168.100.3 activate
neighbor 192.168.100.6 activate
exit-address-family
!
address-family ipv4 vrf cus700
redistribute connected
neighbor 172.16.57.7 remote-as 700
neighbor 172.16.57.7 activate
no synchronization
exit-address-family
!
address-family ipv4 vrf cus200
redistribute connected
redistribute eigrp 27 metric 50 route-map setextcom
no synchronization
exit-address-family
!
ip http server
no ip http secure-server
ip forward-protocol nd
!
!
!
!
ip prefix-list 227 seq 10 permit 192.168.227.0/25
!
route-map setsoo permit 10
set extcommunity soo 5:27
!
route-map setextcom permit 10
match ip address prefix-list 227
set extcommunity cost igp 44 1234567
!
route-map setextcom permit 20
set extcommunity cost pre-bestpath 15 151515
!
!

!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end




R6:
R6-×××1-3-4-PE#show run
Building configuration...

Current configuration : 2663 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6-×××1-3-4-PE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
ip vrf cus100
rd 3456:101
route-target export 100:200
route-target import 100:200
!
ip vrf cus800
rd 3456:800
route-target export 100:800
route-target import 100:800
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive 
log config
hidekeys
!
!
!
!
!
!
!
!
interface Loopback0
ip address 192.168.100.6 255.255.255.255
ip router isis 3456
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Ethernet1/0
ip vrf forwarding cus800
ip address 172.16.68.6 255.255.255.0
half-duplex
!
interface Ethernet1/1
ip vrf forwarding cus100
ip address 172.16.16.6 255.255.255.0
half-duplex
!
interface Ethernet1/2
no ip address
shutdown
half-duplex
!
interface Ethernet1/3
ip address 10.0.46.6 255.255.255.0
ip router isis 3456
half-duplex
mpls ip 
!
!
router eigrp 666
auto-summary
!
address-family ipv4 vrf cus100
redistribute connected
redistribute bgp 3456 metric 1000 10000 255 1 1500
network 172.16.16.0 0.0.0.255
no auto-summary
autonomous-system 27
exit-address-family
!
router ospf 1368 vrf cus800
router-id 192.168.100.6
log-adjacency-changes
area 0 sham-link 192.168.100.6 192.168.100.3
area 0 sham-link 10.0.46.6 10.0.34.3
redistribute bgp 3456 metric 10 subnets
network 172.16.68.6 0.0.0.0 area 0
!
router isis 3456
net 49.0006.0000.0000.0006.00
is-type level-2-only
!
router bgp 3456
no synchronization
bgp log-neighbor-changes
neighbor iPE peer-group
neighbor iPE remote-as 3456
neighbor iPE update-source Loopback0
neighbor iPE next-hop-self
neighbor iPE send-community extended
neighbor 192.168.100.3 peer-group iPE
neighbor 192.168.100.5 peer-group iPE
no auto-summary
!
address-family ***v4
neighbor iPE send-community extended
neighbor 192.168.100.3 activate
neighbor 192.168.100.5 activate
exit-address-family
!
address-family ipv4 vrf cus800
redistribute connected
redistribute ospf 1368 vrf cus800 metric 10 match internal external 1 external 2 nssa-external 1 nssa-external 2
no synchronization
exit-address-family
!
address-family ipv4 vrf cus100
redistribute connected
redistribute eigrp 27 metric 50
no synchronization
exit-address-family
!
ip http server
no ip http secure-server
ip forward-protocol nd
!
!
!
!
!
!
!
control-plane
!

!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end







R7:
R7-×××2-4-CE#show run
Building configuration...

Current configuration : 1786 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R7-×××2-4-CE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
multilink bundle-name authenticated
!

!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!

interface Loopback0
ip address 192.168.100.7 255.255.255.255
!
interface Loopback100
ip address 100.0.70.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.17
encapsulation dot1Q 1278
ip address 192.168.27.7 255.255.255.0
!
interface FastEthernet0/0.1652
encapsulation dot1Q 1652
ip address 192.168.227.7 255.255.255.128
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.1278
encapsulation dot1Q 1278
ip address 192.168.87.7 255.255.255.0
!
interface FastEthernet0/1.1368
encapsulation dot1Q 1368
ip address 172.16.78.7 255.255.255.0
!
interface Ethernet1/0
ip address 172.16.57.7 255.255.255.0
half-duplex
!
interface Ethernet1/1
no ip address
shutdown
half-duplex
!
interface Ethernet1/2
no ip address
shutdown
half-duplex

interface Ethernet1/3
no ip address
shutdown
half-duplex
!
!
router eigrp 27
network 192.168.87.0
network 192.168.227.0 0.0.0.127
no auto-summary
!
router ospf 1368
log-adjacency-changes
network 172.16.78.7 0.0.0.0 area 1278
network 192.168.27.7 0.0.0.0 area 1278
!
router bgp 700
no synchronization
bgp log-neighbor-changes
network 100.0.70.0 mask 255.255.255.0
neighbor 172.16.57.5 remote-as 3456
no auto-summary

ip http server
no ip http secure-server
ip forward-protocol nd
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end







R8:
R8-×××1-CE-to-R6#show run
Building configuration...

Current configuration : 1772 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R8-×××1-CE-to-R6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
multilink bundle-name authenticated
!

!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!

interface Loopback0
ip address 192.168.100.8 255.255.255.255
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.138
encapsulation dot1Q 138
ip address 192.168.138.8 255.255.255.0
ip router isis 138
!
interface FastEthernet0/0.1652
encapsulation dot1Q 1652
ip address 192.168.118.8 255.255.255.240
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.1278
encapsulation dot1Q 1278
ip vrf sitemap setsoo
ip address 192.168.87.8 255.255.255.0
!
interface FastEthernet0/1.1368
encapsulation dot1Q 1368
ip address 172.16.78.8 255.255.255.0
!
interface Ethernet1/0
ip address 172.16.68.8 255.255.255.0
half-duplex
!
interface Ethernet1/1
no ip address
shutdown
half-duplex
!
interface Ethernet1/2
no ip address
shutdown
half-duplex
!
interface Ethernet1/3
ip address 172.16.38.8 255.255.255.0
ip router isis 138
half-duplex
!
!
router eigrp 27
network 192.168.87.0
network 192.168.118.0 0.0.0.15
no auto-summary
!
router ospf 1368
log-adjacency-changes
network 172.16.68.8 0.0.0.0 area 0
network 172.16.78.8 0.0.0.0 area 1278
!
router isis 138
net 49.0138.0000.0000.0008.00
is-type level-2-only
!
ip http server
no ip http secure-server
ip forward-protocol nd

!
!
!
route-map setsoo permit 10
set extcommunity soo 6:18
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4

!
end